This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

[APP Z-Wave] Danfoss LC12/LC13 Z-Wave devices - Main discussion topic



  • Freezing here..1.0.2. ? 
  • Homey Firmware Versie: 1.0.1

    So.. when firm .2 is released my E5 error will be gone? When is this update planned? It's getting cold here and there :(
  • I have a question. I have the danfoss lc13 and because the homey still cannot not set the temperature, as it did before in the old zwave sollution, i was searching the web.

    I found out that de danfoss lc13 is able to have programs/schedules running himself. So i can program the temperature per day.  But i do not see how i can do that on the device itself. Looks like it has to be done with some sort of tool. Does anyone know how i can do that?

    Also i saw the video on this page

    My danfoss does not look exactly the same if i compare the LCS,  i don't have a time and date to set. Is this an other version?

    Hope someone can help me out 
  • That schedule isn't implemented in the driver of Homey and therefore can not be used (yet).
    On what firmware are you, because other users report that they can use the lc13 with the latest firmware.
  • I am on the latest firmware. And it works when i put my homey in front of the radiator.
    But when i put it in the livingroom it does nog work anymore. The radiator valves are on the second floor. Stupid thing is that before the zwave re-write it worked perfectly.

    Also the danfoss app does not work very good either. Because when you set the temperature and then again set it, it does not show you at what temp you had set it before. That is not very intiutive. You have to wait until the radiator had got the value. He should show you the temp which you have set it to be.

    So i hoped that they would fix it, but does not seem to be @Robert ;
     has contacted me, but after giving him the results of my test, he did not respond anymore. So i don't know if they are working on it. My valves are useless right now. 

    That is why i asked the question how i can program the build in scheduler of the danfos lc13. And does anyone know why my danfos lc13 does not have a date/time function on the display, and the one in the link does have that?

  • It's 16 degrees in my son's bedroom :( 

    Anyone knows when Homey will be able to get rid of the E5 error?
  • I can confirm that the E5 is gone on 1.0.2. It is out on the experimental channel. I think on friday you will get some information from @Emile within his friday software update when to expect 1.0.2 to be stable. 

    If you can't wait you could change to experimental, but be aware that there is a bug that could disable your homey when updating at the moment ( it is not hard to repair it on your own but you need some know-how)
  • I have version 1.02 allready, but for me de danfoss still does not work. As said before, only at near distance it works, but 7 meters away, it does not work.

    I have the danfoss living connect, which is not exactly the same as the danfoss lc-13 i think. But then again, it worked perfect with the old zwave classes.

    Can anyone comfirm that their Danfoss LC13 has time and date option in the LCD display?
    I see this picture and video on this website:

    But at robshop i see a total other danfoss. Which one is the correct one?

    The first one, seems nicer te me, the second looks like de one i have now (lc12).

  • I'll wait ;) 
  • PeaoPeao Member
    edited November 2016
    Thats my LC13
  • The z-wave compatible device is not able to set a schedule through the device itself. The picture on the myhomecenter website is of the non z-wave device.

    For our devices (Danfoss/Devolo) it is possible to set a schedule, but it has to be done through the controller. Homey in our case.

    This is done through the command class COMMAND_CLASS_CLIMATE_CONTROL_SCHEDULE.

    Currently there is no UI available within Homey for that command class. The only way setting the schedule would be possible now, is by adding that functionality to the App. I'm looking into that for the Devolo device.

    By the way, there is an advantage to set the schedule: in that case the device learns based on room size, radiator size, surrounding temperature, when to turn on the heating so that the setpoint temperature is available at the defined time in the schedule. 
  • Thanks for the reactions.
  • msmitsmsmits Member
    edited December 2016
  •  :/  :(
  • Hi team, still running into E5 errors here..

    My Homey Status:

    Systeem Informatie

    Homey Firmware Versie: 1.0.3

    I have removed all LC-13 from the radiators and have them gathered rather close to the Homey.
    I think I see random behaviour in E-5's across 4 LC-13 that are about 1 meter away form each other and about 2 meters away from Homey. 2 units are OK, two are not.

    My first question: 
    What it correct,  E-5 is triggered by the fact that the Z-wave controller cannot be reached or is not answering correctly? While giving this error message I cannot see on the display or a temperature change is executed, unclear what happens under the surface.

    Second question:
    Can I monitor this in any way on Homey doing a debug of the Zwave network for a certain time to see messages coming in?

    And off course....
    The mother of all questions: how to solve this?

    Thanks for any suggestion.
  • For me the Devolo version of the App works well. No E5 anymore.

    Perhaps this is because I added the pollInterval to the driver as per @RobinBolscher 's comment in, which is not in the driver for Danfoss atm.

  • Homeware firmware 1.0.2
    I have finally succeeded in coupling my LC 13. I use flows to set the temperature to day and night values at certain times and that works. After a while I get E5 on the display, but that does not bother me. For now I am satisfied that Homey is now my Z-Wave controller.
    It was a problem coupling the LC13 because before Homey arrived I used a Aeotec Z-stick in my portable PC to control the temperature cycle of the LC13 and that had to be completely undone before Homey could couple. Now I can sell my Z-Stick.
  • @MickVanGool ;
    What is the distance between homey and your lc13 valves? And do you have other zwave stuff which repeats the signal?

    At my place the valves are on the second floor, so about 7 meters and 2 wooden floors away. Since the new zwave rewrite it does not work anymore. Only when i put the homey on the second floor itself. So it seems to me that the signal is weaker since the zwave rewrite.  I have no other zwave device, yet.

    I am curious if your situation is more or less the same
  • Sorry Cannon help you, my LC13 is only 4m away from Homey without obstruction. I have no other Z-wave devices.
  • cannot (spellchecker grrr.)
  • You guys have no issues anymore with the Danfoss LC-13? I have the E5 error every day, need to pull the batteries so it works again for a couple of hours. 

    It drives me nuts....  :s
  • 3 LC-13 paired, rock solid for a couple of weeks (since 10.4) not seen E5 error since!
  • I am having the E5 error again, aswell. Tried the Devolo App but its the same. You can fix the E5 error temporarily when you change the temperature of the thermostat with Homey and manually waking up the thermostat with the button at the same moment. 

    For me the E5 is annoying, aswell. But if you don't change the temperature manually and use Homey instead, it shouldn't bother you that much. The setpoints are recieved correctly as far as I know.
  • 1.0.5 went to stable today so also for people who aren't on experimental the E3 issue should be solved..

  • 1.0.5 went to stable today so also for people who aren't on experimental the E3 issue should be solved..

    Im already on 1.0.5, but still the E5 error. Did a re-pair this morning, in the evening it already had the E5 error.
  • Yep, I am on 1.0.5 since pushed to experimental. In the first days E5 seemed to be solved but unfortunately it came back.
  • Damn, still not working as it should? How can it be so hard?
  • Same issue overhere, after a couple of minutes E5 error. This reminds me of the start with the Fibaro HC2. But with the HC2 is it stable now. However, I really like to make use of the Homey instead of the HC2
  • When is it gonna work, and why is it so hard to make it work?
  • I specially bought the homey because the LC13 is supported. 
Sign In or Register to comment.