This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

[APP Z-Wave] Danfoss LC12/LC13 Z-Wave devices - Main discussion topic



  • Thank you very much for the explanation! These issues are not a show-stopper for me anymore. I can use my thermostats with homey and I don't need to re-check the setpoint anymore because it worked fine for me the last 24h.
  • Great progress here. Thanks!

    I was wondering if this App would also work with the Devolo Home Control Radiatorthermostaat ( or the Popp TRV ( Both are essentially the same as the Danfoss.

    The interesting thing about these devices is that they have a patched firmware which allows them to send back the ACTUAL temperature. Something the Danfoss can not do.

    Can anyone confirm these devices will work also with the Danfoss App?
  • As for now it won't work because only the 2 danfoss and product id are in the driver. If those 2 devices have a danfoss product id then it is possible. I have heared that the devolo has a danfoss id, but that has to be confirmed first.
  • i just love how people think because something looks-a-like that they are the same, but still give a thing themselves that makes them not the same.

    they are a different brands
    devolo has multiple devices, so an own brand thing. and their own app already in app store (even though not the thermostatic is implemented)
    popp (device of this brand already in app store) is a daughter company of Düwi (someone working on app for this brand), also a company that makes different devices..

    don't try to make it more complicated for people by adding different brands into 1 app just because they look-a-like
  • @caseda you are right that would be indeed confusing, so if somebody needs it they can (or ask the developer) adjust the devolo app and have a look at the danfoss app for the additional code.
  • mderumderu Member
    edited October 2016
    Thanks @kasteleman for the constructive answer.

    This helps me in understanding how Apps / Devices work and why a Devolo wouldn't work in a Danfoss App. Through I found out that the PID's indeed are different. What it does mean however, is that it would probably be relatively simple to port your Danfoss code over to the Devolo App.

    My reason to prefer the Devolo is that it sends back the actual temperature, a command class (right?) that the Danfoss does not support. So event though the App would not support it from the start, at least the Devolo has more options for future use.

    Perhaps I can find the time and help integrating both, all though a lot of this is totally new to me. Any pointers (on how to actually test communication with a device, a lot of sample code I can find on github myself) would be appreciated.
  • @mderu: Have a look at the devolo app that is in the store. You can find the code on github. The danfoss app isn't mine (anymore ;) ) that is made by Robin from Athom. You can also find the code on Athom's github. Drop me a personal message if you need any details to get started.
  • When adding a LC13 device I get this error: 

    Cannot GET /app/com.danfoss/drivers/LC13/assets/learnmode.svg

    Is the app broken?
  • arthur said:
    When adding a LC13 device I get this error: 

    Cannot GET /app/com.danfoss/drivers/LC13/assets/learnmode.svg

    Is the app broken?

  • That error message is strange because the learnmode.svg asset is present on the github repo.

    I'm very new here, but probably the app store has it's own copy of the github code which is missing the svg file. Maybe an earlier version?

    You could try to clone the repo (git clone and upload the App manually with the CLI (athom project --run or --install).

    I just forked the original Danfoss App in order to integrate it with the Devolo App, so that it supports the Devolo Home Control Radiator Thermostat. When testing that, I didn't get the errormessage.
  • the error message isn't strange, there really is no learnmode.svg even on the github repo, just because there is a path given in the app.json, doesn't mean the file is really there :wink: 
    there is only the icon in the asset folder of the LC13 driver
  • Hmm, ok so I'm really lost now. I cloned the repo this afternoon and I have both a learnmode.svg and an icon.svg on my local machine... They are both exactly the same.

    Ah... found it. I cloned the repo at instead of

    The former one does have the learnmode.svg... Is this something for Athom to solve?
  • @mderu ;
    that moment he uses 2 of the same links to compare :heart:
    but yes, @kasteleman ;made the initial try, @RobinBolscher ;finished it, but forgot the learnmode.svg (hé he's still human.!?)
  • @Peao
    Did you solve the E5 error? I just encoutered the same problem. Will try a shorter wake up intervall now...
  • PeaoPeao Member
    edited October 2016
    G4nd41f said:
    Did you solve the E5 error? I just encoutered the same problem. Will try a shorter wake up intervall now...
    I just stopped using the thermostats buttons and only adjust the temperature via Homey. You have to wait a bit (depends on your wakeup interval) before you can double check at Homey if the setpoint was recieved by your thermostat. If you open the card immediently it won't be saved.
    It's just a workaround but the error is still present if you try to adjust manually.
  • You mean that you can not adjust the temperature by pushing the buttons on the danfoss? That is, the temperaturechange isn't reported to Homey? My LC works flawless. No problem, tempchance is displayed a few sec later.
  • PeaoPeao Member
    edited October 2016
    Yes this is not working for me :( I can't even change the temperature manually because the thermostat shows this error instantly when you  push a button, and it wont go away. Dunno what causes this, I changed the wakeup interval but it did not help.

    The error means that the thermostat can not connect to Homey. But obviously Homey can send data to the thermostat... It seems to be like a one way street.

    Github issue is created.
  • Did you hold down the "middle" button until the display shows M and then press the left button? Then it should try to reconnect with the controller. How is the distance between the Danfoss and Homey. My Danfoss was also very picky about that until my z-wave mesh network was expanded.
  • Is it working ? Really waiting for this app to work properly.. 
  • I tried it but it didn't work. Still the E5 error. When it shows "L1" and press the middle button the "signal" icon starts blinking but after 3-5 sec the E5 error appears again. 
  • I don't think E5 is a Homey specific error, I've read that other z-wave controllers have the same problem, which indicates to me that it is a device based flaw. Correct me if I'm wrong.
  • For me the danfoss app does not work either, but in this case it must be a homey problem.

    Because een week ago, when i was on firmware 0.8.39 with the "old" zwave classes, it worked fine with homey.

    I did not want to go to 0.10 because at that time the danfoss app was not ready and it is cold outside... But this week the app was ready so i also upgraded homey, removed my old zwave devices and re-connect them with the danfoss app.

    That all seems to work, it did see the device. But setting temperature thru the devices panel, does not seem to work. It does not "remembers" the temperature i just had set. 

    so i tried it with a flow. Same as before, but now i get a red warning sign without further information.

    Maybe it is a range problem, but then again, why can it "see" the device when pairing. And why did it work without app on the old firmware.

    It seems strange to me that some people with the same device can get it to work and some don't.
  • Hi,

    Almost same experience here...
    @ version 0.10.7 using the most actual danfoss update of yesterday I still see E5 on all my devices. And since I'm still in testing phase, the units are not yet installed on the radiators I can see that not all my set point are proccessed on all devices. Note, to avoid zwave  issue's  the devices are less then 2 meters from Homey.

    Any experience to share on troubleshooting and solving the issue?
  • casedacaseda Member
    edited October 2016
    I've said it a few messages back, but let me just say it again for the people that find it hard to read the f*ing manual.!

    the set temperature will only be applied to the danfoss when the thermostatic wakes up on it's own interval or if you wake it up manually, the new app sets that wakeup timer by default to every 5 minutes (if you included it in the latest version of the app)
    So you need to wait a max of 5 minutes before the set temperature gets properly saved inside the thermostatic
    this is something that is not changeable since all battery powered devices work this way
  • Robin said:
    I don't think E5 is a Homey specific error, I've read that other z-wave controllers have the same problem, which indicates to me that it is a device based flaw. Correct me if I'm wrong.
    The manual states to the E5 error: "The thermostat is not receiving the expected replies from the control system. Check that you have a Z-wave certified controller running and it has the necessary functionality to control the thermostat (see “Technical requirements”)."

    Therefore I think that the error is caused by Homey as it is the control system.

    You can find the manual with the Technical requirements right here:

  • @caseda ;

    waiting 5 minutes has nothing to do with the problem i mentioned. It gives an error sign,  and temperature is not set!

    also in the previous app it showed the temperature in homey direct after setting it, also when my danfoss did not recieve it yet.
     That is the way you would want it to be, you want to be able to see to what you have set it.
  • casedacaseda Member
    edited October 2016
    @Pils ;;;
    it receives the "old" value from the valve itself ;) the old version used it's own memory to show what value was set on the valve itself,
    and why do you want to see within 5 minutes on what temperature you had put it on... are you that uncertain about your decisions?

    i would it this way, then i am certain if the valve ever changed its value without having to look on the valve itself.
    especially if you put the wake-up time higher... 5 minutes is way too pulling on the batteries. (high battery usage)

    the error message (E5) is just strange since it receives it's values just fine, both ways
  • @caseda ;

    i dont have an E5 error on my valves, they work perfect manually. That was someone else.

    About wanting to see what has been set. What If my wife is upstairs en checking on her app the temperature set. At my home the danfoss only refreshes once every 25 minutes. So there is a change see wil see nothing set.

    I think It is stupid not to see what has been set, especially because it did work in the older version. And does your thermostat at home also forgets what you set it to? No, it shows both values. Homey could do the same, show in red the color set and in blue if the valve has got them

    Ofcourse you may think otherwise, but showing it my way does not harm you.
  • mmm, both values is a better solution.. add that into a github issue (just normal homey issue) maybe athom can implement it :wink:
Sign In or Register to comment.