This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

[APP Z-Wave] Danfoss LC12/LC13 Z-Wave devices - Main discussion topic

mruitermruiter Member
edited September 2017 in Apps

Danfoss LC12 / LC13

Current Version : Pending

Athom Apps store:
Github repository:

Supported Devices:

  • Danfoss LC-13
  • Danfoss LC-12

Supported Languages:

  • English
  • Dutch


  • Hi guys,

    I'm wondering if there is anybody who's interrested in making a app for "Danfoss Living connect Radiator Thermostat (LC-13)".

    I want to create one myself but I realy don't know where to start #ubernewbie

    happy easter!
  • Why do you need a app fir the lc13? 
  • Standard Homey z-wave protocol doesn't work for this thermostat. So i want to create an app for all its features with the right classes.
  • PandaPanda Member
    The problem is that the lc-13 doesn't return temperature value, you can only set a setpoint
  • Temperature value is returning correctly but after al while it returns E5. That means that homey and danfoss aren't communicating the same. I want to use danfoss standard classes to program an app but i don't know how :smile: 
  • As far as i know, you can only set the wake-up interval ( the interval the setpoint is reported) and you can set the setpoint. That's also with other domoticasystems as far as i know. Don't count on the rest. For sure not within à few months. @Taco can you conform this?
  • PeaoPeao Member
    Mine worked perfekt in .23 but after .24 the E5 error promted after a while.
  • TacoTaco Member
    At the office I can use the Danfoss without issues. I'm not aware of an "E5" error, could you explain?
  • PeaoPeao Member
    It seemed i solved the problem with a reset of homey, now everything is working as supposed.
  • PeaoPeao Member
    Unfortunately the E5 error came back :neutral:  but i think it is related to .27, E5 means that the LC-13 can't communicate with the HUB. But after .27 non of my Z-Wave stuff seems sending data to Homey, my thermostats, danalock and my fibaro sensors stoped to react / are not showing data (temperature/lux/movement).  E.g. the Sensors are still aviable but show now numbers under the Icons.
  • PeaoPeao Member
    A factory reset (including wipe) fixed it. Everything is working perfect :smiley: 
  • Factory reset of the....... LC-13 or the Homey??
  • PeaoPeao Member
    edited April 2016
    Of homey. But its easy and fast. Make sure to make a screenshot of your flows. 

    I tried a wifi recovery before ( no wipe ) but this haven't had any effect.

    If you have a similar problem, you could maybe help under .
  • Thanx!
    I'm sorry, still waiting for my Homey. But the LC-13 and/or Honeywell valves are in the picture to regulate my temperature in every room. So very interested whats going on. When received I will join the conversation with some more detail :smile: 

  • PeaoPeao Member
    Allright! I hope you don't have to wait that long :smile: 

    My LC-13 work like a charm right now, no problems after the wipe.
    The only downside is that the themostats itself does not support sending the messured temperature back to homey (If you change the temperature at the thermostat it will send the new setpoint to homey, though). But I don't need this feature because I've got fibaro multisensors in my rooms messuring the temperature.
  • Just had the mail, shipping date 18 th april :wink: 
    so going to order a LC-13 and Honeywell valve. Have to see if I have to change the adapter on mij system. 
    Found the Fibaro motionsensor. Great was looking for some kind of combined sensor.  
    Thanx again
  • Does anybody know if the Lc-12 danfoss are working ?
    I can get a couple cheap. Do these work ?
  • Don't know for sure. They work in my current situation with a Aeon S2 stick. I have to wait a few weeks and then i can confirm.....I expect them to work, but don't pin me on that! ;)
  • If I'm not mistaking @marcof used to use them (or the Honeywells, not sure) maybe he can comment on how well they work.
  • We had the Homeywell Evohome with HR80 knobs and after that I got the Vera3 with LC-13's.
    Evohome has a really great OOTB experience and work VERY good, but the HR80 knobs makes some noise (my wife complained so i removed it from the bedroom).
    The LC-13's doesn't support room-temp, are (very) quiet, but i have no idea if and how it works with Homey.
    For my Vera3 i had to program some stuff such as room temp <> LC13 to get some thing work.
  • OGSOGS Member
    Do the LC13 still work with the latest firmware or is an app neccesary?
    If yes is someone planning on making one?
  • Yes, there is a app required. Already did a first attemp for a app, but at this moment don't get the setpoint to work. Already talked with Robin about it. I ask Emile as soon as he is back from  holliday for advice
  • It is getting cold in here :wink: 

    Any updates?
  • Jip i know. Didn't make any progress
  • Any progress yet? =)
  • Strange. At my home the Danfoss LC13 works fine. I have firmware 0.8.39. Sometime it shows up as an broken arrow, but after a reset of zware from the settings menu, it works again. It shows up in my iphone  and i can (see?) and set the temperature. Also on the webbased devices tab i can set the temperature. Why you need an app for that? See pictures below:

  • That's with the "old" firmware and zwave driver. In the zwave rewrite, you need a seperate zwave app for it.
    Made no progress. Had to much troubles lately with the released firmwares (that seems to be solved now with .10.2 :smiley: ) and was working on Qubino app (flush dimmer with temperature sensor connected). Hope to find some time for it and understand how to get the setpoint value.
  • @kasteleman ;
    i've been working on another z-wave thermostat type device, and came to the conclusion that it isn't properly implemented yet, at least the version the thermostat setpoint i used, wanted still a lot of Buffer values, and can't get one of the "Level" values right, the same is for the thermostat mode CC.
    no real conclusive answer gotten yet

    @Robin didn't know (yet) as he hadn't tried to include a device with thermostat setpoint yet
  • Confirmation has been given that the command classes that we need to use aren't implemented (completely) yet, at least not far enough to be able to be used.

    So we have to wait until we can create drivers for thermostat/thermostatic type devices.

    E.T.A. as fast as it can be done.
  • That makes me a very disappointed and a bit angry too!
    The temperatures are dropping outside, this is just the moment i want to control my danfoss LC13. In mijn current 0.8.39 firmware it works pretty fine. They promised a complete rewrite of zwave which would be better. But if the new version can not do at least the same as the old version, then they should NOT release that as a stable version. Now do i have to uncheck the automatic update feature? That is not what i want. I am curious what @Emile has to say about this.

    When will the zwave danfoss LC13 will be working again in the new firmware? May, June or maybe in summer when i use it the most...  
Sign In or Register to comment.