This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

[APP Z-Wave] Danfoss LC12/LC13 Z-Wave devices - Main discussion topic



  • Glad we agree
  • On the Devolo (comparable device) I also get the E5 error now.
    After inclusion it works, I can read out the temperature, set it from the device and click the middle button for wakeup. Then it sends the setpoint back to Homey.
    However, the antenna and bell symbol keep flashing. And after a longer time it goes into E5.

    When I don't click the middle button, no update is sent.

    From the documentation (
    This device will wakeup regularly and announce the wakeup state by sending out a so called Wakeup Notification. The controller can then empty the mailbox. 

    Could it be that the Wakeup Notification is not sent by the Danfoss/Devolo? Perhaps because it is not being set by Homey? Is there a way to force this through the driver?

    I ask this because when I click the middle button, it forces sending a Wake Notification. And it indeed triggers Homey to read out and clear the "mailbox".
  • I have the same problem with the E5 error. It does seem to work though, although I cannot see on the device itself where it was set on and cannot change it there. From what I understand from reading up on the issue, it is a problem in the communication.

    I do not think it is the distance, my homey is less than 1.5 meter away and there is nothing blocking in between. So probably there is something wrong in handling the device. The problem did not occur before, when homey did not use apps, so I also do not think there is something wrong with my device (it is the same one).

    Would be nice to have this resolved.
  • Using CLI I tried to understand what was going on in the communication verses what the documentation says the device expects.

    The docs state:
    This device will wakeup regularly and announce the wakeup state by sending out a so called Wakeup Notification. The controller can then empty the mailbox. Therefore, the device needs to be configured with the desired wakeup interval and the node ID of the controller

    The nodeID set in the WAKE_UP_INTERVAL_SET command must be for a permanently listening device which reponds to the commands sent from living connect® . 

    The way to enable this seems to be by using the COMMAND_CLASS_WAKE_UP.

    However, nowhere in the logging from CLI, I see any WAKE_UP command coming by. So, either Homey sends the correct WAKE_UP_INTERVAL_SET and we don't see it. Or Homey doesn't send it which is why the device goes into E5 error.

    - Can someone confirm that Homey indeed sends the right WAKE_UP_INTERVAL_SET, but we don't see it?
    - Is there a method that gets called when the device is online in Homey which allows me to sends that command manually? And how to send it manually?
  •  i think you are reading the manual backwards, homey needs to GET all data from the device, as soon as the device wakes-up/is awake/sends it's wake_up notification.

    the "wake-up interval set" is being handelend by the core, we developers can't see the data homey sends to the module... which only consists of timing data (and is send correctly, the device does change it's wake-up interval when you have send the wake-up interval)

    homey also receives the wake-up notification (also the .on('online') trigger/listener)
    at the moment we developers need to specify our selves that all info needs to be GET when the trigger gets triggered, so it's not really the mistake of homey, but something the developer needs to implement.

    at the moment it is being done with the "interval" tag, but that won't work cause it will only send it's data when awake (or it's just luck that the interval triggers when it's awake)

    i'm thinking about adding a "get_on_awake" function in the z-wave driver, but that will take some time to build/code and time... well so many other projects at the moment that i want to do first before things like this.

    i'm writing a small script for "when awake get measure_battery capability", for the obvious reason to get battery level when module is awake, you could use that script when it's finished to get all the capabilities from the module.
  • Any updates on this? It's getting cold here hehe  :#
  • Mine works. Happy. Thanks. 
  • @LuukvD; You dont have the E5 error? Installed the Danfoss today but after a couple of hours the error appeared.
  • If I understand correctly, for the Danfoss to really work well the Homey App has to make sure to empty the "mailbox" of the device after it sent a wake-up-notification to Homey.

    It seems this function is currently not implemented yet in Homey.

    Suggestion for the Homey developers:

    There is now already a pollInterval option it seems, could you allow a value like "onWakeUp" instead of just a number of seconds value?

    That way, we could add this value to the implementation of the measure_battery command class to make sure we communicate with the Danfoss like it expects.
  • get_on_wake_up is currently not working for this very purpose, already tried it :smile:

    it's got something to do with the MAILBOX CC (in homey's core), have not looked into it too much but it seems like homey does not send it's "ACK" signal back when info has been received/send, maybe because we developers need to implemented that our selves.
  • @caseda you clearly have quite some experience at z-wave in general and Homey. Is there a way we can reach out to the developers at Homey in order to prioritize solving this somehow? The Danfoss devices (and it's siblings) are kind of standard in the area of Multi Zone Heating. So a solution would be great!

    I'd be happy to participate in developing /  testing / updating the driver for Danfoss et al.
  • They have a very nerdy way of getting things prioritized, send them cupcakes (or any thing else a like)

    It is not breaking any thing (it just doesn't work, and might even be the app developers mistake) 
    So won't be very high on their list,  it will help if they know where to look (not just a hunch)
    Or if they (emile) is working in that area (zwave) anyway. 

    So second best way to get it prioritized, gather as much information as possible, not just "it doesn't work" or "I get error E5" 
    all information non in-homey and in-homey related to this issue. And see if there is a resemblance somewhere, create your github issue with that. 
  • @Annemarie emailed me a week ago and told me they found the problem and had it solved. It worked at their place. She also asked if I wanted to test it.

    But there is no new version released then, only experimental, so I could not test. 

    So so I asked her how to test and with what version, but no response for more than a week now.

    so they are working on it apparently 

  • @Pils ;
    You probably need to a new homey update to have the fix working, so for now you have to wait until at least that :wink:
  • Yes i know. But if you guys are on the newest experimental release and still have problems, them they did not fix it apparently.

    hope @Annemarie can tell us more about it. It is getting cold, so we need the danfoss pretty soon.
  • Yes, I got my homey to set the tempature of one of my LC13's to 25 degrees. That's just one. Till now I didn't manage to add the others. Probably means I have got to move my homey trought my entire house to get them to pair? There is a ZWave repeater here upstairs.. but that doens't work I guess. 
  • Next step is an easy working app for an easy working opentherm gateway. So non-nerds like can get zoneheating really to work. 
  • LuukvD said:
    Yes, I got my homey to set the tempature of one of my LC13's to 25 degrees. That's just one. Till now I didn't manage to add the others. Probably means I have got to move my homey trought my entire house to get them to pair? There is a ZWave repeater here upstairs.. but that doens't work I guess. 
    You can easily  remove them from your radiator and then pair them nearby Homey ?

    @pils Maybe fw 0.11? 
  • Or 1.0.0

  • Doesn't work for me. I thought they did, but nothing happens. Adding the LC13's to Homey is easy. But I gave them all the order : at 11, set temp to 25 degrees. Nothing happens. Same to all other rooms, I set different times and temps, nothing. They all stay at 53 degrees. Wakeup interval 300. 

  • Have the same issue since 1.0.1. Wakeup time is set to 1800 but the temperature isnt set anymore.
  • Really too bad. Was really hoping this would work now. 
  • Hi,

    I also have the E5 error which does break the working of the thermostat because I can't change the settings on the knob itself. Pairing works like a charm. After a while all (6) of my thermostat knobs show an E5 error.
    After a repair the same happens.
  • @developers

    Are you guys working on fixes for the Danfoss LC-13 radiators? I like to buy a Homey but untill it works 100% with the Danfoss I won't as that is a too expensive investment.

    So please fix the battery drain and the E5 errors.

  • I've been working on a dedicated version for the Devolo (essentially the same, with the same errors) for a while in order to develop and test. It's here:

    I've tried several options like explicitly adding a pollInterval.

    The thing that doesn't help is the lack of documentation on how to use the Homey API and also on the Danfoss itself.

    So I added my findings to the issue tracking of Homey:

    I hope the Athom devs can quickly come back with a suggestion on how to solve the issue. Currently I'm not sure it is something we can fix in the App itself.
  • Thanks for your Response..

    Otherwise, are there no other radiators that are working better? Like the eurotronic devices by example? They are even cheaper and are working with other Home automation Systems aswell..

    Any sugestions?
  • Ohh... E5. I read '53' the whole time. Thought it was the default setting or something. 

    Well, I got the E5 error too then. 

    Thing is.. one radiatoren does has the E5 error, but isn't connect to the homey, and that one is always wayyy hotter then the others. Strange. 

    I mainly bought the Homey for my heating problem.. so please! fix it :)
  • We are working on it! May have found a fix, but will need a homey firmware update to fix it, to be continued.. 
  • Thanks a lot Robin for giving feedback. Good to know it's being worked on.
    If you need any more feedback, input or testing, please let me know or give me a PM.
  • E5 is fixed after 1.0.2. gj!
Sign In or Register to comment.