This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

TKB Home ZWave App (request for..)



  • @caseda
    Thanks for your clarification.. but it does leave me puzzled..
    When adding your recently added Zwave Plus dimmer I accidentally (and repeatedly, like 5-6 times) selected the wrong device in the app.  Every time it failed to complete the pairing process at step 8 or 9 of 12 of the process. Pairing was done next to Homey (1 meter) on every try.. 
    After discovering my error and selecting the right device in the app, pairing was a breeze and on the first try..

    If i'm reading your message correctly this shouldn't be possible..

  • casedacaseda Member
    edited February 2017
    @DenW that is correct. 
    Must be a weird coincidence that it went wrong for the times you selected the wrong one.

    And I think it was outside interference in your case,
    the looking up,  if the id is supported by an app, is only done at the end. So after those steps.

    The first steps in the order is always the same for every device, getting command classes etc.
  • app has just updated to 1.0.2.

    fix the dimming flow cards
    fix id's of TZ36 and TZ56
  • @caseda,
    thanks, I tried it immediately, i can now program the second button from my TZ36D.
    but... it works only from the test button in the flow. Not directly from the switch itself. I noticed one thing: at the "apparaten" page, the image of the switch is not as clear as the others. The image is fuzy. I rebooted the homey, removed the the switch and added it again. Reset the switch, nothing seems to help. Do you have advice?
  • One thing I didn't try yet... to remove the tkb app completely and reinstall it. I will try that tomorrow.
  • casedacaseda Member
    edited February 2017
    TKB is pretty known that they don't follow the rules ... at all, so it might be that they changed something in that device, unlike all the other TKB devices that worked completely the same up until now.

    could you go into settings -> z-wave -> stuff for geeks, and then in the log see if anything comes in at all when you are pressing the buttons on the switch, with a small delay between each press.

    if so copy that here, or better, in a PM/DM to me.

    But I don't know what you mean with "fuzzy", are you sure you are in 100% scale if you are using chrome?
    if that is the case, or if you are using the desktop app, could you send a screen capture from that?
  • Ok. I've send you a pm
  • casedacaseda Member
    edited April 2017
    App Update 1.0.3 has just been submitted for approval.

    this will fix the right switch for the people that it didn't work for (anymore) make sure you read the changelog about the change and what you need to check. (association groups)
    Also updated most icons to make them better visible inside homey.
  • casedacaseda Member
    edited April 2017
    I made a small mistake in the driver for the TZ66 which makes the app crash if you have this device.
    (the reason why i did not spot the issue before sending it in, since i do not have this device.)
    already fixed it but can't seem to send it in to athom because of an error in the app-store.

    doing everything i can to get it fixed as soon as possible, my apologies for the inconvenience.

    EDIT: 1.0.4 should fix any crashes that came in, and is now available in the appstore
  • zimbrazimbra Member
    Hi caseda,

    I have a TZ88. In the previous versions it was not supported but I was able to add it as a general z wave device.
    Since it's now supported in the new version of the tkbhome app I unpaired it and now I'm trying to pair it again.
    After retrying like 50 times homey will now detect the device, retrieve 8/8 components (sometimes it also crashes during this process).
    In the next step you can choose if it's a lamp or a general device but when I click next I get the following error:

  • casedacaseda Member
    @zimbra Sorry my mistake, accidentally used the wrong capability name (measure_amperage vs measure_current like it should be) think i need a new pair of glasses

    will send in the fix to the appstore as we speak, sorry for the inconvenience
  • zimbrazimbra Member
    Ok thanks for the quick fix ;) I will let you know if it works!
  • I bought two wall dimmers (TZ67G, Z-Wave Plus) but they show up as generic devices.

    Here are the device details:

    Could you add this device to your app?
  • casedacaseda Member
    edited January 2018
    already on my todo list for some time now, wanted to do this when converting to the new SDK version (though lacked a bit too much of the thing called time, now do have time in the evenings) which is next up after the app i'm currently converting (eurotronic), hopefully soon-ish, as it is a bit of a learning curve.
  • Is there anything new compared to the driver you already have in your app? Seems like it's just the manufacturer's ID that has changed (which seems odd to me, does this happen a lot in this zwave scene? - I'm a newbie). Really hope you can push this in small update - would love to dim my lights soon ;)
  • casedacaseda Member
    edited January 2018
    All three id's are different if I'm right (the manufacturer id is a horrible mistake tkb made (65535 = invalid manufacturer), and should never have happend).
    But yes, this is mandatory for every zwave device having a separate id's (even though some manufactures don't, which is bad... Really bad)

    But don't worry, made good progress yesterday on the other app.
    And do this in my own spare time, be aware of that :wink: (don't work for athom or anything)

    I don't wanna rely on just adding the id's especially for this brand.
    Did that before, and caused some trouble down the road.
    The one already added is I think non zwave plus, this version is zwave plus for example.
  • Product Type ID and Product ID are similar to your current TZ67-PLUS driver config ( Anyhow, I will patiently await your update (I could create a pull request if you like).
  • vaderagvaderag Member
    edited April 2018
    Been intermittently getting this error with my TKB plug - any ideas?

    Doesn't work in flows either. Have tried rebooting the plug and homey...
  • have seen this,  did re-add device  and all good. 

  • djesko said:
    have seen this,  did re-add device  and all good. 

    Can you tell me how to do this?
    My instructions say the On/Off button to include/exclude - i'm putting Homey to exclude mode and pressing the button but it just changes the colour of the led and homey fails exclusion
  • djesko said:
    have seen this,  did re-add device  and all good. 

    Managed to remove and re-add (triple press fyi), but after working briefly the issue has re-occurred.

    At a loss now

    Any more thoughts?
  • vaderag said:
    Pleasedjesko said:
    have seen this,  did re-add device  and all good. 

    Managed to remove and re-add (triple press fyi), but after working briefly the issue has re-occurred.

    At a loss now

    Any more thoughts?
    vaderag said:
    djesko said:
    have seen this,  did re-add device  and all good. 

    Managed to remove and re-add (triple press fyi), but after working briefly the issue has re-occurred.

    At a loss now

    Any more thoughts?
    Surely someone here has a suggestion??
  • Problem with TKB Home TZ55-S

    When I want to add the TKB Home TZ55-S single dimmer to Homey I get the following message 'No suitable homey app was found for this device'. Now I can not dim my light. Only on/off is possible, because homey uses an default z-wave device.

    Am I doing something wrong? The TZ55 in in the list of compatible devices at TKB Home.
  • hullumhullum Unconfirmed, Member
    I've just installed my TZ55D and i run into the following issue: the right button only works in the flow when i select the option 'is switched 2 times'.  When i select the regular ' is switched on' it does not respond to anything.

    Strange thing is that (even with the option switched 2 times on) i only have to click it once for the button to work... Is this a known issue 
  • @hullum this is a known issue (for some people), there are 2 types of switches floating around (not just the 55D, other types have the same, now know of 3 type that do this) one with the behavior in the app and some that have your behavior. 
    As there is no way for me to know which one you have, it is pretty much impossible to fix fully.

    Tkb is just a REALLY bad zwave manufacturer. 

    They make so many mistakes, their license should be taken away by the Z-Wave Alliance, but alas they won't.
Sign In or Register to comment.