This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

[APP] LG SmartTV



  • phil_sphil_s Member
    i will test it @jorden and will give you my webOS-version if i am at home in the evening.
    thank you!

  • @jorden  :Still running 0.1.2 version, and it works great

    LG.jpg 615.7K
  • phil_sphil_s Member
    edited June 2016
    My webOS version is

    with version 0.1.3: error connection refused. i thing my tv has every time another port?
    for example: log-> discovery... {... "port: 48086"}, or is this a other port?

    ok, it was a try ;-)
  • jordenjorden Member
    I actually made an error with the v2 button, it still linked to the old request method... just got it fixed on Github if anyone wants to try.
  • phil_sphil_s Member
    edited June 2016
    i will when i am at home ;-)
    i don't give up  ;)

    but when my webOS say it is version 1.4.0-2515(afro-ashley) does it mean it must work with V1?
    then it won't work...

    i will see...
  • jordenjorden Member
    @phil_s no I only named it v2 because it was my 'version 2 of testing' :)
  • phil_sphil_s Member
    I came just home. To late i am going to bed but i will test it in the morning...
  • phil_sphil_s Member
    no luck ;-(
    same errors as before.

    but from iphone apps like "lg remote tv plus" or other apps which can pair with my tv there is no problem.
    once it will pair with homey, it is just a question of time ;-)
  • jordenjorden Member
    @phil_s could you still show the logs of the app when pressing the v2 button? Just curious if it goes to the correct function now (it did in my final tests).
  • phil_sphil_s Member
    Ok i will test it and show the logs when i am at home
  • I changed the title of this topic to [app] LG smartTV
  • phil_sphil_s Member
    edited June 2016
    ther is my log when i run athon cli.
    ip ...24 is m LGtv and ip ...77 is my philips hue.

    the first scrennshot of the log shows the part before i request a pairing key. there you can see my tv (
    and then there is my philips hue ( with more logs so i must scroll down and make e new screenshot from the error connection when i try to connect.

    this is when i press the v2 button
  • jordenjorden Member
    Well at least it executes the correct function. Something else is going wrong. Will continue work on this ( @jeroenbos22 is going to help a little by making a little PHP script for his TV this weekend, this is going to help bigtime).
  • phil_sphil_s Member
    edited June 2016
    great to hear that you guys don't give up! 
    i do research by google, but i didn't find a hint why it won't work.
    and normal ios apps can pair without a problem...

    have a nice weekend :-)

  • MarcoFMarcoF Member
    How could the php script solve this issue? I'm also experiencing connection refused/timeout with my TV and not seeing a solution. 
    Only thing is that after a reboot everything works for a few hours. 

    Love to see a solution and if I can help: let me know! 
  • jordenjorden Member
    @MarcoF he has a script running that works for his tv. So if I can see how that is working, I can probably see what I am doing wrong with this app. 
  • MarcoFMarcoF Member
  • MarcoFMarcoF Member
    Did you guys get any further with this issue?
  • phil_sphil_s Member
    edited June 2016
    I think i know which php-scripts are Talking about. There are only  two when you google. I testet both and nothing worked for me.  So i give up, Even when there Must be a Solution, because apps from iPhone can pair.  But i don't believe that someone will get behind this mysterium.
  • phil_sphil_s Member
    any news?
  • jordenjorden Member
    Nothing yet, I'll put some pressure on it :)
  • jordenjorden Member
    No progress yet with the PHP-scripts, they also stopped working for @jeroenbos22 ;  :|
  • phil_sphil_s Member
    It is a real black hole. No idea if a solution exists. Thx jorden!
  • phil_sphil_s Member
    i have contact with my lg tv (55lb730)! LOL

    i found a german forum where a two php files (a php-class and a php-file to execute) can interact with my tv.
    first i have to klick yes on my tv after executing the script and then it displays soma words which are coded somewhere in the scripts. it works!

    after this first call it display differnt parameters of the tv. there is an "LG Client-Key successfully received"-key that must be placed in the testscript for the second time and then the connection is established.

    here is the link to the german thread:öffentlicher-bereich/gebäudetechnik-ohne-knx-eib/823383-ip-control-der-neuen-lg-webos-tv-s

    there is a fault in the pasted code (you must replace the first doublequodes with ticks or backslash all qoudes after the starting and ending quodes).

    i have the scripts wotking here and could send it to you @jorden via email if you are interestet in.

  • jordenjorden Member
    Please send it to and I will have a look!
  • phil_sphil_s Member
    jorden said:
    Please send it to and I will have a look!
  • any help required with testing? :) anxiously awaiting the app to controll my LG tv (670 version)
  • NPetersNPeters Member
    edited July 2016
    I've tried the app a couple of minutes ago, but it doesn't work for the LB630v.

    After installing the app, trying to add to devices, i needed to pair the TV with the APP. It finds the TV with the correct IP-address but requesting a pairing key gives me an error message: 

    Error: {"message":"connect ECONNREFUSED","code":"ECONNREFUSED","errno":"ECONNREFUSED","syscall":"connect","address":"","port":8080}

    The TV accepts LG connect apps.

    Thanks for your work, would be great to get it working!
  • phil_sphil_s Member
    @NPeters i have a LB730v and it won't work with the exact errors you have.  There is no way at the moment to get it working, sorry!
  • That might work, web-os is the new version but I have the feeling they rebuild it (and documented it very poorly :smile: 
    ), because it worked before but now its not working as documented by LG. Maybe they made the pairing process uniform, my type of tv was released just a year before web-os came alive. Lets hope it works, I will also give it a shot @jorden ! #neverGiveUp

Sign In or Register to comment.