Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.
Closed Solved

[Solved] Geo location doesn't load

roel_hendrroel_hendr Member
edited October 25 in Archive
Hi,

In the settings of Homey there is Location. When I click it, nothing happens. See screenshot...

Can someone help me with this?

Also when I ask Homey the current time, its wrong. Its 2 hours earlier according to Homey. Don't know if this is related to the problem about location?

Tagged:
«1

Comments

  • GeurtDijkerGeurtDijker Moderator, Backer - Geek Edition
    edited August 12
    @roel_hendr
    @zowieke
    At this moment it is (remote ) working for me.
    Don't know if 3 hours ago Google Maps or the API has had an hick up.... (why else you both have problem while it is working correct for weeks/months)

    Your time on Homey, seen from Settings - System - Stuff for geeks!
    is that date 2 hours before?
    Nice That's ZULU time ;-) that is correct!

    If date_human is 2 hours earlier maybe your Homey doesn't get the correct time! 
    Does your Router provide a NTP time server? maybe check!

    Pls restart homey once by pulling the plug, power-up and look at it after everything is loaded.
  • Restarting homey doesn't work.

    This is a screenshot from my Stuff for geeks:



    At the moment of the screenshot the time is about 09:10 on my laptop.

  • @GeurtDijker
    Thank you for your reply.

    Tried this morning again, with same result. Page is still not showing up, only the loading icon is visible.

    Restarted Homey yesterday 4 times with no solution. Restarted Homey again this morning, again no solution.

    About the time:
    Yes, the date is GMT.
    But the date_human is also GMT, while it should be GMT+1 DST.
    Like @roel_hendr mentioned, if you ask Homey the time it is 2 hours early.
    My router does not have an NTP server. There is no active NTP server on my network.

    Also I do not block Google, Google API's or Google Maps in any way on my network.

    When i open the page and check the console in Chrome, it gives me the errors and warning below.
    When i try to open the mentioned URL with HTTP-500 error, it gives me status: 500, result: unknown_location


    I'm in The Netherlands, my location can be found by any device in this house or neighborhood.


    Is there any way to fix this? Can i SSH into Homey to change the settings?

    Thank you in advance.
  • For me it is fixed. Took me a little time to figure out how the dashboard works, but got it fixed.
    Location, timezone and time are set correctly now.

    @roel_hendr
    If you want to fix your issue too:
    You will need a browser like Chrome or Firefox.
    Open the Location settings page.
    Press F12 to open the console.
    On the console enter the following:
    Homey.api("PUT","/",{latitude:52.3702157,longitude:4.8951679,mode:"manual"})
    Confirm with Enter. When you reload the page, it should load correctly and have set your location to Amsterdam. From here you can change the setting and your location if preferred.

    Hope this helps.
  • GeurtDijkerGeurtDijker Moderator, Backer - Geek Edition
    Great! Thanks for your update! @zowieke
    Where did you find that API command? I am learning here....

    I see you both joined recent, was this after the first setup?
    I guess the location  has never worked before on your Homey?
    For both, what version homey you run?  
    I see the latest stable v1.3.1 for @roel_hendr for you the same?
    Maybe this is a new issue in that stable. 
    Did you already looked how to report issues on github?

    @roel_hendr if you didn't fix it yet, pls go to system settings and send logs. Pls report the log number here or in an github issue. And maybe a second log after the fix if it works for you. 

    And for @zowieke the same but only logs  after :-)

    @bram (Athom's support and  commuity manager), do you know if this is an known issue? Pls ask the responsible developer to read this issue above! 

  • GeurtDijkerGeurtDijker Moderator, Backer - Geek Edition
    O, and btw... you can't ssh into Homey.... only Athom after inviting them to your Homey can enable it and have key pairs to remote troubleshoot on Homey's Linux operating system. 
  • First setup yes,

    I send the logs before the fix, I received log number: 0D8190B402. When applying the fix @zowieke
    mentioned I see following:


    After reloading the page it still doesn't work :(

  • bvdbosbvdbos Moderator, Backer - Geek Edition
  • When I look at System -> Stuff for geeks I also see my timezone is empty. I see a very old discussion here: https://forum.athom.com/discussion/1217/time-zone.

    Does this ring a bell for you experts?
  • When I send following command:

    Homey.api("PUT","/manager/geolocation/",{latitude:52.3702157,longitude:4.8951679,mode:"manual"})

    And reload the page I get following:


    Only when I then choose for "Vind mijn locatie automatisch", it shows following:


    The map stays blurred and never returns. Can it be something related to GPS inside Homey?

  • When I choose manual mode my timezone is also correct, Homey uses the right time again and I can also use speech via the Homey App. So looks like I can continue my voyage with Homey :). Only thing which remains is that I cannot set the option to find my location automatically. This is maybe something you should look into.
  • bvdbosbvdbos Moderator, Backer - Geek Edition
    See above, that's a known issue for now. On which firmware are you?
  • 1.3.1
  • bvdbosbvdbos Moderator, Backer - Geek Edition
    Ok, could you add that to the GH-issue so Athom knows it's not an issue with FW1.5. Also, could you add you got a blank page at first. This means if no previous location is set the page won't load. That means it has a really high priority!
  • @GeurtDijker Found the API command in the scripts on the page.
    I use JavaScript a lot for work, so i know a little how it works <span>:smile:</span>

    @roel_hendr I see you got it working. If the page loads, it's what you want. You should then be able to do the settings, like automatic location or manual, and if manual select a location (map not blurred, only blurred when automatic location is selected).

    @bvdbos I had the issue in both 1.3.1 and 1.5.0 RC5, so it is not an issue with FW 1.5.
    In my opinion, when setup is complete and no location is set, the page should always load and ask one for the location to set (or choose automatic). Perhaps include it in the setup procedure.

    I am now on 1.3.1 and can select my location and settings for location.
    I do not have the issue with a blurred map when i select manual location. So the referenced issue does not apply to my configuration.
  • klaasklaas Member
    Hi,

    In the settings of Homey there is Location. When I click it, nothing happens. See screenshot...

    Can someone help me with this?

    Also when I ask Homey the current time, its wrong. Its 2 hours earlier according to Homey. Don't know if this is related to the problem about location?


  • klaasklaas Member
    Hi,

    In the settings of Homey there is Location. When I click it, nothing happens. See screenshot...

    Can someone help me with this?

    Also when I ask Homey the current time, its wrong. Its 2 hours earlier according to Homey. Don't know if this is related to the problem about location?


    Hi,

    In the settings of Homey there is Location. When I click it, nothing happens. See screenshot...

    Can someone help me with this?

    Also when I ask Homey the current time, its wrong. Its 2 hours earlier according to Homey. Don't know if this is related to the problem about location?


    @roel_hendr
    @zowieke
    At this moment it is (remote ) working for me.
    Don't know if 3 hours ago Google Maps or the API has had an hick up.... (why else you both have problem while it is working correct for weeks/months)

    Your time on Homey, seen from Settings - System - Stuff for geeks!
    is that date 2 hours before?
    Nice That's ZULU time ;-) that is correct!

    If date_human is 2 hours earlier maybe your Homey doesn't get the correct time! 
    Does your Router provide a NTP time server? maybe check!

    Pls restart homey once by pulling the plug, power-up and look at it after everything is loaded.

    I have the same problems !
  • @klaas Try the same trick i used. It's explained above.

    As @roel_hendr mentioned it seems maybe not to work.
    If this is the case, right click on the main part of the webpage (where the loading icon is) and select "Inspect". The Developers Tools will switch to Elements tab, change back to Console and try again.
    This worked for me.

    When done, reload your entire webpage.
  • klaasklaas Member
    zowieke said:
    @klaas Try the same trick i used. It's explained above.

    As @roel_hendr mentioned it seems maybe not to work.
    If this is the case, right click on the main part of the webpage (where the loading icon is) and select "Inspect". The Developers Tools will switch to Elements tab, change back to Console and try again.
    This worked for me.

    When done, reload your entire webpage.
    zowieke said:
    @klaas Try the same trick i used. It's explained above.

    As @roel_hendr mentioned it seems maybe not to work.
    If this is the case, right click on the main part of the webpage (where the loading icon is) and select "Inspect". The Developers Tools will switch to Elements tab, change back to Console and try again.
    This worked for me.

    When done, reload your entire webpage.
    It works ,Thnks ;-)
  • klaas said:
    It works ,Thnks ;-)
    You're welcome. Glad i could help.
  • EmileEmile Administrator, Athom
    Thank you for reporting - this issue has been fixed in the newest Homey version.
  • Hi,
    Probleem: Homey time (date_human) is 2 Hours before the real "Amsterdam time" and the timezone field is not empty. At the tap location is the donot running.
    Systeem: 
    Homey just 5 days old, versienummer 1.3.1
    PC : Time and time zone in Windows is OK
    Time and time zone in Outlook /agenda is OK
    Router: Time and time zone in modem / router is OK
    I restarted many times, Take out the power plug and no solution 
    I tried al the possible soluties in this blog 
    Tab with richt klik in the "donut" field does not start the comment as mentioned
    Both "PUT" solution gives an Error. "Uncaught ReferenceError: Homey is not defined at <anonymous>:1:1

    Please help
  • Sieufke said:
    Hi,
    Probleem: Homey time (date_human) is 2 Hours before the real "Amsterdam time" and the timezone field is  empty. At the tap location is the donot running.
    Systeem: 
    Homey just 5 days old, versienummer 1.3.1
    PC : Time and time zone in Windows is OK
    Time and time zone in Outlook /agenda is OK
    Router: Time and time zone in modem / router is OK
    I restarted many times, Take out the power plug and no solution 
    I tried al the possible soluties in this blog 
    Tab with richt klik in the "donut" field does not start the comment as mentioned
    Both "PUT" solution gives an Error. "Uncaught ReferenceError: Homey is not defined at <anonymous>:1:1

    Please help

  • bvdbosbvdbos Moderator, Backer - Geek Edition
    Asked @Bram to contact you...
  • No contact with Bram yet!

  • I have the same issue. Sending the command doesn't work for me. Perhaps my steps aren't correct: In the Homey app I selected location. Then went to Firefox, pressed F12 and send the command:

    Homey.api("PUT","/manager/geolocation/",{latitude:52.3702157,longitude:4.8951679,mode:"manual"})

    The response I got was: Reference Error: Homey is not defined.

    So apparently I need to define Homey. But how do I do that?

    Regards Bobby
  • GeurtDijkerGeurtDijker Moderator, Backer - Geek Edition
    edited August 18
    baboonen said:
    I have the same issue. Sending the command doesn't work for me. Perhaps my steps aren't correct: [...]

    Regards Bobby
    open Chrome, (Homey App is build on Chome, everything else is less compatible and less supported)
    Go to https://my.athom.com/#/ and login
    Select your Homey. 
    open Develper tools (Ctrl-Shft-I) and put it there...

  • Thanks @GeurtDijker! It worked like a charm <span>:smiley:</span>
  • Does not work for me
  • GeurtDijkerGeurtDijker Moderator, Backer - Geek Edition
    Sieufke said:
    Does not work for me
    What exactly doesn't work? pls be more specific if you want us to help. Sometime it is not easy to understand what someone else finds difficult to do or how he/she understands what we find logical.

    did you try  as follows:
    1. open Chrome, (Homey App is build on Chome, everything else is less compatible and less supported)
    2. Go to https://my.athom.com/#/ and login
    3. Select your Homey
    4. open Develper tools (Ctrl-Shft-I) 
    5. pasted the following one line in the console:
    Homey.api("PUT","/manager/geolocation/",{latitude:52.3702157,longitude:4.8951679,mode:"manual"})

    it looks like this:


    after this you should be able to open the Settings - Location and see your PIN for Homey in Amsterdam. Zoom into the map ans place the Pin where you live.

This discussion has been closed.