This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to https://community.athom.com.

This forum is now read-only for archive purposes.
Closed Official

Homey v1.5.X - Experimental

15681011

Comments

  • JasperBJasperB Member
    edited December 2017
    If you want to switch back to stable, you have to do a reset. 
    Which removes all flows/devices e.g.

    I'd just disable auto update, and only update when a new stable version is available
  • @JasperB Oke but I thing a while ago there was a possibility to mark out the experimental updates so you only get the stable ones. This one is gone? I can wait till the next stable one and then disable the updates but is there any ETA for the stable one?

  • btwvince said:
    Maybe a stupid question but I can't find out how to disable the experimental updates. 
    I only can disable all the updates but can't choose to only get the full working ones.

    @btwvince
    I have never enabled experimental updates but i think you can do it here: https://developer.athom.com/

    Go to the tab 'Tools' -> 'settings'
  • @tb1962 indeed! thank you   :)
  • @btwvince
    There is no ETA given, there are still some issues on the experimental Athom is working on. 
    However, looking at the coming weeks with christmass and new year, I personally don't expect much as 50% of the world is on leave. Don't know the athom situation but hope they for them that they have some time off as well ;)
  • casedacaseda Member
    edited December 2017
    @btwvince

    warning

    As long as v1.5.6 is not in stable, do not revert to stable if you use z-wave, it will kill your z-wave because it was updated in this experimental version and will not work in any pre 1.5.6 version of homey
  • btwvincebtwvince Member
    edited December 2017
    caseda said:
    @btwvince warning As long as 1.5.6 is not in stable, do not revert if you use z-wave, it will kill your z-wave
    Oke then I will wait. I hope it will come soon because I don't have light in my toilet right now  :D
  • First world problems ;p
  • btwvince said:
    @JasperB Oke but I thing a while ago there was a possibility to mark out the experimental updates so you only get the stable ones. This one is gone? I can wait till the next stable one and then disable the updates but is there any ETA for the stable one?

    Nope, this was never the case. Once you've chosen to go to experimental the only way to go back is to reset your Homey. And for now even that is not possible as @caseda pointed out already. The only thing you can do is disable auto-update, wait for the next stable version and install the update. But even after that, you'll still be on experimental.
  • bvdbos said:
    btwvince said:
    @JasperB Oke but I thing a while ago there was a possibility to mark out the experimental updates so you only get the stable ones. This one is gone? I can wait till the next stable one and then disable the updates but is there any ETA for the stable one?

    Nope, this was never the case. Once you've chosen to go to experimental the only way to go back is to reset your Homey. And for now even that is not possible as @caseda pointed out already. The only thing you can do is disable auto-update, wait for the next stable version and install the update. But even after that, you'll still be on experimental.
    Could you or @caseda elaborate - Cause this is exactly what I was going to do over the holidays.. 
    I am currently on 1.5.6-rc.7
    I was going to wipe and reset everything and re-add every device from the start..

    I am gathering for your expressions that this will not work?

    CONTEXT: I am now experiencing Zwave Delays up to 5 secs that I never experienced before the last two firmware updates
  • btwvince said:
    Maybe a stupid question but I can't find out how to disable the experimental updates. 
    I only can disable all the updates but can't choose to only get the full working ones.

    Correct, you have to reset Homey to change back to stable firmware, this is intended behaviour.

    https://github.com/athombv/homey/issues/1907

    If you chose for experimental, you can't go back without resetting Homey...
    https://www.athom.com/nl/ondersteuning/KB000041/
    https://www.athom.com/en/support/KB000041/

  • @konradwalsh
    the z-wave chip in homey is updated in homey update v1.5.6,
    and because of this update of the chip itself if you revert homey back to pre 1.5.6 only the homey firmware goes back, this is not possible for the z-wave chip (without flashing it manually) it will get confused because of an higher version being used then it knows to work with, and thus not start the z-wave chip up.
  • I am currently on 1.5.6-rc.7
    After the update i I noticed that the KAKU plugs seem to have a little bit longer delay in switching on/off than they used to have.
    Anyone having the same ?
    It's not a real problem, but they used to react pretty fast before.
  • I am currently on 1.5.6-rc.7
    After the update i I noticed that the KAKU plugs seem to have a little bit longer delay in switching on/off than they used to have.
    Anyone having the same ?
    It's not a real problem, but they used to react pretty fast before.
    Yep, about 1 or two seconds right? Noticed it too
  • Yeah, here too...

    I have 2 ASUS-650's that control my curtains. Never had an issue, and still don't; the operating flows send the OPEN / CLOSE command multiple times.

    However,  the X-mas tree  / lights are again operational and set with APA2-2300R power switches.

    These are extremely sluggish and fail almost ever other switch cycle.
  • BramBram Member, Athom
    I see that some people are experiencing some z-wave issues after updating to RC7. 
    @konradwalsh are you experiencing any other issues besides the delay?

    If you are experiencing issues with z-wave after updating to RC7, could you try to describe it as much as possible, so we can try to figure out what's going on?
  • After the update two off my NEO power plugs didn't react any more or after a very long delay (couple off seconds).
    If i look into the tool website They are using about four devices to reach Homey. I did swop both of them with another plugs in the Mesh network and suddenly they act normal again. (Still using four devices to reach Homey)
  • Bram said:
    I see that some people are experiencing some z-wave issues after updating to RC7. 
    @konradwalsh are you experiencing any other issues besides the delay?

    If you are experiencing issues with z-wave after updating to RC7, could you try to describe it as much as possible, so we can try to figure out what's going on?
    Yes at this time, I am now experiencing just delays. Almost like a very busy ZWAVE chip.. yet no new devices added and before rc6 & 7 was responding instantly to lights on flows.. etc

    Now with the new developers pages and the visuals, I can see the errors rates steadily climb all day. If I reboot, I get a few hours of instant response times. But then it drifts again.

    Unfortunately, I only just did a reboot before I saw this post so by error rates are back to 0%. But I will leave it running till tomorrow and post a screenshot of regular intervals and how its steadily drifts
  • Hi,

    Homey Version:1.5.6-rc.7

    All zigbee devices are down, it looks the zigbee controller is broken. All zigbee is not working anymore. See screenshots.

    What did you try to achieve?

    I noticed the ikea lamps where not responding, also it was not possible to ad new zigbee devices.
    In settings the zigbee part is not opening and it is not possible to open the ad zigby devices section.

    What did you expect as result?

    Zigbee to work as before. Till today zigbee works ok, not perfect but ok.

    What was the result?

    Not one working zigbee device and not possible to at new.

    Any other remarks
    I restarted the MI and ikea app, restarted the homey and pull the plug, noting helped.


    Is this an known issue?



  • I had the same today. I did PtP after that it worked again
  • cautjecautje Member
    edited January 2018
    This dit not work, already did that.
  • you need to do a PtP for at least 10 minutes before powering again!
  • Hi @canedje I waited 20 minutes, stil the same.
    Other sugenstions?
    THX!
  • Same here. Homey hangs every day. Z-Wave behaviour that is off. 

    First time in a while that I regret to follow the experimental releases.
    Obviously we have a lot of holidays the last weeks, but I really hope on an intermediate fix / update ASAP
  • sossienl said:
    Same here. Homey hangs every day. Z-Wave behaviour that is off. 

    First time in a while that I regret to follow the experimental releases.
    Obviously we have a lot of holidays the last weeks, but I really hope on an intermediate fix / update ASAP
    Here the same. Every day Zigbee (Ikea Bulbs) not working
  • KeeKee Member
    Same here. Not every day but at least other every day.... update was planned. Hope it's soon.
  • I just installed rc8, saying Zigbee items fixed. I hope so! B)
  • canedjecanedje Member
    edited January 2018
    Unfortunately after 23 hours, Zigbee (Ikea bulbs) not reacting again anymore. Running under 1.5.6.rc8 ( same error as under rc7)
    Giving an address error in the mobile app
    I need to do a PtP again and up we go.

    z-wave looks stable so far (NEO Coolcam and Fibaro devices)

    I installed Candy, doing a Homey reset every night at 3.00 AM. Hopefully that will keep Zigbee up and running.
  • cautjecautje Member
    edited January 2018
    Meeto, and a ptp does not help. Zigbee is dead.
  • very bad update. Zigbee almost does not work anymore, zwave has big problems with the Fibaro components.
    I will soon be tired.
This discussion has been closed.