Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.

robertklep

About

Username
robertklep
Joined
Visits
18
Last Active
Roles
Member

Comments

  • @Aaron I'd be happy to add more features to the "generic tasmota" device. I have a few Wemos D1 devices, and some sensors, so I'll have a look and see how Tasmota sends the data from those sensors to the MQTT broker. Ideally, when adding a generic …
  • @Aaron in theory, my app should work. However, I'm not sure which module type you would set in the settings so it provides optimal support for the NodeMCU, and I'm pretty sure that if such a module type exists it isn't yet supported by my app (which…
  • If you happen to be using `node-dahua-api`, I guess you could try and connect to an IP-address and see if it doesn't emit an `error` event. From what I can infer from the code (not at all tested, just to get you going): const ipcamera = require('n…
  • @Aaron that would mean that you're not in the same network as your Homey? You can probably find its IP-address in the system settings too, under "Stuff for geeks", "network". It will be one of the "address" fields, but not "127.0.0.1" and also not …
  • @Aaron if you go to `my.athom.com` in a browser, and log in there, you will be redirected to your Homey. You should be able to see its IP-address in the location bar of your browser.
  • @Aaron the MQTT broker is running on Homey, so its IP-address is the same as Homey's. You have to change the MQTT setting for Tasmota so it points to the MQTT broker on Homey.
  • @alle can you check which data is sent to the broker? Specifically the "INFO1" message (which the device will send to the broker when it has powered on). By the way, feel free to create an issue about this on Github: https://github.com/robertklep/n…
  • @RemcoHannink I don't have an RF device myself, so the driver for the RF is almost entirely the same as for the Basic (apart from which module name it checks to identify the device). So not sure why it's not working. It could be that the RF device …
  • You mean `Homey.confirm()`, as documented in https://developer.athom.com/docs/apps/tutorial-App Settings.html ?
  • I have no experience with it, but it looks like ESP Easy has a built-in "rules engine" that might be able to provide the functionality you're looking for: https://rutg3r.com/sonoff-firmware-tutorial-to-esp-easy/ The Tasmota firmware doesn't have an…
  • @woei you should be able to install the beta from the Athom app store (go to https://apps.athom.com/app/name.klep.sonoff and click the link in "A beta version of this app is available. Click here to switch to this version"). The current (beta) vers…
  • @woei sorry, I missed this part:  I go to add device, select Sonoff and then I only get the options "Original" and "Tasmota". You need to install the beta version of the app for proper T1 support, the stable version doesn't support it.
  • @woei yeah, the "Module type" is correct. Not sure why it's not picking up the device. Which MQTT broker are you using?
  • @woei make sure you selected the "T1 2CH (Tasmota)" device in Homey when you started pairingduring the "Add Devices" screen, restart the Sonoff device (either by taking off the power or through its configuration screen)
  • @RemcoHannink I just submitted v4.0.7 for approval, which should be able to detect the POW R2 (using Tasmota).
  • @RemcoHannink they aren't explicitly supported, but as long as they are running the Tasmota firmware I think you can get them working without much problems. Tasmota doesn't seem to explicitly support the S26 either, but I guess that if you configur…
  • @woei sorry I forgot to mention that, but because of problems with the original firmware, most features (including support for multiple buttons for a device) are only implemented for devices that run the alternative Tasmota firmware.
  • @woei I don't have any T1 devices (I assume you're looking at one of those?), but in theory, it should work exactly as you describe. The Sonoff devices I've tested don't rely on anything being wired to the outputs in order for it to report the "swit…
  • marcotics said: rogierh said: I always use the browser, yes, it says it is not supported, but it works really well and from everywhere, without any installation needed. Athom, please keep the option available to access homey via the br…
  • Just published v4.0.6.
  • @Alle just submitted v4.0.6 to the Homey app store, with which you can set the sensor update interval for TH10 and TH16 devices. Just have to wait for approval before I can publish it.
  • Alle said: robertklep said: @Alle at the moment, you need to change it through an MQTT message, there isn't a direct way of changing it from Homey (although I'm planning to add this as a setting). Let me know if you need instructions …
  • @Alle at the moment, you need to change it through an MQTT message, there isn't a direct way of changing it from Homey (although I'm planning to add this as a setting). Let me know if you need instructions (you'll need an MQTT client).
  • @Patrick1610 the Tasmota firmware confirms the state of the device after it has received a command to switch on/off. It's the confirmation that is used to reflect the state of the device on Homey. I think that the original firmware does something s…
  • @0burner0 dat is een bekend probleem van Chromecast apparaten: https://www.dutchcowboys.nl/technology/heb-je-een-chromecast-en-wifi-problemen-dat-is-geen-toeval
  • DrDoom said: @robertklep Spot on! Dat heeft het opgelost! Na aanpassen werd hij gezien door Homey en kon ik hem koppellen. Dank! P.S. Bij de pagina van je Sonoff app mis ik de knop om een biertje voor je te kopen....  Haha geeft nik…
  • Nogmaals: uit de gepostte log blijkt dat het Sonoff apparaat probleemloos met de MQTT broker kan communiceren (en ook dat ie is ingesteld als "Sonoff Basic" module), maar dat de "Volledig Topic" ("Full Topic") setting niet-standaard is. Dat moet we…
  • @drdoom "FullTopicModule01/INFO1" is een vreemd topic, lijkt erop alsof je de "Full Topic" setting van het apparaat hebt aangepast naar iets wat niet-standaard is, en dan ziet de app je apparaat niet. Die setting moet je gewoon laten staan op de de…
  • Can you create an issue here: https://github.com/robertklep/name.klep.sonoff/issues (it's easier to deal with than here). Try and see if adding the device as a Generic Tasmota device works better.
  • Which device type are you adding? And which module is the Sonoff device configured to (in the Tasmota configuration)? Those two have to match. If they are the same, retry a few times.