Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.
Closed

Homey v1.5.7

EmileEmile Administrator, Athom
edited February 28 in Archive
We have started the rollout of Homey v1.5.7, which is a bugfix release on top of v1.5.6.

Because this update is distributed in waves, not everyone will get the update at the same time. Existing users running Homey v1.5.6 can bypass the waves by checking for updates manually  in Settings > Updates.

Changelog:
  • [Core] Fixed a bug that could prevent renaming zones
  • [ZigBee] Simultaneous reported attributes are now handled correctly
Please note that Homey v1.5.6 is not rolling out to the stable channel just yet, despite what the Athom Firmware page says.

Please report any issues you find on our Issue Tracker.

As a sidenote, there is some unclarity about new Homeys being shipped with Homey v1.5.6. Due to a minor hardware change —which is incompatible with older software versions— we chose to produce the new Homeys with the new software.

While Homey v1.5.6 still is in the experimental channel, we regard this update as more stable than the current stable version (v1.5.3). Existing users will receive a stable version of Homey v1.5.7 as soon as the update is cleared by our Quality Assurance team and no new problems arise during testing.
«1

Comments

  • What is the minor hardware change :)
  • kukeltjekukeltje Member
    5GHz wifi?
  • hnijveenhnijveen Member
    kukeltje said:
    5GHz wifi?
    If this was possible, I would disable it. I reserve 5GHz for user clients access only. All my HA devices are on 2.4 (together with my neighbours)  :D
  • My Kaku's don't work anymore with 1.5.7.
    With 1.5.6. they worked fine.
  • GeurtDijkerGeurtDijker Moderator, Backer - Geek Edition
    My Kaku's don't work anymore with 1.5.7.
    With 1.5.6. they worked fine.
    Did  you try a Pull the Plug? And check fe  batteries.
    For me 1.5.7 was no change in 433.(as there is also nothing mentioned in the changelog of 1.5.7 about that)
    There are a lot discussions on the forum how to troubleshoot 433/ Kaku.
    There are already a lot of Homeys  on 1.5.7 so could it be a coincidence with something else changed that blocks your kaku? 
  • mveckmveck Member
    Hi all, having a Homey shipped with 1.5.6, but check for updates doesnt give me the option to update to 1.5.7. It is a bummer, because having a 1.5.6 out of the box I already have 3 zones which I cannot rename properly...
    Is there any way to "convince" Homey that 1.5.7 is available (despite not being experimental)?

  • GeurtDijkerGeurtDijker Moderator, Backer - Geek Edition
    mveck said:
    Hi all, having a Homey shipped with 1.5.6, but check for updates doesnt give me the option to update to 1.5.7. It is a bummer, because having a 1.5.6 out of the box I already have 3 zones which I cannot rename properly...
    Is there any way to "convince" Homey that 1.5.7 is available (despite not being experimental)?

    Nope, just wait until 1.5.7  it hits Stable.
  • canedjecanedje Member
    edited March 2
    mveck said:
    Hi all, having a Homey shipped with 1.5.6, but check for updates doesnt give me the option to update to 1.5.7. It is a bummer, because having a 1.5.6 out of the box I already have 3 zones which I cannot rename properly...
    Is there any way to "convince" Homey that 1.5.7 is available (despite not being experimental)?

    Or go to experimental. Be carefull!!! If you go to Experimental you can not go back to stable again. Except by resetting Homey and startup from scratch again.
  • lourenslourens Member
    My Kaku's don't work anymore with 1.5.7.
    With 1.5.6. they worked fine.
    Had the same problem.  A Pull The Plug fixed it
  • My Kaku's don't work anymore with 1.5.7.
    With 1.5.6. they worked fine.
    Did  you try a Pull the Plug? And check fe  batteries.
    For me 1.5.7 was no change in 433.(as there is also nothing mentioned in the changelog of 1.5.7 about that)
    There are a lot discussions on the forum how to troubleshoot 433/ Kaku.
    There are already a lot of Homeys  on 1.5.7 so could it be a coincidence with something else changed that blocks your kaku? 

    Thanks! Pulling the plug did fix it!
  • arndarnd Member
    My Kaku's don't work anymore with 1.5.7.
    With 1.5.6. they worked fine.
    Did  you try a Pull the Plug? And check fe  batteries.
    For me 1.5.7 was no change in 433.(as there is also nothing mentioned in the changelog of 1.5.7 about that)
    There are a lot discussions on the forum how to troubleshoot 433/ Kaku.
    There are already a lot of Homeys  on 1.5.7 so could it be a coincidence with something else changed that blocks your kaku? 
    For me the same troubles with kaku and klik aan klik uit   no response 

  • JPeJPe Member
    Also had problems with 433 (X10) not working first time after update to 1.5.7, first time PTP wait 10 minutes, gave RED Ring, the second try PTP 10 min. did the trick, all is working again.
  • MarcoRitsMarcoRits Backer - Homey
    But still no answer on the what the minor update is.
  • quakerixquakerix Member
    MarcoRits said:
    But still no answer on the what the minor update is.
    I think that got answered in the monthly blog
  • mveckmveck Member
    canedje said:
    mveck said:
    Hi all, having a Homey shipped with 1.5.6, but check for updates doesnt give me the option to update to 1.5.7. It is a bummer, because having a 1.5.6 out of the box I already have 3 zones which I cannot rename properly...
    Is there any way to "convince" Homey that 1.5.7 is available (despite not being experimental)?

    Or go to experimental. Be carefull!!! If you go to Experimental you can not go back to stable again. Except by resetting Homey and startup from scratch again.

  • Exile82Exile82 Member
    Me and my Xiaomi sensors are really looking forward to the 1.5.7 release. Despite some issues reported here, it doesn't seem to be very severe bugs.
  • Exile82Exile82 Member
    Will it still be problematic to go from experimental to stable if, let's say,  I am on 1.5.7 Experimental and want to go the stable 1.5.7 when it turns up?
  • bvdbosbvdbos Moderator, Backer - Geek Edition
    Not if you don't find completely resetting your Homey problematic... But otherwise, it's not stated without a reason and above it's not possible to switch from exp to stable.
  • Exile82Exile82 Member
    edited March 6
    Well, I consider that a bit problematic. :)
    Thanks for your response @bvdbos
  • Fire69Fire69 Backer - Geek Edition
    Exile82 said:
    Will it still be problematic to go from experimental to stable if, let's say,  I am on 1.5.7 Experimental and want to go the stable 1.5.7 when it turns up?
    No, it won't be problematic at all.
    When you're on 1.5.7 in experimental, and it goes to stable (without changes) you don't have to do anything in fact.

    If you don't want to continue receiving experimental firmwares, just disable the option to receive automatic updates and you're done ;)
  • Exile82Exile82 Member
    Thanks Fire69. 
    I am not really sure if I understand you correctly, but if I disable the option to automatically receive experimental updates, I will still be on 1.5.7 Experimental and not be able to receive stable releases. I still need to reset Homey to be able to re-enter stable channel. Right?
  • Exile82 said:
    Thanks Fire69. 
    I am not really sure if I understand you correctly, but if I disable the option to automatically receive experimental updates, I will still be on 1.5.7 Experimental and not be able to receive stable releases. I still need to reset Homey to be able to re-enter stable channel. Right?
    You know 1.5.7 experimental will become 1.5.7 stable (same release) so if you disable out update then for example you can skip 1.6RC1 till 1.6RC20 and only press update when 1.6 will be released in the stable channel. So you are on the experimental channel but you update only stable updates
  • Exile82Exile82 Member
    That make sense! Thanks a lot!
  • canedjecanedje Member
    edited March 8

    Just did an update to 1.5.8
    As a present I did receive spontaneusly an "unknown node""
    Is this recognized by somebody?
    Any idea how to remove this node?

    Beside this I don't see for a couple of days no "z-wave spider" anymore at tools.




  • keverjeroenkeverjeroen Member
    edited March 8
    canedje said:

    Hiernaast zie ik al enige dagen geen "z-wave spin" meer bij tools?

    That's right: https://github.com/athombv/homey/issues/2148
  • Fire69Fire69 Backer - Geek Edition
    Removing the diagram is completely stupid!
    I don't complain often (only for the non-functioning voice until now) but this is really bad IMO...
    If you just start removing functionalities because you can't get them to work as you expected, what will be left in the end??
  • Fire69 said:
    Removing the diagram is completely stupid!
    I don't complain often (only for the non-functioning voice until now) but this is really bad IMO...
    If you just start removing functionalities because you can't get them to work as you expected, what will be left in the end??
    But you know the developer tools are seperated from your Homey version so what happends there stays there, saw your comment at Github about your survey ;) At least the Zigbee graph is still there :) 
  • canedjecanedje Member
    Fire69 said:
    Removing the diagram is completely stupid!
    I don't complain often (only for the non-functioning voice until now) but this is really bad IMO...
    If you just start removing functionalities because you can't get them to work as you expected, what will be left in the end??
    I agree! I'm realy surprised :o
  • Fire69Fire69 Backer - Geek Edition
    Fire69 said:
    Removing the diagram is completely stupid!
    I don't complain often (only for the non-functioning voice until now) but this is really bad IMO...
    If you just start removing functionalities because you can't get them to work as you expected, what will be left in the end??
    But you know the developer tools are seperated from your Homey version so what happends there stays there, saw your comment at Github about your survey ;) At least the Zigbee graph is still there :) 
    Ah, so the graph didn't disappear when I installed 1.5.8?
    Ok, I'll remove my comment from Github then, but my 'disappointment' is still the same ;)
  • Fire69 said:
    Fire69 said:
    Removing the diagram is completely stupid!
    I don't complain often (only for the non-functioning voice until now) but this is really bad IMO...
    If you just start removing functionalities because you can't get them to work as you expected, what will be left in the end??
    But you know the developer tools are seperated from your Homey version so what happends there stays there, saw your comment at Github about your survey ;) At least the Zigbee graph is still there :) 
    Ah, so the graph didn't disappear when I installed 1.5.8?
    Ok, I'll remove my comment from Github then, but my 'disappointment' is still the same ;)
    Yes, developer tools can have the graph back in a blinck if Athom activates it without any update on Homey, just like they can deactivate the zigbee graph without Homey update :) But one note, i thought you need to have higher then 1.5.3 to use the developer tools (because Homey after that delivers the information to the developer tools) 
This discussion has been closed.