This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Add a way to cummunicate with a Telegram Bot



  • Only in combination with a synology NAS?
  • @ThijsDeJong Yeah, I combined my 2 apps to do that. Will take some time before I release the new version though, really occupied at work at the moment.
    When Athom has webcam support (which is on their todo list, but I think it will take months before it is done) more can be done without a Synology.
  • Looking forward to it. In the past I asked @Emile if the cameras of Would be supported. He answered positively but clearly indicated that it could be near the end of 2016/ start 2017. So if it could be made possible via an other app combination.
  • jorden said:
    @Yannick Only when you use an external motion sensor. I don't have a webcam with motion sensor myself, so I am unable to create this functionality. I use my Fibaro motion sensor instead :)
    I do have a fibaro motion sensor. But how do I do the webcam image part? I can only find cards for sending and receiving messages..
  • @Yannick only thing you can do right now, is using the Synology app to send a webcam image by email. The 'webcam image by Telegram' stuff is "work in progress".

    I have finished the part where you can 'request' a webcam image by Telegram, but still need to improve that a lot. Next I will see if I can create a function to send to Telegram, so you can combine it with other elements in Homey.
  • and the app is not working anymore on 0.10.2 :neutral: 
  • I am running it on my Homey on 0.10.2 without a problem...
  • Strange.. will do some tests again
  • Working here also. 0.10.2
  • found it! my token was gone in the homey settings. Working again.
  • Good to hear!
  • Jorden, the app is still not working at my end. Created a new bot, succesfully registered and added the token. However, it does not communicate with my Homey at all..
  • Mine isn't working also. I made a simple flow that let homey tel me the message i send him. That works great but letting homey send a message from a flow doesn't
  • Any updates on this one?  :)
  • No updates yet, I'm really busy at work at the moment.
  • Took some time today to finish what I was working on.

    New stuff:
    Type "/say test" and Homey will say "test".
    Type "/ask How are you today" and Homey will ask that, and put the answer in Telegram
    Type "/snap" if you have the Synology Surveillance Station app installed and you will see a list of cameras installed. Click on one and you will receive a snapshot.
    Some small bugfixes.

    I have submitted it to the app store for approval.

  • I have submitted it to the app store for approval.
    I'm looking forward to it! Thumbs up!
  • New version is published!
  • downloaded the newest version, but how does the /ask option work?
    if i sent /ask hoe laat is het? i get no responce..
  • still getting a turning circle of death on Send a message card.
  • @spoelly I think you need to remove the question mark. It somehow messes up on a level before it enters the app. Haven't figured out a solution yet.
  • @Yannick you might have to try and remove every connection from the Telegram app to the bot, to see if you can "start over".
    Not sure what is causing this; a next version I'll try to add some more information to the spinning circle.
  • Cool that worked. Stopped bot from Telegram iPhone app, restarted and re-registered.
  • Good to hear; debugging is kinda hard because you cannot run this app in developer mode (unless you do a lot of work ;)
  • jorden said:
    @spoelly I think you need to remove the question mark. It somehow messes up on a level before it enters the app. Haven't figured out a solution yet.
    Without it, also doesn't work..
  • Hmm now in my test just a second ago, it did ask me the question, but didn't send me the response. Guess it needs some work :)
  • I noticed the app version on my homey is 0.1.2, while the latest app store version is 1.4.

    Looks like it's not updating to 0.1.4 from 0.1.2. How can I force/trigger it to do so?
  • U can force it by going to the appstore and install the latest.
    The update thingie in the apps section is gone for me also.
    Gonna make a github issue when more peeps have problems with this.
  • Thanks, that worked!

    I was afraid I would lose flows, but at first glance, they are still there.
  • VonkenboerVonkenboer Member
    edited October 2016
    @jorden The new features are cool!

    Just a question, how does the /ask feature work? Do I have to make a flow or some kind?

    EDIT: Nevermind, it is already mentioned in earlier posts... RTFT  :D
Sign In or Register to comment.