This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Add a way to cummunicate with a Telegram Bot



  • jordenjorden Member
    edited August 2016
    After a lot of trying, I got something cool working....
  • Nice!  Good job
  • That's very impressive! Awesome.
  • jordenjorden Member
    edited August 2016
    Now I also build in:
    /ask <question here>

    Asks a question through Homey, the answer will be sent as text to the chat window.

    Will work on some more stuff before I release this, but it is on Github already for whoever wants to try! (If you want to try the /snap stuff, you also need to download the update on the Synolog app from Github)

    (I am going to try and make buttons of the options... so if you send /snap, you get a button for each camera that you can click on)
  • WOW!! Nice! :o
  • That's frickin awesome.
  • This will be a good way to automatically send snapshots when an alarm is breached. The snapshots then will be safely stored on the encrypted Telegram cloud, unattainable for burglars when they steel my mailserver or NAS!
  • KoenMartensKoenMartens Member
    edited August 2016
    @jorden: Could it be that your bot only works on 0.9.x? I'm still on 0.8.x (IR...) and I can't get it to work (even tried to re-set the webhook as you explained on page 2).
    EDIT: Your app.json says it's compatible with 0.8.34+. That means it should work for me?
    I can't seem to get it to work though. I tried both via the HomeyBot and my own bot, I do not get results after I use /register, and the ping command doesnt work. Trying to use a flow with Telegram provides and eternal-spinning circle and no messages.
    If it is indeed 0.9.x+, do not bother to try to fix it just for me ;)
  • That's strange. I don't see why it wouldn't work on earlier versions.
  • I have it working here on 0.8.32
  • @jorden: Alright re-installed the app and registered without any problems. Strange.
  • Stopped working for me too. Installed the latest version from Github but Homey stopped working with all flows. After that, removed the Telegram app, rebooted and flows are working again, except the Telegram app. Installed the v0.1.2, but not working. Any idea?
  • FYI, when a private bot is made in Telegram, the bot can be added to groups by default.
    To change this use /setjoingroups in BotFather to Disable

    @jorden, can you add a step in your app-description comments to disabled this?
  • Will do that when I get back from my vacation. 
  • Have a nice holiday!
  • Thanks! I returned last wednesday. Kinda busy at the moment to catch up with my work, but I made this change in the github repo already. Hopefully next week I can continue with the app.
  • spoellyspoelly Member
    edited September 2016
    After updating to 0.10.0 firmware my bot stopped working.. got the same issue as earlier in this topic  :(
  • mbalik79mbalik79 Member
    edited September 2016
    spoelly said:
    After updating to 0.10.0 firmware my bot stopped working.. got the same issue as earlier in this topic 
    same here
  • Can not add homey to my bot anymore :(
  • Also here after updating to firmware 0.10.0 Telegram bot doesn't work anymore.
  • Second that. 

    Another question, would it be possible to add the feature to make a snapshot through Telegram of the IP camera in the next version (using the Synology NAS)?
  • HTD said:
    Also here after updating to firmware 0.10.0 Telegram bot doesn't work anymore.
    Homey does send Telegram message's that goes ok, but Homey doen't receive messages from Telegram (or Homey doesn't  respond to message sent to Homey) 
  • I will have a look next week to solve this 
  • It seems the webhooks don't work anymore. I can't get any webhook to work (also the Webhook.manager doesn't work anymore).

    It shows the "times fired" correctly, but it doesn't push to Homey anymore. Will have to wait for a response from Athom before I can fix this.
  • Bas just confirmed that something broke in 0.10.0 which causes Webhooks not to work anymore. Therefor, receiving messages on the Telegram app no longer works. He is working on a fix which will be in 0.10.1 (together with a lot more bugfixes).
  • Thanks for the update @jorden ;
  • Aha, that explains a lot, fun thing is, I not in the "unstable" releases, still on  0.9.1. Here it works.

    For future versions, is it possible to make it possible that the bot sends messages to an group?

  • Firmware 0.10.1 is available and automaticly fixed the problems with the webhook and Telegram.
  • is it already possible with this app to create a flow that sends an image of a webcam when motion is detected by a motion sensor?
  • @Yannick Only when you use an external motion sensor. I don't have a webcam with motion sensor myself, so I am unable to create this functionality. I use my Fibaro motion sensor instead :)
Sign In or Register to comment.