This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Support for 433mhz temperature sensors



  • Ok, I've added decoding for Alecto v1. However, I'm assuming it still won't work. Looking at the two bit-streams the data doesn't make sense (and CRC looks invalid).
  • your assumption was right ;-)

    22:45:18.898 [oregonv3] data array length 95
    22:45:18.898 [oregonv3] Removing incomplete nibble from message
    22:45:18.899 [oregonv3] data array length 92
    22:45:18.912 [oregonv3] Device id hex aa45
    22:45:18.916 [oregonv3] Unknown sensor ID aa45; ignoring...
    22:45:18.920 [oregonv3] Error: aa45
    22:45:19.180 Received payload for Oregon Scientific v3
    22:45:19.188 [oregonv3] data array length 86
    22:45:19.192 [oregonv3] Removing incomplete nibble from message
    22:45:19.196 [oregonv3] data array length 84
    22:45:19.202 [oregonv3] Device id hex aaaa
    22:45:19.208 [oregonv3] Unknown sensor ID aaaa; ignoring...
    22:45:19.214 [oregonv3] Error: aaaa
    22:45:19.297 Received payload for Cresta / TFA
    22:45:19.302 [cresta] 52 {"type":"Buffer","data":[1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,0]}
    22:45:19.312 [cresta] 12 b6b6b6b6b606 false 27
    22:45:19.315 [cresta] Error: Not a valid Cresta message
    22:45:38.045 Received payload for Conrad 868
    22:45:38.046 [alectov3] 56 {"type":"Buffer","data":[1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1]}
    22:45:38.047 [conrad3] Error: Not a valid Alecto message
    22:45:45.704 Received payload for Conrad 868
    22:45:45.714 [alectov3] 50 {"type":"Buffer","data":[1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1]}
    22:45:45.750 [conrad3] Error: Not a valid Alecto message
    22:45:52.102 Received payload for Conrad 868
    22:45:52.108 [alectov3] 52 {"type":"Buffer","data":[1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1]}
    22:45:52.112 [conrad3] Error: Not a valid Alecto message
    22:45:53.597 Received payload for Cresta / TFA
    22:45:53.603 [cresta] 47 {"type":"Buffer","data":[1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1,0,1]}
    22:45:53.610 [cresta] 10 fffefffeff false 31
    22:45:53.615 [cresta] Error: Not a valid Cresta message
    22:45:53.798 Received payload for Cresta / TFA
    22:45:53.802 [cresta] 56 {"type":"Buffer","data":[1,0,1,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,0,0,1,1,0,1,0,1,0,1,0,1,0,0,0]}
    22:45:53.808 [cresta] 12 6f6c6c6cac7e false 22
    22:45:53.812 [cresta] Error: Not a valid Cresta message
    22:45:54.188 Received payload for Oregon Scientific v3
    22:45:54.201 [oregonv3] data array length 116
    22:45:54.205 [oregonv3] Device id hex a459
    22:45:54.214 [oregonv3] Unknown sensor ID a459; ignoring...
    22:45:54.214 [oregonv3] Error: a459
    22:45:54.338 Received payload for Alecto v1
    22:45:54.347 [alectov1] 36 {"type":"Buffer","data":[1,1,1,0,0,0,1,1,1,1,0,0,0,0,0,0,0,0,1,0,0,0,0,0,0,0,1,0,1,1,1,0,1,1,0,0]}
    ReferenceError: decVal is not defined
        at Object.parseAlectoV1 [as parser] (/node_modules/alecto/index.js:125:11)
        at WeatherSignal.parse (/node_modules/utils/index.js:31:27)
        at Signal.<anonymous> (/app.js:43:15)
        at emitThree (events.js:97:13)
        at Signal.emit (events.js:175:7)
        at /homey-app/various/rf.js:23:19
        at /homey-app/helpers/client.js:1:1013
        at Array.forEach (native)
        at process.<anonymous> (/homey-app/helpers/client.js:1:982)
        at emitTwo (events.js:87:13)

    --- INFO: has been killed ---

    Hope this helps
  • RamonBaasRamonBaas Member
    edited November 2016
    @ArenBreur Sorry about that. One line was missing, added it now. Really annoying that I cannot test it myself  :s.
  • @RamonBaas ;
    don't be sorry,
    I will test it, it is running already

    thanks for the effort

  • @RamonBaas ;
    this is another log file.

  • @ArenBreur Thanks, additional fixes applied. Looks like you can turn off Alectov3 and Conrad.
  • @RamonBaas ;
    ready for the next round ?
    here is another log file.
  • RemcoHanninkRemcoHannink Member
    edited November 2016

    Just tried the latest code, now nothing happens, no sensors are detected, but the app doesn't crash anymore. But no sensors found. 

    Gr. Remco
  • @ArenBreur Thanks for the log. One last thing we can try is see if signal recognition gets better without looking for the sync bit. I've updated the code to remove the sof.
  • @RamonBaas ;
    I am running the code without the sof ( dont know what the sof is) But after more than 10 minutes no info only the ..... registered.
    maybe you removed a bit to much ?

  • @RamonBaas ;
    funny, after about 1 hour, there was activity in the debugscreen.
    good luck with puzzeling.

  • @ArenBreur Thanks. Is this a temp/hum sensor? If so, we likely have the bits reversed. Also, if you happen to have the actual values at that moment, that would help.
  • at the moment it is  10.7 degrees en 98% humidity.

  • @RamonBaas ;
    Hi, I saw there was a new version., so I tried it.
    It found two devices

    at the moment it is 10.4 degrees and 88% humidity.
    My alecto V1 has no battery info ( as far as I know)

    these are the devices as seen by domoticz with an RFlink

    happy hunting
  • @ArenBreur Ah, you do have a wind sensor as well! So that may have been the data I've seen. The Alecto v1 protocol does carry battery info. Can you send a log file that I have some data to work with?
  • RemcoHanninkRemcoHannink Member
    edited November 2016

    The latest version is working.....great work !

    My Ventus W044 temp/hum sensor is detected as a TA-75 ?? But I can change this name.
    Other issue is that I have two temp/hum sensors in house, both Ventus W044. The one upstairs is found by Homey, but the second one in the living, close to Homey, is not detected ??????

    Thanks again for your work.

    Gr. Remco
  • @RemcoHannink That is good to hear! Since the data contains no device ID (that I know of) it will call it 'TH' (Temperature Humidity) + the unique code.

    As the W044 is known to be Alectov1, I'm curious which devices @ArenBreur has and what RFlink/Domoticz calls Alecto v1 and v4 (first time I see a v4).
  • RemcoHanninkRemcoHannink Member
    edited November 2016

    My two sensors look like this in Domoticz (RFLink):

    I changed the names from Alecto V1 to the names above.

  • Ramon,

    After about an hour !!!!! my second temp sensor in the living also showed up and is working fine now.

  • I have not the latest version yet, but a working 'older' version of about 1 monthe ago. That works, but when i put mijn thermometers on their place, 1 outside, 2 on the second floor, 1 in livingroom, then only the livingroom can be read. So the range is not good enough.

    Does the newer version also have a better range, or is that something homey only can solve?
  • @Pils: Limited range is indeed an Athom/Homey thing which they have on their list to solve SOON(TM). This cannot be solved in any app.
  • Ok, thanks

  • Thanks Ramon for this excellent app, it works perfectly with my Oregon THGR810.

    I have some other 868 temp/hum sensors what I would like to add to Homey:
    - TFA 30.3187.IT
    - TFA 30.3144.IT

    I am a noob currently because my Homey just arrived 2 days ago… 

    I do not know much about the protocol of this devices yet but I suppose may same as the version 433MHZ. So could help me how I can add support to the app?
  • @pagocs Glad you like it. To be honest, I haven't been able to receive anything useful with Homey on 868 MHz. Where the 433 spectrum configuration is relatively broad, it seems very narrow for 868. From the docs:
    ... This comes down to a frequency band ranging from 433.76MHz to 434.08MHz for 433 MHz signals and 868.14MHz to 868.46MHz for 868 MHz signals.
    I have one (Conrad branded) 868 temperature sensor on '868', which in actual fact sends the data on 867.8 MHz. This is outside of the range Homey is configured to receive, hence I cannot receive that data. For Visonic sensors that send their data on 868.98 Mhz, this is also out of range for Homey. I haven't seen any example of 868 communication with Homey yet (besides zwave, which is a separate radio).
  • @RamonBaas ; not the best news, because I also planned to control my existing thermostat devices which are use 868 frequency also. 

    Supporting the multiple communication channels was one of the key selling point of Homey for me.

    What is the best way to determining is Homey can handle a 868 device or not? Are there any way to debug the the RF receiver inputs like in RFLink gateway (i have just an 433MHz version)?
  • You can try to capture 868 Mhz signals using the Chrome console with the command
    api('POST', '/manager/microcontroller/record', { frequency: '868' }, console.log)
  • Thx , but where I can find some documentation about how to access the console.log?

  • In chrome press F12 or go to developer-tools...
  • @BasVanDenBosch thanks, got it.
Sign In or Register to comment.