This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

[APP] Synology Surveillance Station for Homey



  • jordenjorden Member
    Yeah that's correct. In that case it SHOULD work. But I guess there's a bug somewhere. I'll make sure to check that ASAP.
  • JulianJulian Member
    @jorden ; Have you been able to check it? AFAIK I configured it correctly but it has never triggered on itself (other than using the test button). 
  • jordenjorden Member
    @Julian sorry I forgot about it! I have just tried and indeed, I was using the wrong kind of trigger... I triggered the app instead of the device, while I made the cards for the device and not the app...

    So now I bind everything to the device instead. Tested it, found a bug where the 'polling' only worked directly after turning it on but not after a Homey reboot, or app upgrade... so I fixed that as well. New version submitted to the app store for approval but not yet published.
  • JulianJulian Member
    Great, thanks for the quick reply and finding the solution. Will await the new app and let you know if it works.
  • jordenjorden Member
    Update is published in the app store now! @Julian ;
  • skylabskylab Member
    Running latest athom fw and synology app version but can't add my Synology as a device. Entered ip, port 5000, admin user but saving config does not add any device and keeps displaying the config window. No messages either. Anyone?
  • JulianJulian Member
    @jorden ; thanks for the update, but up to now nothing has changed for me. I have also tried a complete re-install of the app & the device, but again only the test works (including sending a snapshot via mail) and not a single real trigger.
  • jordenjorden Member
    That is strange, all worked for me when I tested...

    Can you try to disable the app under 'Settings > Apps' and then enable it again? That forces a reboot. Perhaps then it works.
    I received a few errors from the Synology app regarding timeouts on the IP this morning, perhaps that is what happened in your case.
  • JulianJulian Member
    edited June 2016
    Sorry, disabling and enabling did not do the trick.
  • JulianJulian Member
    @jorden ; Have you been able to figure out what  goes wrong? If you need specific information from me I will be glad to help.   
  • jordenjorden Member
    @Julian I just tested with version 1.1.4 which is coming up soon (under review in the app store). It is basically 1.1.3 which is already live but with some better error catching.

    I made 2 flows:
    1- When 'woonkamer' camera starts recording, say "Start"
    2- When 'woonkamer' camera stops recording, say "Stop"

    Then I made a 3rd flow, when anything was said, start recording on "woonkamer" camera.

    I did a 'test' on the 3rd flow, and within a few seconds Homey said "start".

    Then I changed the 3rd flow, to stop recording instead. I tested the flow, and Homey immediately said "Stop".
    This was after checking the "polling" box.

    Then I stopped the app and started it again, to make sure it ran the polling function automaticly after an app restart. And then ran the same test. It worked well.

    I did come across some "error: code 105" while testing. Synology sometimes does that. And then it didn't poll the device anymore.

    So I decided to move the 'activation of polling' upwards in the code so it should still owork after an error code. And that seems to have worked. Even after some error codes (105 and 117) it now still polls.

    So the 1.1.5 is now submitted to the app store for review.

  • Are you considering other Synology parts beside the surveillance station?
  • jordenjorden Member
    I've looked into it, and a lot if possible... for example, download station => trigger when a download is complete. And with Music Station also there are a lot of possibilities. But I don't really use that myself and since it is a lot of work to create a well working app, I'm not planning to do any work on that yet.
  • JulianJulian Member
    @jorden ; after the latest update the notifications came pouring in :smiley: So it works ok now! Thanks.
  • jordenjorden Member
    @Julian Good to hear!
  • EternityEternity Member
    edited July 2016
    The Syno App frequently stops working (once a day). I have the idea that the Domoticz package I have installed, causes the problem, but have no idea how to find out. Anyway, stopping the Syno App and restarting solves the problem.
  • jordenjorden Member
    I have one error that sometimes occurs that I have to fix, which makes the app crash. Hope to have time this week for another small update.
  • Thanks you Sir!
  • jordenjorden Member
    Submitted to the app store now for approval!
  • OskarOskar Member
    @Jorden ; I got the app working and like it. Thanks for the good work.
    I want to use it to email a picture when a movement is detected, however most of the time the picture has nothing on it. When I look at the recorded movie on the NAS I do see people on it. Is it possible to add a card that makes it also possible to send the recorded video once the recoding stops?
  • jordenjorden Member
    @Oskar I get the picture via the API, so it is encoded as text. To my surprise, that worked, and I was able to pass it to the e-mail.
    I think that it is not possible to do the same with video, but I might test it in a few days.
  • FranqFranq Member
    posthok said:
    Your not the only one. There's something wrong with the mail settings.
    I know that you already have a work around  (lowering the security) but doesn't this has to do with the app-password from Google? 

    Just search on 'app password google'

    You can create passwords for apps.
  • MennoMenno Member
    Yeahhhhhh received a mail today with screenshot. Don't know what changed but I like it Maybe the nice weather
  • The door opened? Lol
  • jordenjorden Member
    Even palm trees! Man you live like you're on vacation :)
  • MennoMenno Member
    Hmmmm waiting for homey to take a picture of me and my beer under the palmtree but no homey email.
    Received two emails yesterday but after that no more emails
  • jordenjorden Member
    What did you use as a trigger?

    Sometimes the connection Homey <---> Synology doesn't do what it should do. The commands generate an error in Synology. I blame Synology for this.
  • aloftaloft Member
    @jorden ; i have the same issue as @skylab some comments earlier; Pairing my synology doesn't work: I save settings, but I don't get the next screen. The 'debug screen' of chrome doesn't show anything, until the pairing times out. 

    Disabling and re-enabling the app won't help. 

    The SMTP settings work fine, I get the test mail. 
  • jordenjorden Member
    @aloft please try running in "developer mode" (see and let me know how the logs you see in commandline turn out.
  • aloftaloft Member
    @jorden ;

    enablepolling = undefined

    Synology Surveillance Station app - got get_devices from front-end, hostname =

    [CMD] Login called

    RESPONSE END "{\"error\":{\"code\":402},\"success\":false}\n"

    [CMD] List called

    RESPONSE END "{\"error\":{\"code\":105},\"success\":false}"

    [CMD] Logout called

    RESPONSE END "{\"success\":true}\n"


    I am using a non-standard port for my NAS. http , not https.  If I set in on a non-responding port, I don't get this output. If I use a incorrect password, I get the same output. If I use an incorrect username, I get the same output.

    It looks like something with authentication on the WebAPI


Sign In or Register to comment.