This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

[App] Qubino by Athom - main discussion topic



  • @pascal Did you manage to get the ZMNHDA2  flush dimmer working?
  • OskarOskar Member
    edited November 2016
    @pascal Did you manage to get the ZMNHDA2  flush dimmer working?
    Not yet for my ZMNHBA2 (is this similar as DA2?).
    It works with all on and all off, but not with the individual switches via Homey. The individual switches do work with the wall switches that are wired to the Qubino. I've not yet tried to re-add/include since the latest Homey update as the change log did not say anything about changes to the Z-Wave implementation.
  • @pascal Did i mix up some modules? The ZMNHBA2 isn't supported in the app yet.
    The ZMNHBA2 is a double switch and the ZMNHDA2 is a flush dimmer. So different modules.
    So confusing those names......
    Trouble with the ZMNHBA2 is, that i don't own one. Therefore can not test when building a driver....
  • I have the ZMNHDA2 Flush dimmer. And it is still not working.
  • Ah, i  mixed up the users, not the devices... :(
    @pascal is that the only Qubino device you have in use?
  • I just bought a pair of ZMNHOD1 for my two screenline roller shutters, but it seems as homey only detects it as a generic zwave device and the result is I only have an on/off switch to control it. Is there a way to make it work as it should?

    Looks like openzwave already added support for it:

    device details:

    3.png 32.1K
  • I would like to add them, but because i don't have the device, it is difficult to integrate. Can not  test the results. Think have to wait until Athom writes a driver for it. Thee have Some devices
  • @kasteleman understand. I'm going to try if i can get this working myself by adding a new driver to the Qubino app. If I cannot get it to work i will have to send them back to xat.

    P.S. Did you hear anything about new devices athom would add?
  • Robin is working on it, but not yet on the shuttermodels. I don't know how long you can wait and if you succeed, please share it.
  • @kasteleman can you please add support for the Qubino Flush 2 Relays (ZMNHBD1)?

    Please let me know if you need more information
  • I think it is in Github, but the app won't be upgraded because Athom is going to publish it when the time is right. Robin has been working on it lately.
  • Only those 4 are on Github.

    @Robin do you have more information about athom Qubino app?
  • That's @kasteleman 's repo which is in fact the one on the appstore I think :) But there's a second repo:

    But, it seems like work in progress. The app crashes if I install it...

  • The app works just fine. Make sure you have the zwave driver included.
  • Thanks @clandmeter and @BasVanDenBosch!!!
    everything is working great
  • I've recently added support for Qubino DC roller shutter aka ZMNHOD1. I would have waited for athom to update the Qubino app but it seems they are currently more busy with other things. So for now you can sideload the app from and you can add additional features from the outstanding PR's if needed.

    cc @Skorpion
  • LeonVanDerReeLeonVanDerRee Member
    edited February 2017
    Very nice job guys. I was forking the qubino repo of kasteleman last week to add support for the ZMNHOD1, but found out there is another branch of athom, you all forked and which was way further than I got in my first attempt.

    Since today I've got an Qubino RC roller shutter myself, and tried to add it to my Homey Zwave network (next to a dozen of Fibaro Dimmers), while I sideloaded the latest commit:
    - aa15fa67030d5485299a7ed4b76411db9df1d036 "ZMNHOD1: add action flows for dim capabilities"
    But during the inteview, in which it succesfully handles 16 command-classes, it fails in the last step in which it is gathering info about the manufacturer, and finally aborts the inclusion.

    I already tried to sideload an older commit (the latest of athom: 8e2b45 "All drivers: fix int overflow, fix wrong setting size, add documentation reference, remove debug" However unfortunately with the same result"

    Can anyone give tips about what I can do (check some logs, reboot devices in a particular order or retry for xyz times?)


    tail of zwave log:
    [2017-02-06T18:33:39.114Z] Node[38]: Received application command for COMMAND_CLASS_VERSION, data: 0x142001
    [2017-02-06T18:33:39.119Z] command status: addNode, status: INTERVIEW_CC_16_OF_16
    [2017-02-06T18:33:39.471Z] command status: addNode, status: INTERVIEW_MANUFACTURER_SPECIFIC
    [2017-02-06T18:33:39.472Z] Node[38]: sendData to COMMAND_CLASS_MANUFACTURER_SPECIFIC, params 0x0404
    [2017-02-06T18:33:39.472Z] Command start: sendData
    [2017-02-06T18:33:40.709Z] ProcessSendData[233]: To node: 38 with data: 0x720404 and txOptions: ACK,AUTO_ROUTE,EXPLORE
    [2017-02-06T18:33:40.714Z] Command end: sendData
    [2017-02-06T18:33:40.741Z] Node[38]: Received application command for COMMAND_CLASS_VERSION, data: 0x142603
    [2017-02-06T18:33:41.770Z] Command end: sendData
    [2017-02-06T18:34:09.474Z] Command end: addNode
    [2017-02-06T18:34:22.494Z] Command start: addNodeAbort
    [2017-02-06T18:34:22.501Z] Command end: addNodeAbort

  • On what firmware are you? What happens if you try to include it without the app side loaded?
  • I'm running on Homey Firmware Version: 1.1.4
    I tried adding the Roller Shutter without the Qubino App (removed it completely from Homey), by triggering the inclusion of a Fibaro module. 

    This initiated the same discovery process, with the 16 command-classes, but unfortunately also the same error.
  • I filed a bug:

    My guess is that this probably is a 1.1.4 bug, since you all probably succesfully added the DC module before firmware 1.1.4
  • @LeonVanDerRee  I think its related to the venetian blind support. Please check your bug report for my comments.
  • SkorpionSkorpion Member
    edited February 2017
    I tried to sideload the version of @clandmeter and the other branch as well, but both versions crash. I copied the files of the ZMNHOD1 from clandmeter into the master branch and installed this one. Everything seems to work, but when I start the interview process, it finds the module, but then I get "something went wrong". :(
  • Ik heb een qubino ZMNHDA2 aangesloten op een pulsschakelaar. Als ik knop 1 indruk gaat de lamp aan. Als ik nogmaals op knop 1 druk gebeurt er niets. Als ik op knop 2 druk gaat de associated lamp aan zolang ik de knop inhoudt. Zodra ik deze los laat gaat de lamp weer uit. Via een andere (fibaro) schakelaar en via de homey app kan ik de lamp wel aan en uit zetten. Welke instellingen moet ik doen zodat ik de lamp ook via de schakelaar kan schakelen.

    Alvast bedankt.
  • Welk type schakelaar heb je aangesloten?
  • Het is de busch jaeger 2020us-205. Deze gebruik ik zonder problemen ook met al mijn fibaro dimmers.
  • kastelemankasteleman Member
    edited February 2017
    heb je het juiste type ook gekozen in de settingspagina? Post anders ff een screenshot van je settingspagina
  • Is it technically possible to add a double/triple click flow trigger card?
  • Dat lijkt allemaal goed te staan. Heb je de busch jeager goed aangesloten? Bij qubino heb je de blauwe draad nodig.
Sign In or Register to comment.