This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.
Closed Official

[App] Fibaro by Athom (v1.5.18)



  • With Domoticz and the 255 + polling I had no green lights. Now, with all Greenwave nodes in Homey, I have had green leds for days. 
  • @caseda ;
    Yes, it is now working with S0 instead of S1... my bad......

  • Also where to read that mesh network needs hour(s) to re-build? 
  • mesh build-up: experience, and one of the other controllers is stating when you press the "manual heal" button, that it can take up to half an hour, but have seen cases on other forums that it can take longer before the network became stable. that's why i like to say, at least an hour
    Also because you don't know exactly when homey sends the heal command, you never get any feedback for it.
  • update on my pull request.

    At the moment it has not been included because athom is going to change a thing (productid's as an array) that will need to be updated in my pull request.
    As soon 0.9.3 is out and my pull request is updated to this new way, the pull request will probably (hopefully) pretty fast accepted.
  • That sounds nice, but also sounds like no update today......
  • and here is the update.! and have updated my pull request accordingly.

    My Timeline on the fibaro app at this moment:
    1. add drivers for FGS-213 and FGS-223
    2. figure out to change 3 devices -> 2 devices
    3. when the MultiLevelSwitch gets their MultiChannelNodes fixed will add scene activation for any modules that have them
    4. this also makes it possible to add drivers for roller shutter (v1 and v2) properly.
    5. add central_scene (the newer scene activation) triggers for devices that have them (FGS-2*3)
    6. add/extend the rest of parameters that are still missing from some devices (FGWPE-101, FGSS-001, FGSD-002, FGGC-001, FGRGBWM-441)
    don't expect much, if anything, this weekend, am pretty busy.
    But after this weekend you can expect a lot coming :smile: 

  • PeaoPeao Member
    Hopefully they'll update the fibaro app today, too...

    Thanks caseda <3
  • kastelemankasteleman Member
    edited August 2016
    Are the changes documented Or just look into github?? That is for the one driver with different product id's ?
  • casedacaseda Member
    edited August 2016
    @kasteleman ;;
    no not just the one device.

    Most device have 2-4 different ids some older products even go up to 10/11(!) productids

    before there were only 2 devices with multiple id's implemented (FGS-211 and FGS-221), but i have changed ALL drivers to have all the corresponding id's (i think, from the top of my head, that there are only 2 devices with only 1 product id now)

    i have not documented the id's the list would just be too long, if you wanna see the id's you can always look into the app.json file @github

    all things i do, i will write into the commit what i did (99% of the time at least) so will be documented there.

    if people want i can give a small recap in the README file what has been added/changed, but most of the time it's just drivers being added, and will be shown in the "supported devices" list.
  • @caseda what i wanted to say is if Athom documented the change already, how to do it. If not, i could have a look at the way you did it!
  • casedacaseda Member
    edited August 2016
    @kasteleman ;;
    They have not, i asked how exactly, but had no answer as of yet, so i just assumed it was the way i did it, because it's the most obvious way to do it.
  • snijplanksnijplank Member
    edited August 2016
    <Please Remove> :smile: 
  • Distinguish different relais... 

    In the pairing process, you get presented with icons of various Fibaro devices. Which one is the 222? Two double relay switches are shown. 

    Where can you see the icons, which are available in the installation directory?
  • @Eternity ;
    I don't understand? 
    The 222 is the only module that has 7 contact points (also shows in the icon) and there is a difference in the name:
    Old version: Double Relay Switch (fgs-222)
    Latest version: Double Relay switch 2
    Both unique names to the rest of the devices. 
  • Problem is that the icon is the same and the name gets cut off so you can't see it right away. I had the same with the motion sensor :smile: 
    You have to hover your mouse over the name to get a pop-up. 
  • EternityEternity Member
    edited August 2016
    Oh, right... 

    I have them screwed in the wall and haven't memorized the amount of contacts...
    Will test hovering!

    Thanks guys!
  • Hi guys, I tried my best looking for similar posts on this issue I have but haven't found any.
    Furthermore I do not know if this is the right place to ask because it was also an issue before the Fibaro app.
    Basic description of the issue: over time, Homey is unable to connect to a couple of dimmers.
    I have a couple of Fibaro dimmers and a motion sensor currently setup with Homey. It always takes two takes before the inclusion is succesfully concluded. After that I can control them without any problems and I have succesfully created a couple of flows that use the triggers from the sensor and then switch the lights on or off. Worked like a charm. 

    But after a couple of days (and this has happened several times, even after a complete reset of Homey) the Homey can't connect to some of the dimmers (they're within 10 meters of Homey). Now a couple of updates before there was this button on the Z-wave settings menu where you could restart the 'Z-Wave chip'. Most of the time that corrected the error and I could control them again with Homey. But that button is gone (and quite frankly I wasn't intending on pressing that button every once in a while). Right now the only solution (afaik) is to remove the devices and add them again. This will work for a couple of days, until the same issue occurs again.

    Question is: anyone familiar with this issue? And more importantly: does anyone have a solution for this?
    Thanks in advance for your help.

    Cheers, Roel
  • @roelvdberge ;
    Please take a look at this post of mine and check the placement of your dimmers/sensors.

    Also please look at Github if there's already an issue for the Reset Z-Wave chip (I thought there's one) and else create one.

    Also could you tell us which sensors/dimmers you are using (type/version/z-wave+(plus)/(un)secured paired/etc)?

  • edited August 2016
    I have the same issue that @roelvdberge mentions - three Fibaro motion sensors, fairly close (<5m) away from Homey, they work for a little while (ten mins up to a day) and then motion detection stops. I get the occasional lux and temp info, but that's it.

    These are all the Fibaro devices I have hooked up currently, one is in direct line of sight, 2 others are behind a single internal wall.

    What's the trick to get these things to work properly? Is there any way to get some debug information so I can see their current status? They're Zwave+, securely paired.
  • Hi Marco,

    Thanks for your fast reply!
    The sensor is the Fibaro FGMS-001 EU V3.2 (secure/Z-Wave+)
    The dimmers are Fibaro FGD-212 (secure/Z-Wave+). The dimmers are powered and behind 3 pulse switches. These switches work without any problems. The battery-powered sensor lies more or less between Homey and the powered dimmers. The sensor is approximatly 1,5m from Homey. The nearest dimmer is 10m. 

    I responded to the issue on GitHub. They say that resetting Homey should trigger the Z-Wave reset but in my case it didn't solve anything. Any more ideas? 
  • They're Zwave+, securely paired.


  • What, is that not good?
  • What, is that not good?
    It should work, but the Zwave+(plus) and especially secured pairing is showing a lot of issues.
  • Yeah, they respond for a while and then go silent again, very strange.
  • Yeah, they respond for a while and then go silent again, very strange.
    Not completely silent, at least not in my case. I have the Fibaro Motion Sensor zwave+ as well. Motion detection works for some time after a (soft) reboot as this does indeed restart the zwave chip as well on firmware 0.9.3. But I also experience that motion detection stops working after some time even though lux and temp keep working.
  • Yup, lux and temp work intermittently, battery indicator works only once after the initial pair. Now it's just a hyphen.

    Is there anything we can do about this? Other than sit and wait for :smile: 

  • Is there anything we can do about this? Other than sit and wait for :smile: 
    Walk around and wait for 1.0.0 .. ;-)
  • Phuturist said:

    Is there anything we can do about this? Other than sit and wait for :smile: 
    Walk around and wait for 1.0.0 .. ;-)
    Hehehe :smile: 
  • seeing all these problems with the Z-Wave+ version of the motion sensor, kinda happy i went the old Z-Wave route.

    But still, if i had one i could try to debug this issue, maybe it has already been fixed in my (ex) pull request?
    would like to hear when it lands in the app store (should be today or tomorrow).

    Further on my workings on the fibaro app:
    Have added support for the FGS-2*3 switches, so if anyone is willing to test this, that would be awesome.
    These also uses the different way when having multiple endnodes/endpoints/relays/switches.
    Endpoint 1 is now not included as a separate device anymore, but is now just the main device itself. (this is for all FGS modules)
    Still trying to figure out how to add name changing capabilities while including them, which should make it more user friendly.
This discussion has been closed.