This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Z-Wave does not work anymore

Yesterday I tried to change the language of my Homey from Dutch to English. After the Homey rebooted Z-wave does not work anymore. All of my devices are not recognized anymore and if I try to enter the Z-wave settings there is an error with a timeout warning and the remark that I have to reboot the Homey. I did that serveral time with no success. The language is Dutch again now but that does not solve the problem also. 

Look like the Z-wave drivers can not be loaded or something like that? I have no clue at all. Should I reset the Homey and loose all my settings and devices?


  • Did you try powering off Homey (PTP: pull the plug) for 15 minutes?
  • rtnartna Member
    bvdbos said:
    Did you try powering off Homey (PTP: pull the plug) for 15 minutes?
    Yep, twice. No difference.
  • Shut down all ur Zwave apps, PTP and wait till Homey forgets u was realy mad at her (minimum like 15 minutes) , Put her back in and wait, then start ur Zwave apps again carefully!
  • @rtna see

    Take the following steps:
    - Go to settings, send log to Athom and post the log code here or at
    - Disable all Z-wave apps 
    - PTP for more then 15 minutes
    - Start-up Homey again, wait for 15 minutes to allow the Z-wave network to restart completely
    - Start all apps 1:1
  • rtnartna Member
    Ok guys, thanks for so far. I'll come back to you after the reboot and after I'm cooled down ;-)
  • rtnartna Member
    That solved the problem. Any idea what went wrong here?
  • TedTolboomTedTolboom Member
    edited April 2017
    rtna said:
    That solved the problem. Any idea what went wrong here?
    No... 3rd report in short time.
    Do you have the Code for your LOG-file?
    Then I'm able to add it to the Github issue so Athom can look into it.

    Nevermind... see that you added it to the Github issue already
  • rtnartna Member
    Same issue again today. Zwave is not starting correctly after reboot. Filed report on Github. Does anyone else have these problems with Zwave?
  • casedacaseda Member
    edited May 2017
    there are 5 known people now that have this issue,
    you are the first one where it reappears though.

    should be fixed in 1.3 (which is now in developer preview, and probably reaches experimental channel next week)
Sign In or Register to comment.