This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Unable to add z-wave remote controllers (fakro zwp10 and ZME_054436 ) to homey

I have 3 Fakro zwp 10 remote controllers and 1 ZME_054436. These devices can act as a controller, but can also be included in an existing network. When i try to add them to Homey something goes wrong. 

What I tried:
When I add a default z-wave device to Homey and put one of the devices in learn mode, Homey recognise the device as controller. After that it says it can't connect to the device anymore, with the result that the device is not added to the network. 

When I add the device ZME_054436 to my old z-wave network domoticz. I noticed that the device is added as an unknown device when I use the inclusion button. But after sending a Node information it gets recognised correctly. 

Should I try to add controllers in another way to Homey? Or is this a bug?


  • the app is not supporting this unit as i found out also, i hope it will do one day as i also have this device.
  • Priknr1Priknr1 Member
    edited March 2017
    I might be able to help with the    I also added the WALLC-S and WALLC-S 2 for the app
    But not sure when I have the time

    Edit:  Found this one: (Precessor??)   :  064435

    If you are able to give me
    Manufacturer ID:

    Product Type ID:
    Product ID:
     for the 064436

    I can probably build you the driver

    Found it:
    I will have a look
  • -> looks like the device i have.

    Problem is that i can't add it to homey, so i can't figure out the product Id and product type. Maybe with version 1.2 but i don't have that installed.

  • Mentioned here before in the app topic:

    Hope it still gets added :)

  • @stimien
    Try resetting your device manually (so not from homey 's settings) . 
    Had the same yesterday when trying to re-include a device.

    It instantly says something went wrong .
    After manual reset it could include again
  • @caseda I think I tried that already after every new version. When 1.2 is released i'll try to add it again with all the possible options. For the record, i have never succeeded to add one of these devices to homey.
  • @luccie_007 @stimien
    I have copied the WALLC-S controller from another manufacturer (Devolo)  
    So now I have a base to work from with the 2 switches from above.  But that is no guarantee, it is all a big puzzle for me, but I have been able to copy/paste/steal code before into something working, so when I have the time, I will do my best to get these to controllers working.

    P.S. These controllers have the status End of Life, so if for some reason you want more of these instead of the WALLC-S,  buy them now.  check robbshop
  • I have 2 x ZME_06443 Wall Controllers with firmware version 1.1, with manual, see attachment.

    Manufacturer ID: 277
    Product Type ID: 4096
    ProductID: 4

    Until now I am unable to include them in the Homey Z-Wave network, mainly because the connection is lost, as Homey says. I think this is because they are battery-powered and are going to sleep rather fast.
    It would be very nice if I could re-use these 2 scene-controllers in my Homey network.

  • stimienstimien Member
    @caseda with version 1.2.2 there are no improvements. I still can't add both devices.

  • casedacaseda Member
    does the device you have the proper frequentie where homey works with?
    you can test this by using the "remove device" inside homey's settings -> z-wave -> [remove device]

    if no node is able to be found you have 3 things that can be wrong:
    1: your homey's  z-wave chip is damaged, this is only see able by including another z-wave device that you 100% know it works and is on the right frequentie, or by sending it back to athom
    2: your device has the wrong frequentie, and you will have to return it to the seller. (or throw it in the trashbin)
    3: you don't use the right inclusion/exlusion activation of your device
  • stimienstimien Member
    Yes it has the proper frequentie. It works fine with Domoticz and a z-wave stick. 
    Other z-wave devices are working fine. 

    Homey recognizes the device, but then connection is lost, or something went wrong. 
  • @stimien without log it's difficult to judge; at what moment does it fail during the inclusion process?

    I had a similar issue with the Remotec Scene Master, where it failed during INTERVIEW_MANUFACTURER_SPECIFIC.

    Yesterday, @Emile discovered a generic issue with the interview process that might hamper more devices from being included... is fixed in the next 1.3.x release.
  • casedacaseda Member
    could you try to reboot your homey, look into the settings -> z-wave -> stuff for geeks (below the log) until both
    `currentCommand:` and `currentProcess:` are empty
    and then try it again.

    if you still think the wallswitch is falling asleep before being done with inclusion (staying on 1 step too long) triple press the button so it wakes up again and homey can continue with getting all the information.
  • stimienstimien Member
    after a restart, command and process are empty.:
    for the 054436 zw ws:
    [2017-05-02T18:00:20.282Z] Command[36] start: addNode
    [2017-05-02T18:00:20.378Z] Command[36] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
    [2017-05-02T18:00:25.473Z] Command[36] status: addNode, status: ADD_NODE_STATUS_NODE_FOUND
    [2017-05-02T18:00:25.678Z] Command[36] status: addNode, status: ADD_NODE_STATUS_ADDING_CONTROLLER
    [2017-05-02T18:00:25.707Z] Node[3]: Received application command for COMMAND_CLASS_METER, data: 0x022134000000450000
    [2017-05-02T18:00:29.150Z] Command[36] status: addNode, status: ADD_NODE_STATUS_PROTOCOL_DONE
    [2017-05-02T18:00:29.258Z] Command[36] status: addNode, status: ADD_NODE_STATUS_DONE
    [2017-05-02T18:00:29.415Z] ProcessAddNode[35]: Error: TRANSMIT_COMPLETE_NO_ACK
    [2017-05-02T18:00:29.427Z] Command[36] end: addNode

    for the ZWP 10:
    [2017-05-02T18:01:47.793Z] Command[39] start: addNode
    [2017-05-02T18:01:47.841Z] Command[39] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
    [2017-05-02T18:01:53.211Z] Command[39] status: addNode, status: ADD_NODE_STATUS_NODE_FOUND
    [2017-05-02T18:01:53.305Z] Command[39] status: addNode, status: ADD_NODE_STATUS_ADDING_CONTROLLER
    [2017-05-02T18:01:55.104Z] Command[39] status: addNode, status: ADD_NODE_STATUS_PROTOCOL_DONE
    [2017-05-02T18:01:55.208Z] Command[39] status: addNode, status: ADD_NODE_STATUS_DONE
    [2017-05-02T18:01:55.449Z] ProcessAddNode[37]: Error: TRANSMIT_COMPLETE_NO_ACK
    [2017-05-02T18:01:55.455Z] Command[39] end: addNode

  • luccie_007luccie_007 Member
    edited August 2017
    Ik krijg het volgende met een 54436

    [2017-08-14T20:25:26.137Z] Command[85] start: addNode
    [2017-08-14T20:25:26.197Z] Command[85] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
    [2017-08-14T20:25:36.909Z] Command[85] status: addNode, status: ADD_NODE_STATUS_NODE_FOUND
    [2017-08-14T20:25:37.408Z] Command[85] status: addNode, status: ADD_NODE_STATUS_ADDING_CONTROLLER
    [2017-08-14T20:25:38.541Z] Command[85] status: addNode, status: ADD_NODE_STATUS_PROTOCOL_DONE
    [2017-08-14T20:25:38.697Z] Command[85] status: addNode, status: ADD_NODE_STATUS_DONE
    [2017-08-14T20:25:38.993Z] Command[85] status: addNode, status: INTERVIEW_MANUFACTURER_SPECIFIC
    [2017-08-14T20:25:38.999Z] Node[71]: sendData to COMMAND_CLASS_MANUFACTURER_SPECIFIC, params 0x04
    [2017-08-14T20:25:39.000Z] Command[86] start: sendData
    [2017-08-14T20:25:39.023Z] ProcessSendData[68]: To node: 71 with data: 0x7204 and txOptions: ACK,AUTO_ROUTE,EXPLORE
    [2017-08-14T20:25:39.180Z] ProcessSendData[68]: Marked node 71 as offline for the next 1800000ms
    [2017-08-14T20:25:39.181Z] ProcessSendData[68]: Error: TRANSMIT_COMPLETE_NO_ACK
    [2017-08-14T20:25:39.182Z] Command[86] end: sendData
    [2017-08-14T20:25:39.184Z] Command[85] end: addNode
    [2017-08-14T20:25:46.219Z] Command[87] start: addNodeAbort
    [2017-08-14T20:25:46.230Z] Command[87] end: addNodeAbort

    En als ik dan nog eens prober krijg ik de melding, node al toegevoegd (maar nergens vindbaar)
    [2017-08-14T20:27:25.503Z] Command[89] start: addNode
    [2017-08-14T20:27:25.510Z] Command[89] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
    [2017-08-14T20:27:49.611Z] Command[89] status: addNode, status: ADD_NODE_STATUS_NODE_FOUND
    [2017-08-14T20:27:49.876Z] Command[89] status: addNode, status: ADD_NODE_STATUS_ADDING_CONTROLLER
    [2017-08-14T20:27:54.775Z] Command[89] status: addNode, status: ADD_NODE_STATUS_PROTOCOL_DONE
    [2017-08-14T20:27:54.944Z] Command[89] status: addNode, status: ADD_NODE_STATUS_DONE
    [2017-08-14T20:27:55.099Z] Command[89] end: addNode
    [2017-08-14T20:27:59.448Z] Command[90] start: addNodeAbort
    [2017-08-14T20:27:59.450Z] Command[90] end: addNodeAbort

    Dan reset ik het device, want verwijderen van 71 gaat niet.
    Dan voeg ik hem erna weer toe als device 73, maar dezelfde fout.
    Tijdens het pairen bleef ik op de aan knop drukken zodat hij niet in sleep ging

    [2017-08-14T20:32:27.194Z] Command[98] start: addNode
    [2017-08-14T20:32:27.218Z] Command[98] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
    [2017-08-14T20:32:33.963Z] Command[98] status: addNode, status: ADD_NODE_STATUS_NODE_FOUND
    [2017-08-14T20:32:34.774Z] Command[98] status: addNode, status: ADD_NODE_STATUS_ADDING_CONTROLLER
    [2017-08-14T20:32:42.989Z] Command[98] status: addNode, status: ADD_NODE_STATUS_PROTOCOL_DONE
    [2017-08-14T20:32:43.202Z] Command[98] status: addNode, status: ADD_NODE_STATUS_DONE
    [2017-08-14T20:32:43.642Z] Command[98] status: addNode, status: INTERVIEW_MANUFACTURER_SPECIFIC
    [2017-08-14T20:32:43.649Z] Node[73]: sendData to COMMAND_CLASS_MANUFACTURER_SPECIFIC, params 0x04
    [2017-08-14T20:32:43.650Z] Command[99] start: sendData
    [2017-08-14T20:32:43.652Z] ProcessSendData[76]: To node: 73 with data: 0x7204 and txOptions: ACK,AUTO_ROUTE,EXPLORE
    [2017-08-14T20:32:43.799Z] ProcessSendData[76]: Marked node 73 as offline for the next 1800000ms
    [2017-08-14T20:32:43.799Z] ProcessSendData[76]: Error: TRANSMIT_COMPLETE_NO_ACK
    [2017-08-14T20:32:43.801Z] Command[99] end: sendData
    [2017-08-14T20:32:43.803Z] Command[98] end: addNode
    [2017-08-14T20:32:50.497Z] Command[100] start: addNodeAbort
    [2017-08-14T20:32:50.499Z] Command[100] end: addNodeAbort

  • Priknr1Priknr1 Member
    edited August 2017
    I have a RC2 myself, which is a handheld remote.  I havent been able to succesfully include it yet. And I am figuring that it is the same issue as with the 54436. 

    For now I am affraid I cant help. It is still out of my league when it comes to programmign skills
  • If I read it all then it is just a remote that falls asleep during inclusion and you need to triple press the button, wait 5 seconds, triple press again, wait 5 seconds, and repeat that until it is included (so not hold the button!) 

    This is something completely out of the hands of homey, or the app. 
    And also not a thing that can be implemented since a controller (in this case homey) can't keep a device awake, the device can only do that itself.
  • caseda said:
    If I read it all then it is just a remote that falls asleep during inclusion and you need to triple press the button, wait 5 seconds, triple press again, wait 5 seconds, and repeat that until it is included (so not hold the button!) 

    This is something completely out of the hands of homey, or the app. 
    And also not a thing that can be implemented since a controller (in this case homey) can't keep a device awake, the device can only do that itself.
    Thats what i understand to,
    BUT i already tried this, although a bit differently by continously clicking the button, without the triple press 0,5 second rhytm.
  • damn still isues pairing zwave
    now i have it pared as unknown controller, i can even see the data comming in, but i cannot us it in flows as a device
    because it is nowhere to be found as a device
    2017-08-17T19:01:28.246Z] Node[119]: Received application command for COMMAND_CLASS_BASIC, data: 0x01ff
    [2017-08-17T19:01:50.777Z] Node[119]: Received application command for COMMAND_CLASS_BASIC, data: 0x0100
    thats the on and off button
    but during pairing you van get 2 options:  lost communication try moving it closer, or something went wrong,
    and when i try to re-pair the device it says, its already paired.
  • luccie_007luccie_007 Member
    edited August 2017
    Oke, ik heb iets werkend en dit is voldoende voor nu, maar ik dnek dat het officieel anders moet ;)

    Mijn doel is om met deze plak schakelaar een andere zwave module te bedienen die ook aan de homey hangt.

    Dit betekend dus dat er op 3 plekken de lamp aan en uitgezet kan worden = "Hotel schakeling" zonder draden

    Stap 1
    Voeg de dimmer/switch toe aan je homey op normale wijze. Hierdoor komt hij in het homey netwerk
    Voeg de remote control toe als volgt:
    Laat homey naar Z-Wave luisteren,
    Druk 3 seconde op include, de lamp gaat knipperen en als homey hem vind sneller.
    Druk hierna 3x snel op de up toets.
    Als de homey zegt lost connection ben je klaar.
    De schakelaar denk dan dat hij in hetzelfde netwerk zit als de homey.
    Hierdoor kan hij erna ook de dimmer vinden.

    Als hij zegt something went wrong moet je nog eens proberen, en eventueel de switch resetten (zie bovenstaande linkjes)

    Controle stap:
    Ga naar zwave -> stuff for geeks,
    1 in je netwerk moet een unknown device hangen
    2 als je op de aan of uit knop drukt meot je in de log een melding krijgen van een basic command die ontvangen is.
    VB: 2017-08-17T19:01:50.777Z] Node[119]: Received application command for COMMAND_CLASS_BASIC, data: 0x0100

    Dan zit je controller in hetzelfde netwerk als homey, alleen de homey kan er verder helemaal niks mee.

    Stap 3
    1. Press Assoc for 3 seconds (fast green blinking),
    2. Then on the top button (long green blinking),
    3. Then, on the button of the module to be controlled (for example, simply press the button of an AEON DSC06 / DSC08 plug module or triple press the button of a Fibaro micro-module, check the procedure in the module manual )
    4. The light should turn green and then go out.
    Nu krijg je dus de status van de dimmer in homey binnen omdat de dimmer werkt via de normale toevoeging.
    En de controller bediend direct de dimmer zonder delay van de homey. :D

    Status van de dimmer komt helaas niet binnen, nu even testen of dat bij al mijn dimmers zo is.

    Als ik nog zin heb vertaal ik het nog, want zie nu dat ik in het nederlands heb getypt.

  • luccie_007luccie_007 Member
    edited August 2017
    Het allergekste komt nu:

    Mijn 3e schakelaar is gewoon goed gepaired.
    Als onbekende dan wel, maar het pairen ging tot het einde goed.

    Ze zijn nu alle 3 goed gepaired, moest ze wel binnen 50cm van homey houden, en zelfs dan een paar keer proberen/resetten.
    Helemaal content nu, alleen jammer van dimmer waarde dat die niet richting homey wordt gestuurd.

    @Priknr1 ;  Staat hier de data in die jij nodig hebt om er een herkend device van te maken?

    Zie log:

    [2017-08-17T19:50:11.112Z] Command[1788] start: addNode
    [2017-08-17T19:50:11.136Z] Command[1788] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
    [2017-08-17T19:50:15.835Z] Command[1789] start: sendData
    [2017-08-17T19:50:15.842Z] Command[1790] start: sendData
    [2017-08-17T19:50:15.863Z] Command[1791] start: sendData
    [2017-08-17T19:50:17.877Z] Command[1788] status: addNode, status: ADD_NODE_STATUS_NODE_FOUND
    [2017-08-17T19:50:18.356Z] Command[1788] status: addNode, status: ADD_NODE_STATUS_ADDING_CONTROLLER
    [2017-08-17T19:50:19.287Z] Command[1788] status: addNode, status: ADD_NODE_STATUS_PROTOCOL_DONE
    [2017-08-17T19:50:19.384Z] Command[1788] status: addNode, status: ADD_NODE_STATUS_DONE
    [2017-08-17T19:50:19.421Z] Node[1]: Received application command for an unknown Command Class, data: 0x800340
    [2017-08-17T19:50:19.667Z] Command[1788] status: addNode, status: INTERVIEW_MANUFACTURER_SPECIFIC
    [2017-08-17T19:50:19.680Z] Node[124]: sendData to COMMAND_CLASS_MANUFACTURER_SPECIFIC, params 0x04
    [2017-08-17T19:50:19.869Z] Command[1792] end: sendData
    [2017-08-17T19:50:19.878Z] Node[124]: Received application command for COMMAND_CLASS_MANUFACTURER_SPECIFIC, data: 0x05006450020000
    [2017-08-17T19:50:19.891Z] Command[1788] status: addNode, status: INTERVIEW_ASSOCIATION
    [2017-08-17T19:50:19.892Z] Node[124]: sendData to COMMAND_CLASS_ASSOCIATION, params 0x05
    [2017-08-17T19:50:19.892Z] Command[1793] start: sendData
    [2017-08-17T19:50:19.894Z] ProcessSendData[1732]: To node: 124 with data: 0x8505 and txOptions: ACK,AUTO_ROUTE,EXPLORE
    [2017-08-17T19:50:19.922Z] Command[1793] end: sendData
    [2017-08-17T19:50:19.928Z] Node[124]: Received application command for COMMAND_CLASS_ASSOCIATION, data: 0x0601
    [2017-08-17T19:50:19.930Z] Node[124]: sendData to COMMAND_CLASS_ASSOCIATION, params 0x0201
    [2017-08-17T19:50:19.930Z] Command[1794] start: sendData
    [2017-08-17T19:50:19.934Z] ProcessSendData[1733]: To node: 124 with data: 0x850201 and txOptions: ACK,AUTO_ROUTE,EXPLORE
    [2017-08-17T19:50:19.971Z] Command[1794] end: sendData
    [2017-08-17T19:50:19.992Z] Node[124]: Received application command for COMMAND_CLASS_ASSOCIATION, data: 0x03012000
    [2017-08-17T19:50:19.993Z] Node[124]: sendData to COMMAND_CLASS_ASSOCIATION, params 0x010101
    [2017-08-17T19:50:19.993Z] Command[1795] start: sendData
    [2017-08-17T19:50:19.996Z] ProcessSendData[1734]: To node: 124 with data: 0x85010101 and txOptions: ACK,AUTO_ROUTE,EXPLORE
    [2017-08-17T19:50:20.021Z] Command[1795] end: sendData
    [2017-08-17T19:50:20.054Z] Command[1788] end: addNode
    [2017-08-17T19:50:20.230Z] Node[124]: Marked as online
    [2017-08-17T19:50:20.232Z] Node[124]: Received application update: 0x0101728085ef2026278582
    [2017-08-17T19:50:30.234Z] Node[124]: Marked as offline

  • @luccie_007
    to make it a recognizable devide, I need Manufacturer ID, Device type ID and device ID.
    But I have no experience adding a controller (other than copying the WALLC-S from the devolo app.

    So even if I have those, no guarantee whatsoever that this would work properly than. I am just not nearly programmer enough for that.
  • luccie_007luccie_007 Member
    edited August 2017

    Hopefully this will do,
    I added some found github code from Openzwave where they added this device aswell.

    Battery: Yes
    Manuf ID: 100
    Product Type ID: 20482
    Product ID: 0000
    Device class (basic): BASIC_TYPE_CONTROLLER
    Device class (generic): GENERIC_TYPE_GENERIC_CONTROLLER

  • Sorry to bump this topic, but did you ever succeed in adding your Fakro remote to Homey? :)
  • JonJon Member
    Sorry to bump this topic, but did you ever succeed in adding your Fakro remote to Homey? :)
    I'm also interested to hear about that! 
Sign In or Register to comment.