This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

[Z-Wave] NodOn [v 1.1.0]

casedacaseda Member
edited March 2017 in Apps
Initial Post for the brand NodOn.
App Store

I have the NodOn Octan Remote, and it still needed an app, so have created one.

Update: 02-09-2016:
- 1.0.0 Has been approved and is published in the app store.
- Update 1.0.1 (add support wall switch) has been accepted.

If you have a device from NodOn that you want included, just ask for it, and i will (try) to include it in the app.


  • I have the NodOn Soft Remote. Would very much appreciate if you include this on. 
  • casedacaseda Member
    edited August 2016
    @Aljoen ;
    i have added the soft remote, it will be available as soon as it is accepted in the store
  • Thanks. Great work
  • caseda said:
    @Aljoen ;
    i have added the soft remote, it will be available as soon as it is accepted in the store
    I have an additional question: Can you add the wall switch as well?
    As far as I know the soft remote, the wall switch and the Octan remote are (almost) identical software wise. Except for things like the product ID.

    Thanks in advance..
  • They are indeed practically the same. 
    The only big change is the icons and images.
    So will add the wall switch as well.

    Will be added after it has been accepted in the app store, and the update for this addition has been accepted as well.
  • Thanks!
  • and the app has been published in the appstore.! yay for my first app.

    Update 1.0.1 that adds support for the wall switch has also been submitted for approval
  • Thanks, works like charm :smiley: 
  • 1.0.1 works perfect for the wall switch. Thanks for your effort!

    I have one question: does somebody knows how to make the dimmer dim up or down when the button is constantly being pressed?
  • Its one of the issues on github now, to add the functionality of "relative dimming control"
  • How can I make the wall switch control my lights using associations?

    Node 5 and node 6 are everspring dimmer plugs. But this configuration doesn't work.
  • you will need to change 2 of the parameters that i did not made possible to change as normal settings because it will currently stop letting homey know you press buttons, you can still do it with raw parameters:
  • he @caseda I'm a bit confused about your answer. Why did you not enable such a common scenario? Is this a bug in Homey or a shortcoming of the Nodon hardware?
    Are you suggesting that the only way is to control the lights using a flow?
    What do the Raw parameters mean? And why do they magically make everything work, even changing dimming level on long press!! Thanks!
  • it is exactly the reason that i told you.

    In the current way I've implemented them, homey will not trigger ANY triggers anymore, besides it being in the Scene mode it's in by default.
    if i had implemented the setting already, and people change it, they will definitely complain that it doesn't work anymore :wink: 

    the occasional someone that want to use it as a dimmer, will come here and are then being told it doesn't trigger inside homey anymore, and can do it easily with raw parameters. 
    cause even if i put that in the read me, they won't read it anyway :smiley:

    in the future i will add both other ways of triggering into homey. just too many thing to be implemented (and fixed)
    all basics first, extra's later
  • so with the raw parameters I can't use the double click scene triggers anymore right?
  • casedacaseda Member
    edited October 2016
    well depends if you want to use one side of the remote (2 buttons) as a dimmer, you can use the other 2 for double click (etc).

    the not being able to double click because it's in DUO mode (that's what dimming mode is called) is because that's the way the remotes work

    it's either, being able to use,
    single, double, hold and release
    MONO (every button can be pressed once)
    DUO (dimming mode)

    no "and, and" possible unfortunately that is not something i can do anything about...
    well maybe with a workaround, an action card ([THEN] column) that lets you switch the mode, (and then wake up the remote...) but you will have to flow trigger that on every mode you use :tongue:
    maybe will implemented that in the future as well
  • casedacaseda Member
    edited March 2017
    This evening the app will be updated to 1.1.0
    This version includes all zwave devices nodon still has left (smart plug and micro smart plug)

    Fixed a core change that made the settings save button disabled, the reason has to do with the wakeup interval that should only be 0.

    Added battery alarm capability to the 2 remotes and wallswitch.
     to be able to use this function you will need to re-include it to homey. 
    But this is optional, so if you don't need /want the capability you don't have to do anything, it will keep working just fine.

    Also added the settings for the remotes and wallswitch to use them better in direct associations (single and dual button control) 
    This includes flow triggers but is way more limited then scene control (default way) nothing I can do about that unfortunately. 

    Tested everything thoroughly, but if you still find something that doesn't work as you expect, don't be shy to let me know

  • Can somebody tell me how I can connect my nodon wallswitch to mine Homey? I try to add it with the button combination, but the interview fails everytime. Wat I do wrong?  
  • casedacaseda Member
    edited April 2017
    @marclu Try resetting it manually once (hold the 2 bottom buttons) 

    If that does not work, on which step does it timeout
  • caseda said:
    @marclu Try resetting it manually once (hold the 2 bottom buttons) 

    If that does not work, on which step does it timeout
    I have reset the wall switch several times. When I push the two upper buttons of the wall-switch, the led blinks purpel. then I push the left button. Nothing will happen. Homey is still showing which buttens I have to press. When I push another button on the wall-switch the led is blinking red. After a wile i get a time out
  • It can take 2 seconds after pressing the top-left switch part

    Do you have it within 2 meter of homey and are you able to delete the device from homeys settings -> z-wave? 

    If not, were/are you able to add more zwave devices to homey? 

    If you can, then there is a big chance you don't have the proper zwave frequency or the device is broken

    If you can not (or don't have more zwave devices) then it can be your homey that is faulty. 
  • Hi Caseda, thank you for youre support.

    I try to connect the wall swich at within a distance of 50 cm from my Homey.
    I have connected two other z-wave switches from Fibaro. These work properly.

    on the box there from the nod-on wall-switch is z-wave+ mark. Can that be the issue?

  • casedacaseda Member
    edited April 2017
    No, zwave plus is the version 5 of the zwave protocol, where the "normal" zwave is version 3.
    Frequency is talking about the mhz it is sending on, this is different for different parts of the world. 

    Not sure if there is a frequency on the box, or if nodon even delivers other frequencies since it's a pure French company.
    But that is why I asked for the remove device in homeys settings -> zwave. 
    If that doesn't give the message that it successfully has been removed, but states that it couldn't find a device to remove, then your switch is dead or the wrong frequency.

    If it does give the message that it was successfully removed, then it should include just fine.
    Maybe try a reboot of homey before trying again.
  • Yeah, it works finaly.
  • Hi there, I have added a NodOn Smartplug (Product Type 1 - Product ID 1) and the basic ON/OFF is working but the power reporting doesn't work. Can you add that?
  • @d_janssen If you can supply me with the signal it sends for power measurement (COMMAND_CLASS_METER or COMMAN_CLASS_MULTILEVEL_SENSOR) found in the zwave log (homey settings, zwave, stuff for geeks) 
    Then I am more then happy to add it.

    But both nodon and the webshop cannot give me this information, but gave me the answer that the zwave version of the (big) plug does not support power metering
    Only the enocean and micro support it
  • Hmm, can't reproduce this yet, very strange :/
  • caseda said:
    Hmm, can't reproduce this yet, very strange :/
    Fixed the issue late last night. Did the following:

    1. Excluded the unit
    2. Tried to include it again but got the message "Something went wrong" (or something similar)
    3. Excluded it (even though it didn't include earlier)
    4. Factory reset the unit ( by holding button 3 and 4 until the blinking of red and green)
    5. Included it again with a successful inclusion.

    It works perfectly fine for now :)

  • Hmm, then you are a first where settings get disabled because of a failed (?) inclusion.
    Shouldn't be happening thanks to the way it is implemented.

    Oh well, for everything a first I guess, happy that it works for you know, let me know if it happens again, then it needs a fix in the core probably.
Sign In or Register to comment.