Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.

[APP] Z-Wave.Me

IcarusIcarus Member
edited March 28 in Apps

[APP] Z-Wave.Me

This app adds support for Z-Wave.Me devices to Homey.

Note: I created this app to add support for one of my devices. Feel free to change it as you please! God bless open source software!

Currently supported devices:

Currently supported languages:

  • English
  • Dutch (Nederlands)
  • Germany (Deutsch)

Additional information:


Changelog:

For recent release notes see: https://github.com/IcarusProject/me.zwave

v0.0.9

  • Removed double device (05433 - manufacturerId: 100 productTypeId:4096 productId: 9)

v0.0.8

  • Added support for the 054375
  • Added support for the 064394
  • Added support for the 064367
  • Added support for the 054336
  • Added support for the 05433
  • Changed wrong link to pictures of 054367Z

v0.0.7

  • Updated to latest Z-Wave driver

v0.0.6

  • Added support for the 05458

v0.0.5

  • Added support for the 054313

v0.0.4

  • Added basic support for the 054367Z

v0.0.3

  • Added basic support for the 05461: Dual load switch

v0.0.2

  • Replaced a couple of icons, fixed a slider issue and removed the tinycolor2 package (since it's not used)

v0.0.1:

  • First version
«1345678

Comments

  • Not sure why you can't get this app submitted to the app-store, but one word of advise, please use an email address that you will read. I think Athom uses this address to send crashlogs etc if your app would crash. 

    There are enough free 'privacy-aware' email services that you could use. 
  • I also created a driver for the dimmer :).
    https://github.com/bkockx/homey-zwave.me

    Anyway I got the response that the id is already claimed by somebody else.

  • I also created a driver for the dimmer :).
    https://github.com/bkockx/homey-zwave.me

    Anyway I got the response that the id is already claimed by somebody else.

    Might be a good idea to merge your source with mine? I just checked and I can see that you paring images for example look much better than mine. Difference between your and my version is also that I added configuration properties to the device (and Germany translations --> as good as possible)
  • aloft said:
    Not sure why you can't get this app submitted to the app-store, but one word of advise, please use an email address that you will read. I think Athom uses this address to send crashlogs etc if your app would crash. 

    There are enough free 'privacy-aware' email services that you could use. 
    Athom just fixed the approval issue. You might be right about the email address. I changed it (although you should create issues in GIT if you have any ;) )
  • swtttswttt Moderator
    Awesome, now i don't have to write my own :smiley: 
    Great job, and thanks!
  • Good idea to merge.

    I'll create a pull request with the images.
    Also there is a thing with the homey slider it counts from 0-100.
    The device does not accept 100. at least mine did not.
  • I have a zwave.me ZME_05433, but that does not like to be paired with your zwave.me app
    Do you know if the version of the zwave.me switch is the causing issues?

    I was able to pair it to homey using homeys zwave app (0.39), but since 0.9.1 homeys zwave app does not get it liked.



  • RobinVanKekemRobinVanKekem Backer - Homey
    KeepT said:
    I have a zwave.me ZME_05433, but that does not like to be paired with your zwave.me app
    Do you know if the version of the zwave.me switch is the causing issues?

    I was able to pair it to homey using homeys zwave app (0.39), but since 0.9.1 homeys zwave app does not get it liked.
    What numbers does it have when you click on the wrench of the device and you open the node information?
  • KeepT said:
    I have a zwave.me ZME_05433, but that does not like to be paired with your zwave.me app
    Do you know if the version of the zwave.me switch is the causing issues?

    I was able to pair it to homey using homeys zwave app (0.39), but since 0.9.1 homeys zwave app does not get it liked.
    What numbers does it have when you click on the wrench of the device and you open the node information?
    Robin,

    I don't exactly know what you mean. I cannot add the device to homey any more. (not using the homey-build app nor with @Icarus app. How should I obtain the node info?


  • @KeepT. The problem might be that the device is still connected to your homey. Try the following.
    1. Login to your homey;
    2. Go to the settings page;
    3. Go to the z-wave page;
    4. Click on 'remove a device';
    5. Triple press either to on or off button on your z-wave device that your are trying to add;
    6. This will remove any configuration regarding that z-wave device from your homey.
    After that try to add the device again using my app. If that returns the same result (not working properly) repeat the above steps. Afterword try to add the device using the builtin z-wave drive that comes with homey. If you can add the device then send me a screenshot of the'Node information' on the settings page of your device. For example:

  • @Icarus ,

    Thanks for the advice, I will try tonight.
    The device might still be connected to homey (although homey currently does not display any connected zwave device). And reconnecting would indeed fail if it was already connected (somehow invisibly).
    I'll post the result later....

  • @Icarus ;

    Hi Icarus my homey is not detecting my ZME_05433 my node information is:




  • @Menno: I took a look at the information your provided but I can't seem to find a Manufacturer ID (100) in any of my code. The devices currently supported are '054336Z' and '05461'. Did you check the supported devices before installing the driver-app? There is quite a list of Zwave.Me devices and I'm personally not planning to implement them all. If you are missing a device feel free to alter the github code. I will add the app to the appstore when ever posible on my side.
  • Hey Guys,

    I see that the 3 of you (3 contributers to the app) haven't been working on this app anymore. Right?

    I have several Duwi switches for blinds control, dimmers and wall switches.
    I want to add them in this code, and also add the options for flow.

    So I downloaded the sourcecode, and will start adapting it. Just want to make sure that none of you is already doing the same.

    When I have finished for all my  devices, can I submit the new changes myself to athom / github, or do you have to do is as author @Icarus ?


  • Athom won't accept a second app for one brand in the App-store.
  • @Priknr1 . I'm currently not working on any support for the mentioned devices or for flows. So just create a branch from my source and change whatever you want to. Afterwords just push to my repository. I will review your changes (briefly) and will start an update process for the Athom app store.
  • Priknr1Priknr1 Moderator
    edited September 2016
    @Menno
    Started adding devices to the zwave.me driver.
    Yours is in there, so hang on, as soon as I am done, Icarus will request an update of the app at Athom.
  • @Priknr1 I did not have much time to work on this app.

    Are you planning to add the Flush mountable switch?
    ManId: 277
    ProductTypeID: 4096
    Product ID: 1

    If not I will add it soon so it can go into 1 app store submission?
  • @RadientBee I will add it for you.
  • Thanks
  • I also just installed the app and tried to add my dimmer, through the app but it was not recognized.
    What do you need to add it?

  • @Priknr1 ;
    thanks would be great if dim is working again. Can only give my dimmers now on/off command.
  • I also just installed the app and tried to add my dimmer, through the app but it was not recognized.
    What do you need to add it?

    @Priknr1

    What can i do for you, so it becomes possible to add?
  • MennoVanDerAatMennoVanDerAat Backer - Geek Edition
    Hoi @Priknr1 ,

    Should it already work? or does the app still needs to be updated?
    I tried it this morning and it still doesn't find the device and add's it as an unknown z-wave device

    If the app still needs to be update no problem I wait for it thanks for adding the code anyway
  • Priknr1Priknr1 Moderator
    Hey guys, I am sorry for the delay.
    I have been on holiday, and right now I am extremely busy with work.

    I have written part of the drivers, but have not been able to test things at home.
    I will see and hope that I can do this in the next 2 weeks. But no prom,ises here. sorry.
  • PhuturistPhuturist Member
    edited October 2016
    Priknr1 said:
    Hey guys, I am sorry for the delay.
    I have been on holiday, and right now I am extremely busy with work.

    I have written part of the drivers, but have not been able to test things at home.
    I will see and hope that I can do this in the next 2 weeks. But no prom,ises here. sorry.
    @Priknr1  I'd like to see support for the Duwi ZW ES 1000 / 54313 flush mounted switch (http://www.pepper1.net/zwavedb/device/18) in this app. Are you currently working on this one as well or should I add it myself?

    [EDIT] Nevermind, created a pull request already.
  • Just bought a set of zwave stuff.

    The wall controller is not available.
    Link to zwave spec sheet:
    http://manuals.zwaveeurope.com/make.php?lang=en&type=mini&sku=ZME_054436&pdf=1

    Hope it can be added, because i bought 3.

    Now going to test the dimmers i bought

  • Any change of adding support for the http://products.z-wavealliance.org/products/1086  to the app any time soon?


  • Just bought a set of zwave stuff.

    The wall controller is not available.
    Link to zwave spec sheet:
    http://manuals.zwaveeurope.com/make.php?lang=en&type=mini&sku=ZME_054436&pdf=1

    Hope it can be added, because i bought 3.

    Now going to test the dimmers i bought

    I have one of those(ZME_054436 ) too. I can't connect it to homey at all. When i add it through Homey -> Z-wave -> hold include button for 3 seconds. Homey reports: "Node geidentificeerd als controller". Little bit later: "Het apparaat kan niet meer bereikt worden"
      Can you add it to Homey?
  • stimien said:
    Just bought a set of zwave stuff.

    The wall controller is not available.
    Link to zwave spec sheet:
    http://manuals.zwaveeurope.com/make.php?lang=en&type=mini&sku=ZME_054436&pdf=1

    Hope it can be added, because i bought 3.

    Now going to test the dimmers i bought

    I have one of those(ZME_054436 ) too. I can't connect it to homey at all. When i add it through Homey -> Z-wave -> hold include button for 3 seconds. Homey reports: "Node geidentificeerd als controller". Little bit later: "Het apparaat kan niet meer bereikt worden"
      Can you add it to Homey?
    Mine always says:  Something went wrong.  on al 3 devices i have.

Sign In or Register to comment.