Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.

How-To - Aeotec MultiSensor 6

2456712

Comments

  • JerryvdvJerryvdv Backer - Homey
    Did anyone figure out how to increase the reporting time? I am not able to get it reporting more than once an hour.
  • DaneeDeKruyffDaneeDeKruyff Backer - Super Early Bird
    It should work by setting the following parameter: 111,4,1800 AND setting the z-wave wakeup interval at 1800. Not sure I've tested this yet on 0.8.32 but I tested it on 0.8.30 and got a report every half hour.
  • JerryvdvJerryvdv Backer - Homey
    It should work by setting the following parameter: 111,4,1800 AND setting the z-wave wakeup interval at 1800. Not sure I've tested this yet on 0.8.32 but I tested it on 0.8.30 and got a report every half hour.
    Thanks for the quick reaction again Danee. I have the same settings and am on 0.8.32, however it still reports only on the hour. I'll try reinstalling the sensor tomorrow, perhaps it will help. :smile: 
  • TedTolboomTedTolboom Backer - Geek Edition
    edited May 2016
    Jerryvdv said:
    Did anyone figure out how to increase the reporting time? I am not able to get it reporting more than once an hour
    @Jerryvdv ;Which FW and which settings (specifically what is the lowest value) have you tried?
  • JerryvdvJerryvdv Backer - Homey
    @Jerryvdv ;Which FW and which settings (specifically what is the lowest value) have you tried?
    Hi Ted,

    I'm on 0.8.32 and have the current settings:
    5,1,2;3,2,10;40,1,1;43,2,10;101,4,241;111,4,600

    I have tried 60 seconds as my lowest value (as it's not battery powered).
  • DaneeDeKruyffDaneeDeKruyff Backer - Super Early Bird
    edited May 2016
    @Jerryvdv ;Did you get any result from setting 43,2,10? I've tested with that too, but it didn't work for me.
  • TedTolboomTedTolboom Backer - Geek Edition
    edited May 2016
    @Jerryvdv and @DaneeDeKruyff did any one of you test to set a parameter to a extremely low setting (e.g. 1 - 3)?
    See my last update in Z-Wave: Fibaro multisensor

    With this sensor, there is apparently an offset of ~255x in setting several parameters. Meaning that settings a parameter to a value of 1 second, the actual interval will be 255 seconds.

    I did the testing today (so no feedback from Athom), but it would be interesting to get the confirmation that this is a Z-wave generic issue (and not Fibaro specific)..
  • JerryvdvJerryvdv Backer - Homey
    @Jerryvdv ;;Did you get any result from setting 43,2,10? I've tested with that too, but it didn't work for me.
    No results here.

    @Jerryvdv and @DaneeDeKruyff did any one of you test to set a parameter to a extremely low setting (e.g. 1 - 3)?
    See my last update in Z-Wave: Fibaro multisensor

    With this sensor, there is apparently an offset of ~255x in setting several parameters. Meaning that settings a parameter to a value of 1 second, the actual interval will be 255 seconds.

    I did the testing today (so no feedback from Athom), but it would be interesting to get the confirmation that this is a Z-wave generic issue (and not Fibaro specific)..
    Just tried setting it to 3, it does not appear to change anything (If it does overnight I'll let you know tomorrow morning).
  • TedTolboomTedTolboom Backer - Geek Edition
    @Jerryvdv You've saved the setting to 43,2,3 in the device card and than manually updated the sensor?
    I don't expect that the sensor went through it's wakeup interval by itself; you're response was too fast for that.

    My suggestion: after saving the settings, manually update the sensor and reboot Homey afterwards
  • JerryvdvJerryvdv Backer - Homey
    @TedTolboom Yes, I have. This morning showed no results, hence I performed a reboot of Homey just to be sure.. Sadly no results.
  • TedTolboomTedTolboom Backer - Geek Edition
    edited May 2016
    Jerryvdv said:
    @TedTolboom Yes, I have. This morning showed no results, hence I performed a reboot of Homey just to be sure.. Sadly no results.
    @Jerryvdv ;I don't have a Aeon sensor myself... I just briefly read through the manual...
    it does makes sense that you do not see a difference.

    Parameter 43 is defining the threshold based on which illumination reports are being send (and is a 2-byte parameter)... You just set it to 3 (Lux). Assuming that the same factor is applicable for all Z-wave devices; Homey changed the threshold to 3x255 Lux = 765 Lux.

    With an indoor positioned sensor, you will not see these light intensity changes....
    I would change this one back to defaults.

    The parameter to look for is 111:
    Parameter 111-113 [4 byte decimal] can be con gured through your gateway in case the default settings of your MultiSensor are not what you desire. Parameter 111 will set the interval for Group 1 (parameter 101), parameter 112 will set the interval for Group 2 (parameter 102), and parameter 113 will set the interval for Group 3 (parameter 103). As an example, you have set parameter 101 to 241 which will report all of the sensors, and you want to report it every 1800 seconds. Set parameter 111 to 1800 to accomplish this. 
    But this is a 4-byte size parameter and I don't know if the same factor applies for 4-byte size parameters...
    You could try a relative should value (e.g. 10) and see what the interval in Insights will be...
  • DaneeDeKruyffDaneeDeKruyff Backer - Super Early Bird
    Jerryvdv said:
    @TedTolboom Yes, I have. This morning showed no results, hence I performed a reboot of Homey just to be sure.. Sadly no results.
    @Jerryvdv ;I don't have a Aeon sensor myself... I just briefly read through the manual...
    it does makes sense that you do not see a difference.

    Parameter 43 is defining the threshold based on which illumination reports are being send (and is a 2-byte parameter)... You just set it to 3 (Lux). Assuming that the same factor is applicable for all Z-wave devices; Homey changed the threshold to 3x255 Lux = 765 Lux.

    With an indoor positioned sensor, you will not see these light intensity changes....
    I would change this one back to defaults.

    The parameter to look for is 111:
    Parameter 111-113 [4 byte decimal] can be con gured through your gateway in case the default settings of your MultiSensor are not what you desire. Parameter 111 will set the interval for Group 1 (parameter 101), parameter 112 will set the interval for Group 2 (parameter 102), and parameter 113 will set the interval for Group 3 (parameter 103). As an example, you have set parameter 101 to 241 which will report all of the sensors, and you want to report it every 1800 seconds. Set parameter 111 to 1800 to accomplish this. 
    But this is a 4-byte size parameter and I don't know if the same factor applies for 4-byte size parameters...
    You could try a relative should value (e.g. 10) and see what the interval in Insights will be...
    To be sure, I set 111 yesterday evening, it seems it doesn't work anymore on 0.8.32. 

    (https://forum.athom.com/discussion/comment/21340/#Comment_21340)
  • TedTolboomTedTolboom Backer - Geek Edition
    @DaneeDeKruyff ; Can you try to set is at a value of e.g. 10? Which most likely corresponds to an update interval of 42 minutes (2550 seconds)
  • DaneeDeKruyffDaneeDeKruyff Backer - Super Early Bird
    @TedTolboom no sorry, not now, my homey just had his paintjob :) I'll put him back together tonight and test it.
  • mruitermruiter Member
    I hope its pink, black is already done by some many people
  • edited May 2016
    @DaneeDeKruyff ; Can you try to set is at a value of e.g. 10? Which most likely corresponds to an update interval of 42 minutes (2550 seconds)
    happy to give it a go if we can make the data come in more often then once an hour. 
    I just connected the aeon to the homey, so happy to try some settings - but please chew it out for a noob what goes where (completely

    let me know

    ow and currently its constantly triggering the generic alarm - i aimed it at the wall 20min ago... still going nuts

  • JerryvdvJerryvdv Backer - Homey
    @DaneeDeKruyff ; Can you try to set is at a value of e.g. 10? Which most likely corresponds to an update interval of 42 minutes (2550 seconds)
    Hi Ted, I have changed it to 5 (apparently the min. value for 111 according to z-wave alliance) as well as reporting time to 5 with no results (5,1,2;3,2,10;101,4,241;111,4,5).

    One thing that strikes me as odd is that the pepper1 site and zwave alliance site report different values (i.e. for parameter size).. Anyone knows if Aeotec has their own version of these tables?
  • TedTolboomTedTolboom Backer - Geek Edition
    Jerryvdv said:
    @DaneeDeKruyff ; Can you try to set is at a value of e.g. 10? Which most likely corresponds to an update interval of 42 minutes (2550 seconds)
    Hi Ted, I have changed it to 5 (apparently the min. value for 111 according to z-wave alliance) as well as reporting time to 5 with no results (5,1,2;3,2,10;101,4,241;111,4,5).

    One thing that strikes me as odd is that the pepper1 site and zwave alliance site report different values (i.e. for parameter size).. Anyone knows if Aeotec has their own version of these tables?
    Just to check: Did you save the settings on the device card > manual wakeup of the sensor > reboot of Homey > no results in insights after 2-3x 21 minutes?

    If I check the settings on Pepper1, it also shows a 4 byte size for parameter 111.
    Can you compare device ID's with this page?
  • JerryvdvJerryvdv Backer - Homey
    TedTolboom said:
    Just to check: Did you save the settings on the device card > manual wakeup of the sensor > reboot of Homey > no results in insights after 2-3x 21 minutes?
    Yes I did, no results.. Reporting only done every hour.
    If I check the settings on Pepper1, it also shows a 4 byte size for parameter 111. 
    Can you compare device ID's with this page?
    You are right, similar settings as the link you provided. The ID is the same as well.
  • DaneeDeKruyffDaneeDeKruyff Backer - Super Early Bird
    @Jerryvdv @TedTolboom I've attached the engineering sheet to the first post.  
  • TedTolboomTedTolboom Backer - Geek Edition
    @Jerryvdv this would confirm our recent findings

    See Github #464 Homey not able to receive (multi) sensor data, only with polling or wakeup 

    Short version: It looks like there is a byte conversion error which converts the value of 5 seconds into 83886080 / 84215045 seconds (as send to the sensor)... Which will not give you an additional data point in the next 2 2/3 years.. 

    I think the issue #464 now has sufficient leads to squash this bug...
  • Wurzel21Wurzel21 Backer - Geek Edition
    For those who are still having problems in adding this device , I have had issues in getting these to add to honey - interview issues- but I have just updated the firmware of the aeontec multisession 6 (version 1.06) and now I have been successful in adding it to the homes :) ... Just now need to add adjust settings as per this thread - hope this helps
  • cautjecautje Member
    Nice, can it be updated by homey? Thx!
  • TedTolboomTedTolboom Backer - Geek Edition
    edited May 2016
    @Jerryvdv and @DaneeDeKruyff ;

    @Taco confirmed the cause of the issue with 2 and 4 byte (relevant for the Aeotec multisensor) size parameters::
    Fixed in 0.8.33. Thnx guys! Swapped the value bytes for size 2 and 4.
    According to the statements made on Slack regarding the release of 0.8.33 on May 6th:

    Next week will probably happen

  • JerryvdvJerryvdv Backer - Homey
    Thanks for the update! Looking forward to .33  ;)
  • DaneeDeKruyffDaneeDeKruyff Backer - Super Early Bird
    Great, when it's out I'll test my sensors all over again.
  • so for a noob - we hope that .33 will bring:
    - option to get more frequent updates from sensor (more then 1 an hour)?
    - more carts and options?
    right? :) 
  • JonJon Backer - Super Early Bird
    edited May 2016
    To all: when you have a Aeon multisensor that refuses to connect with your Homey, there's a good chance that this is due to a faulty sensor. In my case, I had an very early edition of the sensor (anticipating the arrival of Homey last summer, I purchased mine around July 2015, just after the sensor was launched to market). I bought mine at www.betaalbaredomotica.nl. So I sent a request to this webshop, explaining that I couldn't pair the sensor (even after the perfect help of @DaneeDeKruyff ).
    So Betaalbare Domotica's Gertjan let me return my sensor to have its firmware updated and he would then try to pair it with his own Homey (yes, he luckily had one!). This didn't turn out to work, so now Gertjan sent me a new one (after succesfully trying to pair this one, of course).  Woohoo, a working multisensor is coming my way now!

    In conclusion:
    Props to Gertjan at www.betaalbaredomotica.nl, he deserves some free publicity after all.
  • DaneeDeKruyffDaneeDeKruyff Backer - Super Early Bird
    @Jon good news you have a working sensor now! And great service!
  • JonJon Backer - Super Early Bird
    edited May 2016
    To @DaneeDeKruyff or someone else: I am currently trying to use my (now working, yeah!) sensor in a flow: If luminance level drops beneath a certain value, then do switch on my light.
    I was using the example flows of @BasVanDenBosch on page 1 of this thread, so I wanted to create 2 flows like below. But I encountered 2 issues:
    - the first flow can't be saved, due to some unclear error with the Variable name.

    - as for the 2nd flow: how do I set my flow in order to have my light switched on?


Sign In or Register to comment.