This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

[App] Devolo by Athom - main discussion topic

edited April 2018 in Apps

Devolo by Athom App - main discussion topic

Main discussion topic to centralize all Questions, Answers and Information around the Devolo App for the Z-wave devices of Devolo (

Links and information:

Athom Homey apps store:
Devolo App code repository: (CLI install how to)

Specific device topics:
<Links to other relevant Devolo topics, e.g. device topics>

Issue resolution and feature requests:

Please be aware that this topic is not actively monitored by Athom; it is a topic maintained by the community to share knowledge within the community.
In order to keep track of issues and feature requests for the Devolo app, please them at:

App contribution and co-development:

This app is actively supported by the following community developers: 
Contributions to this app can be made by any community members, more information can be found on:

Devolo App - Frequently Asked Questions 

Which devices are supported by the Devolo app:
In the app store a list of supported devices is shown with picture and description in the 'Supported devices' list. This list is generated by the actual content of the app.
In the readme of the app store, a more detailed list is maintained by the developers, showing the device numbers and the state in which the device has been implemented (e.g. basic support or fully implemented)

My device is not supported, how do I get it implemented into the Devolo app:
Most devices are implemented but new devices are being developed by Devolo. If your device is not supported, check on this topic if there are already plans to add support. In addition create a GitHub issue (see link above) to request to add support for this device.

What is the changelog of the Devolo App:
The changelog of the app is shown in the readme of the app store (see link above), but can also be derived from the commit overview on the Github repository:

Forum Discussion

Initial Discussion created by @TedTolboom
Ask any Moderator to add/update/correct this Discussion.


  • BramOBramO Member
    Yesterday I was at Mediamarkt and they're selling a Devolo Scene Switch. So I took one home with a mindset finally 4 hardware buttons to control Homey from my bed. When I try to start inclusion the device is not recognized as a switch but as an unknown device/sensor/.  So I did some research and I think this is a rebranded  Z-Wave.Me Wall Controller. They look like twins and the manual matches for both devices. (yes, I did read it and paid too much for it :) )

    Here are the details like command classes and manual. 

    I was wondering if this is a known issue, maybe there is a workaround or should I write and app for it :# .  Maybe someone can help me with this on. The whole z-wave is kind of new for me.

    I would love to help fixing issues if that is possible. 

  • RobinVanKekemRobinVanKekem Member
    edited August 2016
    Currently, Z-Wave has issues. If all goes well Athom will release an complete rewrite of the z wave part today.
    After that it could be that a driver has to be made to fully support this device. Which, the way it looks right now, shouldn't be to hard for a developer to do.
  • BramOBramO Member
    edited August 2016
    Cool, I'm allready writing a Devolo driver here:
  • BramOBramO Member
    edited August 2016
    I started writing an app to support Devolo Z-Wave devices. You can buy these device at Mediamarkt and online.  I think these are rebranded ZWAVE.ME devices so I hope I can support those as well. 

    Currently supported:
    • MT2652 Wall Switch (not yet tested).
    Feel free to help out here:
  • I just published a new driver for the Devolo Home Control Radiator Thermostat.

    It's quite similar to the Danfoss but adds retrieving the actual measured temperature.

    The driver therefore is very much inspired on the existing Danfoss driver by @kasteleman (now Athom), so credits where they are due! I also want to thank @kasteleman for helping me out with some issues I ran into.

    For now you can download it from: And install it with the athom CLI.

    I'll create a pull request for to ask for incorporating the radiator code into the existing devolo driver.

    Future plans:
    - Add a scheduling mechanism for weekly planning
  • Awesome, I just bought 2 of them at the Mediamarkt. Going to test them out next week! 
    I will keep you updated about the findings.
  • Hi @yvisee ;

    Unfortunatly the device is having the same E5 issues as the Danfoss for now. Check out the thread here:
  • When trying to add a Devolo home control z-wave plus switch an error message pops up: manager.vdevice.drivers.zwavebasic.pair.invalid_capability

    Could someone help me with this?
  • Robert1981 : An update is submitted which fixes this issue. Meanwhile you can install the app manually.
  • Athom solved the issue that stopped this App from working in v1.0.2. Big thanks guys!
    Testing now.

    The updated App is available at for now. I'll create a pull request for the generic Devolo app soon!
  • Mod break: added opening post and merged some old topics to maintain history
  • AndreasAndreas Member
    edited September 2017
    I have a metering Plug from devolo V2 which is not recognized right it is recognized as genric Zwave device. The old V1 Plug works fine. If you need further informations or tests i can do this.
    No seperated topic needed for above question, merged into the app topic. Please use the search for your next post before opening a topic.

  • Is it an easy job for me to try and add the Devolo humidity sensor to your code ?  I'm passable with JS but never touched Z-Wave, or is it something you might be adding yourself ?
  • Hi Guys, I'm new to this so please forgive me. Do I need to buy the Devolo controller in order to make a Devolo switch or sensor work with Homey?
  • EternityEternity Member
    edited December 2017
  • ignore what?
  • RocodamelsheRocodamelshe Member
    edited December 2017
    He wrote a comment and after that he decided that the comment was not usefull so deleted the comment. As the users cannot delete the message in total he wrote 'ignore' so we know.
    So has nothing to do with ur question at all.
    And for ur question: No controller is needed to add Devolo devices to Homey as far as i know.
  • Thanks ! <span>:blush:</span>
  • EternityEternity Member
    edited December 2017
    Thanks @Rocodamelshe, exactly as you wrote!
  • G4nd41fG4nd41f Member
    edited April 2018
    Please add support for the humidity and temperature sensor:

    I tried it with the Philio humidity and temperature sensor, which looks quite similar, however this does not seem to work. It says unknown device.

    Edit: I cannot add it to the github repository. Could someone do that for me?

  • Oy1974Oy1974 Member
    If a device is supported you can find out by yourself ofcourse, just look at the app on athoms appstore there you could see if its supported or not.

    Always first try to find the answer by yourself ;)
  • The Homey app has support for other Devolo devices but not for the Sirene! 

    So my question is for the sirene?


  • Oy1974Oy1974 Member
    As you stated by yourself. It isnt supported, what you could see at the app page. You could ask the devolper the he/she is willing to add support for it
  • At the Homey - Devolo device add window I don't see the Sirene Device! So maybe the device has a similar driver and can work with driver for Switch or Motion Sensor?


  • Oy1974Oy1974 Member
    I give up :#
  • Ok so here is my testing results...

    I tried to pair with the predefined drivers/profiles from the Athom / Devolo page like Scene Switch, Home control keyfob, Motion sensor, Door Windows Conatc and Metering Plug with a successful paired message with "No compatible Homey App has been found for this device. It has been added as a Basic Z-Wave device" When I am triggering the switch from my Homey the Siren alert lights are blinking but the sound is not ON. I made a video to show you what is happening.

    Is there any specific custom config to make this sirene work properly with Homey?


Sign In or Register to comment.