This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

[APP] Visonic PowerMax App (1.1.1)



  • It worked, thanks all!
  • Question, one of my motion sensors is detected as a CO sensor. Including it again in the visonic doesnt resolve the issue. Anyone seen this before? 
  • Hi Phaeton, I have the same issue with a few sensors. In addition since a few weeks, my connection with Homey is not longer working while the port and IP-adress can be found when scanning my network. All wires seem OK, trying to re-add the Powermax to Homey does not work.

    Any idea and seen before by others??
  • Hello,

    Finally got the hardware from aliexpress. I have everything set up and connected according to RemcoHannink's info in this thread for powermax+. The USR-TCP232-T is assigned an ip adress from the router but then I am stuck.

    The Viasonic powermax app in homey is not finding and device and I can not connect with Putty (telnet).

    Is there any software to be installed in the USR-TCP232-T.

    Would appreciate if any suggestion on what to do next?

  • @Jorgen66 ;You can download the software here:
    You'll need to configure the device as server and set the baud rate to 9600.
  • Thank you @RamonBaas. That worked fine. Homey will find the alarm panel and waits for powerlink to be activated in the panel.

    And now comes next problem (of course). There is no option/selection in the user menu to "DEFINE PWRLNK" in my panel!! It is also missing in the swedish manual. In the english manual it is described but not in the swedish.

    Panel version:
    PWRMAX+ (868) SW
    P/N 90-5466-0W Rev: B

    Is there a way to update/upgrade the alarm panel software or should I give up on this. I have searched but not find any valid info.
  • @Jorgen66 Propose you check with your supplier. For the app to work the panel does need to support Powerlink mode.
  • bass850bass850 Member
    edited January 2018
    Hi All,

    I was offline a while due to workload but I got time to get back to trying to get Homey and Visonic Powermax+ working. After more hours trying all different options with hardware and even factory resetting the Homey a colleague of mine came with a solution to try: why not try a different web browser (i am on linux so use web browser to configure homey) DUH!. 

    It turns out Firefox on Ubuntu will not work with Powermax app in Athom portal (nothing happens when you click search in first screen while adding a new panel). However Chrome and Chromium do work.

    Now everything works and I can finally use Powermax+ in Homey!

    Thanks again to all forum contributors who posted to try and help me. I hope this post can maybe help somebody in future with same issue I faced ;-)
  • Jorgen66Jorgen66 Member
    edited January 2018
    I was able to get hold of a newer version of the alarm panel (Rev: F) where Powerlink mode was available.

    All good now :)

    Thanks all for support and especially to @RamonBaas for app development.
  • Hi all,

    My powermaster pro LCD stopped working, so after trying to repair I changed to a new Alarm unit Powermaster 30 which is also a quality upgrade. My RS232 (for link with Homey) which worked on my Powermax Pro I connected to the Powermaster 30 and deleted the old PowerMax from Homey and searched for PowerMaster. Trying many times, no joy. Via Lan scan I can see the RS232 show the IP address. 

    Does somebody have experience with this or know what could be wrong? 
  • probieprobie Member
    edited March 2018
    Hi Ramon,

    I am desperately trying to add my powermax pro to Homey, but am failing quite bad.
    I have the powermaster programmer and used it to program my powermax pro in the past.
    For the sake of it I connected the powermaster programmer today to test if that still works and it works fine.

    I have a usr-tcp232-e2 connected to the powermax and see traffic flowing by (TX and RX) which suggest it should be working.
    However as much as I try the powermax can not be added to Homey for some unknown reason.
    Homey keeps saying 'Wachten tot dat registratie voltooid is...'

    I checked the javascript code and found that for a secret it uses '[0x56 0x50]'.
    As I know the powermax pro uses 4 hexadecimal values for access codes I thought this to be odd.
    My powermax pro has, by default, AAAA or BBBB as master code and installer code.

    Finally I see there is extensive capability of logging in the app and the option to enable debug, but I cannot find it anywhere or see a feature to change the secret to something else.

    Could you point me in the right direction?

    PS. There was a powerlink2 connected on the port PC/IP before, not sure if that's important.

    Hopefully you can help me get further.

    Thanks so much.

    Kind regards,
  • @probie Your powerlink2 will have registered with it's own magic code (i.e. not 0x56 0x50). You'll first need to de-register the powerlink in the alarm panel menu. After that you can register a new 'powerlink' (aka Homey) during the pairing process.
  • @RamonBaas I would like to use my Homey in conjunction with my PowerMax Pro. I do have a Powerlink Pro installed to use the web portal of the Visonic alarm system. Using the Visonic App in Homey I thought I had to use the IP address of the web portal. This is the internal IP address with the ports 80 (HTTP) or with 8351 (HTTPS) but apparently it's not connecting to Homey. The message shows that it cannot find the Visonic Powermax. The Visonic alarm system is normally reachable via the internetbrowser using this IP address. Some more detail: HW VERSION #:123SW VERSION #:3.1.11SERIAL #: 2310027367. Then I have read more closely that I should use one of the options below:
    1. Using the Visonic (dual) RS-232 Interface Module in combination with a RS-232 to Ethernet module (e.g. USR-TCP232-200). RS232 kit USR-TCP232-200

    2. Directly using the TTL signals of the Visonic PowerMax and interface via a TTL to Ethernet module (e.g. USR-TCP232-E). TTL Interface USR-TCP232-E

    So my question is basically what setup should I use and do you advice? Do you have an instruction manual for both those options? I would like to make sure I do purchase the right products by which I can get this integration working...... :-) I have added pictures of my Visonic system below. 

  • @wencew You have a Powerlink module installed. The app will not work in conjunction with a Powerlink. This is already discussed many times before.
  • @RamonBaas, just found out indeed in the forum thread and thanks for responding. I am fine to remove the Powerlink but what product should I purchase to get it connected to Homey and to replace the Powerlink? Do you have a manual for example? Thanks a lot Ramon.
  • @RamonBaas The Visonic app is working great for me. But when I look up in the application when a sensor has caused the last alarm the shown time is always two hours earlier than the real time. I tried several setting but no solution yet. Any idea?
  • @rpbras Probably Athom has changed the date to string function again and you are looking at UTC time.
  • @RamonBaas I have read the forum thread and created the pictures below to show how I understood the setup for the Homey and Visonic PowerMax Pro integration using the Visonic (dual) RS-232 Interface Module in combination with a RS-232 to Ethernet module. Can you please check if this is correctly described? Do I need for example to switch 3 & 5 around with the RJ45-DB9 plug or can I apply 2 - black, 3 - yellow and 5 - green? Thanks a lot for the response.

  • @wencew Problem is that the Jumper Box Plug and USR-TPC232-302 both have a female DB9 connector. Hence you need to add a gender changer (product 955 allekabels). You need to make sure you connect GND to GND, RX to TD and TX to RD.
  • @RamonBaas Are you sure about this as according to the site the Jumper Box Plug shows it has a Male Serial (DB9) connector:) If that's the case can I use this setup (2 - black, 3 - yellow, 5 - green) for the RJ45-DB9 connector?
  • Don’t have that connector myself, so I cannot say anything about the colors of the wires. But yes, then you don’t need a gender changer.

  • @RamonBaas , I have received the USR-TCP232-302 and I have provided the device with a static IP address. With the IP address I am able to connect via the web interface without any issues and made sure that the needed settings as explained in this forum were applied (e.g. TCP Server, Port 23, 9600 Baud; Data Bits 8; Stop Bits 1; Parity None). I have also connected the 3 pins (TX, RX, GND) in the  Jumper Box Plug to the USR-TCP232-302 (see the schema on image 3). In addition I have also de-registered and removed the previous PowerLink from the PowerMax Pro. Unfortunately for some reason I cannot pair the new Powerlink (aka Homey) with the PowerMax. I looked at many things but I cannot find the issue here, I even did switch the yellow (RX) and black (TX) cable in the USR but without results. What is what I am doing wrong or what could I check on the issue here? Is this RS-232 to Ethernet module even suitable for this PowerMax Pro release 1 device? Or should I connect all DB9 pins to the USR? Thanks a lot for the response.
  • @wencew First of all, do not connect more than these three wires to the DB9 connector! That will do more harm than good.

    There are a number of things you can check before trying to add the panel to Homey.
    1. Connect the RS232 connector to the PC and verify there is communication with the Visonic programmer software (i.e. not using the USR-TCP232-302). Use an USB serial converter if you have no RS232 port.
    2. Use the TCP232 test software. Connect as client to the USR-TCP232-302 server (i.e now using the USR-TCP232-302). As soon as an alarm sensor is tripped, you should see data coming by (A5 messages).
    If this is all verified to be working, you should be able to add the PowerMax panel to Homey.
  • wencewwencew Member
    edited April 2018
    @RamonBaas , thanks for your response. The first option is unfortunately not an option as I do not have the Visonic programmer software and it seems to be difficult to get it. The second option I am not really sure what you mean.... ;-) I did connect to the TCT232 via the USR software (USR-M2 v2.2.2.279) via LAN and I am able to connect. Below is the screenshot. I do not see any A5 messages unfortunately. Should I do something different?

  • @wencew You can download the programmer software from the Visonic website. Zip password is easy to find on the internet.

    USR-TCP232 testing software is here:

    From the screenshot it shows you’ve configured the module as TCP client. That should be TCP server.
  • @RamonBaas , I did change it to TCP client as I thought you referred to that earlier ... :-) It's changed back to TCP server again. In the meanwhile I have downloaded the Visonic programmer software and got it installed succesfully, thanks! The only thing is that this really old software only works with RS232.... :-) I have found the following picture below and I already have the Visonic Powermax Pro dual RS232 interface. Can you confirm this is the correct setup?

    - UTP cable will be connected to the Powermax Pro dual RS232 interface and JumperBox connector (RJ45 Female / RS232 Female).
    - The JumperBox connector will need to connected with all 9 colored cables.
    - From the JumperBox connector this will be connected using the RS232 Female connection to the Serial Male to USB cable.
    - USB cable obviously will be connected to the PC.

    Is this the correct setup as stated above? Thanks a lot.
  • Yes, this is the normal setup. However, if you use another RJ45-DB9 converter, you won’t test your original one.
  • Hoi Ramon and all,

    I stepped over from Powermax Pro to a Powermaster 30. In my old setup the Powermaster App worked great, but using the same rs232 module in my new Powermaster, Homey cannot find it anymore with the same IP/Port number. 

    Would you know what could be the issue? Any setting I should verify/change?
  • @Justjomi First check that it works OK with the Visonic programmer software on PC.
  • Tx, I never used that software. Where can I download?
Sign In or Register to comment.