This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Somfy RTS device shutters is not working

tonvos6tonvos6 Member
When I add a somfy RTS Blinds device for my shutters, and I do that according the instruction, it is not working.

I have done the next steps:
Next to the homey, I add the somfy RTS Blinds, I push the prog-button of the remote-control, push the button next, than you can test it, and than next button to Finish it. And it is still not working!

I will install 3 shutters. And I have done it many times, but only the first time was it working. I have delete that one (because it was a test version). And after that I have try it again, but it was not working, and I have done it many times.

Do you know what I must do to fix it?

The version of Somfy RTS is v2.2.1.

Regards Ton


  • tonvos6tonvos6 Member
    edited July 2017

    Hello Bos, 

    I've solved my problem.

    The reason that I could not add the somfy device is that I did not push the prog-button not long. So the shutter did not come into programming mode. The programming button must hold down until the shutter is responds (goes up and down a little bit).

  • This is driving me nuts.. I have a Somfy Junior 30 RT - with a remote

    I think I have tried all possible combinations

    Put the roller in programming mode it responds - I press Next in the Homey App - and the roller responds - but NOTHING happens when I test in the app - The remote stops working - and I need to press the prog and assign the remote again and it works from the remote but no matter what the homey does not work with it..

    Even though it actually responds when I press Next.. 

    What can be wrong here?
  • Same problem here, also with the junior blinds:

    I already have 2 somfy blinds working with Homey and they work fine. Now I've recently bought a new somfy blind but it cant seem to connect.
    It works fine when I add a second telis remote; just 1 program button push on the connected remote and 1 program button push on the new remote. But it doesnt work with homey.

     When I try to add the blind to Homey the following occurs:
    - I click on the devices add button in the Homey software and select RTS blinds.
    - On my somfy telis remote I push the program button on the back, the motor responds.
    - When I go to the next page in the software, the motor responds 3 times! Which means a factory reset is given to the motor!

    The result is I have to go through the install process of learning up/down positions with the telis remote. No response from the blinds when I trie to control them with homey. Is it possible in the Homey adding process to control the number of times the reset button is pushed by Homey? So my motor doesnt go into factory reset?
Sign In or Register to comment.