This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Your Motion Sensor Ideas Fibaro,Smartwaves

Hallo together,how Do you managed your Motion Sensor in a Flow? I have already the Problem that the Motion Sensors me see after a Minute or two not More. I will prepairing my Flow "as Long on as Motion" have you ans ideas for me? I have the Z-Wave Motion sensors in the Standard Configuration why i dont know what Parameter can bite whith a Flow.Any ideas?


  • aloftaloft Member
    There is a time-out in the Fibaro motion sensor itself before it re-reports a new motion. So you might need to fiddle with its internal parameters to get a more continuous motion detection.  And then configure your flow to act when motion stops. 
  • I have a Fibaro in the toilet and did not change the parameters.
    This works as expected, as long as you move around long enough of course :)

    But this is not yet with the Homey, but with my previous controller.
    Since this is essential functionality for my house, I did not migrate it yet, because I feel it's not stable enough yet.

    Concerning the settings for the Fibaro:
    You can change the sensitivity, but it's almost at maximum by default
    After detecting motion, there is an 8 second window during which it checks for new motion.
    If no new motion is detected, it sends a 'no motion' after 30 seconds.

    All of this can be changed of course.
  • jordenjorden Member
    edited March 2016
    Does anybody have the Fibaro Motion Sensor? I am really interested in buying one, but have some questions:
    a) Do I need anything else to connect it to Homey?
    b) What is the maximum range between the sensor and Homey?
    c) Any idea on how long it works on its battery?
    d) Is it possible yet to use 'movement' to start a flow?
  • @jorden ;
    I've the FIBARO MOTION SENSOR FGMS-001 really nice gadget

    A. Nope no other controller needed just put homey in detect mode and push 3 times on connect button of sensor
    B. It seems 10M with thick wall is to much to handle (I'm testing this at the moment)
    C. I believe they say it should work for one year or something
  • B) If you only have the motion sensor, the range will be limited.  With multiple devices (mains powered, not battery) you have a mesh network, which extends your range.
    C)  Mine are all still at 100% after 6 months
    D) Don't know it that works already
  • @MennoVanDerAat ;@Fire69  Thanks, that's awesome

    So I guess that if I add a wall plug half way, that should extend the range... Good tip, thanks!
  • Yep, a wall plug should do the trick :)
  • aloftaloft Member
    edited March 2016
    Motion detection works.  I have a flow that turns on a Hue light based on movement that is detected by the Fibaro motion sensor.
  • Awesome. I ordered one and if needed, will get a wall plug later on :) Thanks everyone!
  • @aloft ;
    What parameters and association are you using? are you using general alarm?
  • edited March 2016
    For others maybe having same problem what I have done is:

    Group 3 = 1
    Data 5,1,2
    On motion device press 3 time button

    After that I see alarm going on and off after motion detection

    Edit --> Data is not needed
  • After some heavy fight (zwave 3 - me 1) I've managed to create two flows with motion detection:

    1. On motion (FIBARO MOTION SENSOR FGMS-001) turn on lights ( ZME_05433)
    2. On no movement (FIBARO MOTION SENSOR FGMS-001) turn off lights ( ZME_05433)
  • What problems did you have?
  • I just received mine, will try this tonight :) I'm so in love with Homey. <3
  • @Fire69
    The problem is that I don't know how to reset the ZME_05433

    I can remove the device from homey but when I do a new detection it's finding something but I don't have all the option that I should get. Also got an error about secure something (secure is ticket when I look at the settings)
    So I had to take down the power and replace the unit with another one. I did a reset for something else but after that the second unit was not detected okay.

    So I did an other dimmer in different room and that one was detected fine

  • jordenjorden Member
    edited March 2016
    I managed to add my new Fibaro motion sensor. In 'Devices', I can see:
    Generic alarm - Off
    Luminance - 21lx
    Temperature - 23.1C
    Battery - 100%
    This makes me think it works. Although I am not sure if "Generic alarm" is meant to be there for when motion is detected or when vibration is detected.

    I set the polling interval to 60 seconds. I tried setting group '3' to '1' as Menno said.

    If I move in front of the sensor, I see it lights up green. If I pick it up, I can see it light up white/red/blue. However, I made a flow for 'generic alarm' and that one doesn't run. @aloft, how did you set it up?

    I also tried to set up a flow, 'if temperature changed' and 'if luminance changed'. It should tell me the luminance/temperature on my phone when I testrun it but it shows me an empty message.

    Any help is appreciated :)
  • @jorden ;
    after chanching group 3 with value 1 you have to sync settings by clicking 3 times on the button of the motion device (to make sure do this close to homey

    If it works you see alarm on after movement and after 20 seconds it should change back to off
  • jordenjorden Member
    edited March 2016
    When I add the device, do I choose "None", 1, 2, or 3 as the group? I chose group 1, not sure if that helped. Then edited, filled in '1' behind the group 3 field, then 3 times pressed the button on the hardware and then it worked.... thanks so much! <3
  • I skipped (none) it in the wizard I changed it after wizard
  • Now that I have my motion working with my lights I'm wondering how to fix the following:

    1. after reboot my lights always start at 0% brightness (is there an option to set default brightness to 50% or so)
    2. after motion detection lights go off after 5 minutes so after new movement within the 5 minutes it's changed again to 5 minutes I tried with delay but that is not working for me
    3. how to factory reset ZME_05433
  • That is the big Problem at the moment the second motion after first motion, i think the parameter 2 and 6 is  important to modifiy, i dont have tested yet, when i have checked then i post an update
  • aloftaloft Member
    Sorry for the delay in answering. I have -as the others have- the association to Homey on group 3 . Parameters is 80,1,17 ( but that is to change the light colour when there is movement, I mainly use it when changing something and making suring that the sync is processed. 

    I have to admit that it cost me a couple of times of including/excluding and updating parameters to get the Homey/Fibaro pair to detect the motion correctly. 

    For flows, I have an extended setup:

    Flow 1: When generic alarm turned on (= movement detected), I set a BetterLogic boolean to TRUE and a counter BetterLogic number to 0
    Flow 2: If boolean is TRUE => turn on light
    Flow 3: If boolean is FALSE => turn off light
    Flow 4: Each 15 seconds, increase the BetterLogic number with 15
    Flow 5: If number > 60 => boolean FALSE

    This way, if a new movement is detected within 60 seconds, the counter resets and the light will stay on for another 60 seconds.

    There might be a better way to get this done, I am open for suggestions, because this needs a lot of flows ;-)
    I also like to include a "WHEN" part in the Flow 2, to take into account the luminance report. (Only turn the light on when luminance < X ) .  Problem is that I cannot store the luminance reported in a BetterLogic number, only in a string. 

    Also, updating the parameters to get more frequent luminance updates don't work yet. Only when luminance changes are higher than configured 200 lux, it will report, but also not always. I need to test further to determine what is happening.
  • aloftaloft Member
    To add to my own post, doing some extra tests:

    I can compare the luminance with the Homey's built-in logic.   Update of luminance is not predictable yet.

    I added an extra flow 6: when generic alarm off > turn boolean2 to TRUE
    I edited flow 1 (boolean2 = FALSE )and flow 4 (WHEN boolean2= TRUE ) so that the counting in flow 4 only starts when there is no motion detected. This way, the lamp won't turn off if there is continuous movement within the timeframe ( the counter only resets to 0 when a new motion is detected. But if you are within constant motion reach of the sensor, Homey nevers reports is as new" motion". )

  • @aloft ;

    Sounds great (a lot of flows ideed but heee if it's working)
    Will test this tomorrow do I have to do something on the settings page of homey for better logic?

  • aloftaloft Member
    @MennoVanDerAat I have 3 variables defined in BetterLogic:
    - counter_motion : number
    - status_light: boolean
    - status_counter_running: boolean
  • edited March 2016
    @aloft ;
    I got the first part working only thing is my sensor alarm resets after 60 seconds so all motion within this 60 seconds is ignored. I changed the time from 60 to 120 and now when I move after 60 seconds the timer is resset to 0

    Now going for the second part brb

    << Edit >>

    Got the second part working indeed this is what I was looking for
    Did you had any succes with luminance?
  • Added 7th flow to stop the counting after 60 seconds
    Now have my kitchen and studyroom under controle very nice!
  • Can you post pictures? Big thanks
  • aloftaloft Member
    edited March 2016
    @MennoVanDerAat ;
    Yes, My luminance is also working. A new luminance is only reported when there is a change in luminance. I added a parameter to update every 30 minutes.
    I now have an extra flow that sets the luminance in a BetterLogic number, but only when the light itself is off ( to offset wrong luminance due to the light being on).
    In the 'motion detected' flow, I now only execute when luminance is lower than a  certain number (still experimenting with the best value )

    I'll try to post pictures of all flows later. 

  • aloft said:
    @MennoVanDerAat ;
    Yes, My luminance is also working. A new luminance is only reported when there is a change in luminance. I added a parameter to update every 30 minutes.
    I now have an extra flow that sets the luminance in a BetterLogic number, but only when the light itself is off ( to offset wrong luminance due to the light being on).
    In the 'motion detected' flow, I now only execute when luminance is lower than a  certain number (still experimenting with the best value )

    I'll try to post pictures of all flows later. 

    @aloft which settings are you now using with the Motion sensor?
    Specifically regarding the Luminance in order to get it working properly... 

    I only get luminance reported once every 2-3 hours (or even longer)... while I changed the reporting parameter to once every 15 minutes
Sign In or Register to comment.