This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Silent Alarms as Flow triggers, possible?


I tried to search, but didn't find anything related to my problem. My apologies if I missed something.

How do I set sound behaviour for alarms, preferably at an individual level?
At the bottom of the "Alarms" page there is a suggestion to use alarms to trigger flows, I'm using this feature to control heating schedules. This results in Homey playing a tune and announcing it's time to wake up several times throughout the day and evening to increasing levels of frustration from my wife. I have resorted to turn down the master volume, of course this makes the speaker function pretty useless. From the "Alarms" page there is no method of setting sound behaviour as far as I can tell, how do I make individual alarms silent?

Frode, Norway



  • JPeJPe Member
    edited August 2018
    You have to do some settings in Settings / Alarms  (sorry I only have a Dutch picture,
    Instellingen is Settings,  Wekkers is Alarms)

    there is also the description, what cards to use, to get the Flows as you want them.
    If you haven't used an Alarm card (like in this case called "Weekend-Wekker") in one of your flows, then the default Audio will play.

  • Interestingly some Dutch words are not too far from Norwegian, your Instellingen is the same as our Instillinger and Wekker is close to the Norwegian word Vekke which means to wake someone up. In particular western parts of Norway have similarities with Dutch, other west-Norwegian words which comes to mind are Kortebrok (shorts) and boremaskin (power drill).

    Anyway, back to Homey. I am using the settings and flow card as you indicate.

    In Settings -> Alarms there are no settings, only "Enable" and "Delete" buttons are available when I hold the mouse over a spesific alarm. There are no general settings.

    The Flowcard seems more promising at first, but on closer inspection I'm not able to change the sound. Hovering on the information symbol displays a message saying "Creating a Flow with this card will replace the default alarm sound." When an alarm goes off there is first a melody playing and then the current time is announced, even when there is an Alarm Flow Card using this alarm.
     - What is the default alarm sound?
     - How do I prevent the melody being played?
     - How do I replace the tag "a time" with another tag of my choice or no sound at all? It is not possible to drag and drop from the tag list and on to the Alarm Flow Card tag.

  • JPeJPe Member
    edited August 2018
    This is what I see when all alarms are deleted:

    Then press: Add new Alarm (Nieuwe wekker)

    Here you fill in, the Name you want to give to this Alarm (Wekker 1 in my case), check Enable (Ingeschakeld) and check the days, the alarm must go off and the Time.

    You cannot "change" the default sound, when a flow exists, that uses the Alarm-name, then the sound is automatically replaced by the action that you have programmed in the flow

    you can only drag the tags from the Alarm card not to it, in the Then column you can use all tags that are available.
    Hope this helps, good luck, 
  • Ok, so alarms with active flow cards shall not make sound unless specified in the flow actions? I will look into that and double check. I believe I have created flows for all my alarms, but maybe I still have some unused alarms.

    I have the same options as you in settings: Alarm name, time, days, enable and delete - no sound settings. For me it seemed intuitive that a "mute" option would be available here also, but if a flow card will mute the alarm this should achieve the same result. Hopefully I will be able to confirm this after going through my alarms again.

Sign In or Register to comment.