Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.
Ask your Homey-related questions in this category. You can also go to athom.com/support to get support from Athom.

Google Home / Assistant won't talk to homey anymore with the right Google account

MarkVMarkV Member
edited August 8 in Questions & Help
When I got home from my holiday the Google Home speaker (mini) told me she was not connected to Homey anymore.

So I asked Google to relinked (“OK Google, let me talk to Homey.”) and found the blue connect popup in the Home app, but it's won't link if I press is.

Not the language
So I checked if it had something to do with the language of the phone (Dutch/ English) and found that since my phone was still set up as English so that was not the issue (if you open this link: https://assistant.google.com/services/a/id/45e28a03ce038eb8/ when set to Dutch it will open up a non working page).

Multiple Google accounts
After some fooling around I did get Homey to work again with my phone with Google, but it works with the wrong Google account now. I could now send commands from my phone to the homey, but the Google Home Mini would not work since it was connected to another Google account. 

I tried to setup my secondary Google account with the Home mini (which did not work and did not give a blue popup in the home app).

I tried unlinking Homey from my secondary Google account, but am still not able to connect it to my first account (it gives it a try but defaults back to the old screen instead of the homey authentication page).

What I tried
Unlinking everythink and relinking it (works for secondary account, not for primary)
Rebooting everything (Mini, Phone etc)
Unlinking the Google Home entirely and setting it up again.
Cleared cookies from my mobile phone browser.

The difference betweet my primary and secondary account is that the secondary does continue to the "homey login/authentication" screen and the primary does not.

Anyone any suggestions?

Comments

  • MarkVMarkV Member
    edited August 13
    Thank you @JaapPelt
    https://forum.athom.com/discussion/comment/75271/#Comment_75271

    In the Google Assistant app in your phone you find the compass icon. This brings up a search, where you can search for Homey (or click this link). There is a link / unlink feature there, but also a reset app link. After the reset the setup started working again.

    Ooh and a tip. You don't have to say "ok google tell homey" every time if you set things up right:

    1. In the Google Home app you find the hamburger icon on the left top. Click on it.
    2. Click on the ... More settings
    3. Scroll down to the "Services" section and click on Routines
    4. Here you can add new routines (for example: when I say "got to sleep", my assistant shoud... "tell homey to go to sleep".)
    It takes some time to set up but it's real nice for voice commands you often use.



Sign In or Register to comment.