This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Homey won't reconnect to WiFi on small WiFi changes of Unifi Uquibity AP's

Hi All, 

I have an interesting issues when I fiddle even for a bit with my Unifi Uquibity managed AP's (3 AP's, one per floor) Homey loses connection and doesn't reestablish it again.
Although the setup method mentioned at the "wifi setup" page works fine to get Homey reconnected. It becomes pretty annoying when you have to repeat the setup method every single time I play even a little with the settings of my AP's (e.g. changing transmit power or channel setup). The SSID or password and such are unchanged. Every other device in my household is capable of reconnecting or  even staying connected.

The most funny part is that after changing these settings in the AP's.Homey is gone from the network (not connected to the wifi anymore), however when I reboot all AP's at once, Homey is able to automatically reconnect, but is gone after about 5 minutes again! At that point I have to redo the setup procedure above to get it fully connected for a longer period.

Personally I have a feeling it might have to do with the wifi reflections and therefor possible bad quality of the wifi signal, but that still doesn't explain the reason Homey is not able to reconnect after reboot (PtP), or, the more funny situation, is not capable of stay connected after a reboot of the AP's. It doesn't even seem to retry (based on logs of Unifi manager).

I would like to think it is AP related instead of Homey, however I'm having a hard time believing it, when Homey is the only device failing to reconnect and I also have to re-setup Homey every single time I try some other setting/solution on the AP's

Is anyone else experiencing similar issues? Is there anything I can do about this or is this a bug?


  • deWekkedeWekke Member
    Have you done a firmware update on your Unifi AP's? Which version are you running? there were some problems with disconnecting devices in firmware 
    I don't had problems with Homey disconnecting but my wife's (cheap) tablet had wifi issues. I'm now on version and have no problems but some users on the Unifi forum still have disconnect issues with version 3.9.27.x

    You could test with firmware version
  • SpikeySpikey Member
    Yes, I update my AP's quite frequently. Recently I've indeed updated to the latest version I have no other device that have the similar issues, but it might indeed be worth to verify with an older firmware version. I'll see if I can find and update (downgrade) the firmware.

    Thank you in advance for the tip.
  • SpikeySpikey Member
    Thanks, I've just downgraded all AP's and it actually looks promising. I haven't been able to reproduce the issue yet, where it was pretty easy before.
  • deWekkedeWekke Member
    edited May 2018
    It's a known issue. My (or wife's) devices are working fine now on firmware 3.9.27.x. I only had issues on 3.9.24.x
    Have you enabled "Block LAN to WLAN Multicast and broadcast data" in your wireless network settings? I've read that this also could cause some troubles. This is only enabled on my guest network (disabled on private wifi network)
  • deWekkedeWekke Member
    edited May 2018
    just curious... what "manufacturer" is shown for your Homey device? In Unifi controller go to Insights -> known clients to show the Manufacturer

    Mine is "TexasIns" (Short for Texas Instruments??).
    I had disconnecting problems with manufacturer "Shenzhen"... China stuff (Medion tablet from Aldi)

    A colleague at work also had the same issues with a smartphone from.... Shenzhen.
  • SpikeySpikey Member
    Mine says: AzureWav.
    Don't know which one that is.

    I'll have a test tomorrow with the latest firmware again and the option "Block LAN to WLAN Multicast and broadcast data"enabled, since I've never touched it and therefor was still disabled. It sounds worthwhile to test. Alternatively I now have a working backup.
  • deWekkedeWekke Member
    My old Chromecast is also from "AzureWav". Could the difference in chipset vendor explain why I don't have problems on 3.9.27.x ??? I'm a new Homey user (bought Homey about 1 month ago)

    I don't think you need to test the "Block LAN..." setting because there could be problem when this setting is enabled... and yours was never enabled.
    On the Unifi forum you can find a lot of information about the firmware issues.
  • SpikeySpikey Member
    Yeah, I've noticed.
    After I upgraded back to the 3.9.27 version and enabled "Block LAN to WLAN Multicast and broadcast data", it worked even worse.
    It could very well be that this specific chip has issues.

    I'll have a look at the unifi Forum, since it is quite annoying. I also noticed one other device had interesting behavior since the upgrade (or basically I noticed it didn't anymore after the downgrade). That device, while being a stationary device like Homey, started to roam between all three AP's every few seconds!. It was already less when the setting for fast roaming was disabled, but I noticed with the old firmware it was working fine even with the fast roaming seting enabled.
    In other words, I think Unifi has made a buggy firmware version.
Sign In or Register to comment.