This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Velux Roller Shutter

Hi again,

I have an electric Velux Roller Shutter that uses a remote.
Can this be controlled using Homey ?

I found a site where it is done with a Raspberry Pi ...

Kind regards,



  • Would be great to have these Velux shutters integrated indeed!
  • bramskibramski Member
    I am using a KLF-200 interface. You can connect it to your LAN and do calls using a HTTP api to start Velux scenes (ie open your schutters)
  • Yes, but is it integrated in your Homey or do you still use a separate app (like my grandparents :-) )
  • Nogal duur om slechts twee rolluiken te bedienen.

    En dit bovenop de prijs van de Homey ...

  • ..."Om het bereik van de afstandsbediening te vergroten kan de KLF 200 ook als repeater/versterker worden gebruikt."...
  • bvbbvb Member
    Velux has anounced Velux active in late 2018, there you can control it through an interface and also use Siri, etc. I will wait for this feature and hope someone write an app for this.
  • OskarOskar Member

    Connecting a Velux shutter to Homey.

    Many people have tried it and we finally succeeded. The approach works with the Velux KUX 100/110, but in principle also with other solutions where 2 wire motors are installed. In principle, it works by replacing the remote controller, the KUX, with KAU switches (or similar that can operate with 24volts) and then having it controlled by Homey. To achieve this it is also necessary to reset the engine in order to forget settings in the motor that let it be only controlled by the KUX.


    Step 1: Reset the motor

    Press the KUX reset button until the shutter starts to move. Then immediately disconnect the power (pull out the brown / white wire). Then Velux de KUX is forgotten and this is very important, otherwise it is not possible to drive Liège with just 24v!

    A detailed description can be found here:


    Step 2: Replace the KUX with 2x ASUN650 (KAKU) and a DC24V transformer.

    First check whether the shutter can be controlled with 24 volt transformer. We actually did not have one at hand and tried it with a 19v adapter, which also worked (the 24v transformer is on order now). Test it by connecting the + and - on the motor wires (brown & white in our case) and confirm the up or down movement. Switch the wires and see the shutter moves the other way. If so, it all works as expected and we connected the 2 ASUN 650 switches.

    One of the transformer wires goes to one switch and one to the other. Than connect the “Up” to motor from both switches and cross-wire the “down” connectors at the same time also to the motor; this switches the wires around between up and down movements.

    We picked the idea from this post:


    Step 3: Set up the shutter control via Homey

    Add both ASUNs to Homey and create a new virtual device as a Shutter. We use the virtual shutter to control the ASUNs, preventing them from short-circuiting as the wires are connected to both + and -.

    A flow for "Up" switches both ASUNs "Up" and after 40-50 seconds when the screen is down again put it in "Stop". A second flow is needed for "Down" and of course also one is needed for "Stop".

    (Here you can attach a screen shot)


    Step 4: Can we still use the old remote control?

    Currently not, but this would be nice to do as well. But we have no solution yet, and we do not have the development skills to work this out.

    Perhaps someone is able to develop an app that can record the codes of the Velux remote control and then use that code to have Homey actions taken instead of seeing them as KUX commands. Even if encrypted or proprietary this should be possible in my mind as we just need to pick up string and act on it via Homey – no need to decode and try to send the code to the KUX.
    Ideas about if this is possible and how to do this would be welcome.


    This is how it looks like now – not fully completed yet and nicely put out of sight, but I think you get the picture.

    Hopefully this is helpful for others still trying to get Velux controlled by Homey.

Sign In or Register to comment.