Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.

Sonoff met Tasmota via MQTT broker, wil niet starten/installeren

Undutchable62Undutchable62 Member
edited April 5 in Nederlands
Hoi,

Nadat ik de Sonoff basics heb ontvangen ben ik aan de slag gegaan met het inrichten van de Homey.

Op de Sonoffs stond firmware 1.6.0, ondertussen met hulp van dit Forum en http://http//jacco-janet.nl/category/domotica/sonoff-tasmota/ heb ik Tasmota Firmware er op weten te plaatsen. 

De log van MQTT-server blijft maar aangeven dat de verbinding mislukt.

Wat heb ik geprobeerd; met/zonder user+ww, IP-adres wijzigen, opnieuw opstarten, opnieuw installeren van MQTT-broker+Sonoff op de Homey.
Wanneer ik vervolgens probeer de Sonoff (Tasmota) te installeren zie alleen maar "wacht op apparaten....". 
5/10/15 minuten gewacht, telkens toch proberen met "uit en weer aanschakelen".
Geen succes, ik vermoed dat ik ergens of een denkfout of een tikfout heb gemaakt. 

Maar waar?



«1

Comments

  • arthurarthur Member
    In de PIC van je broker staat dat deze niet actief is. Misschien ff starten?
  • Sorry, @arthur , verkeerde plaatje geladen.
  • robertkleprobertklep Member
    edited April 4
    Zet "Beveiligde verbinding" eens uit in de MQTT broker (dat heeft niks te maken met gebruikers maar met hoe de broker verwacht dat clients, bv de Sonoff, er verbinding mee maken).
  • Dag Robert,

    Ook nog eens opgestart zonder "Beveiligde verbinding".

    Helaas.....

    Wat doe ik fout;

    IP Homey = 192.168.10.71
    IP Sonoff toilet = 192.168.10.66
    Sonoff kan middels de HTTP in- en uitgeschakeld worden. (die werkt dus)

    Maar bij het toevoegen van apparaten gebeurt er niets. 
    Zoeken met apparaat aan
    Zoeken met apparaat uit
    Uit- en inschakelen

    enz.
  • robertkleprobertklep Member
    edited April 4
    Je Sonoff zegt dat ie niet kan verbinden met de MQTT broker, dus dat moet allereerst gefixt worden (zolang dat niet werkt kan de Sonoff app geen apparaten vinden).

    Ik heb zelf authenticatie van gebruikers helemaal uit staan in de broker, probeer dat eens. En ik neem aan dat 192.168.10.71 het correcte IP-nummer is van de Homey? (kun je ook uittesten door http://192.168.10.71 te openen in een webbrowser).
  • Webbrowser wordt geopend met het genoemde IP-adres.

    Zou het uitmaken dat de Sonof (nu nog) via 3.3V voeding verkrijgt?
  • robertkleprobertklep Member
    edited April 5
    Webbrowser wordt geopend met het genoemde IP-adres.

    Zou het uitmaken dat de Sonof (nu nog) via 3.3V voeding verkrijgt?
    Nee, dat is hoe ik meestal de apparaten met de apparaten bezig ben als ik aan de app werk (3.3V via een USB-naar-serieel dongle).

    Die "-2" code die je ziet in de Sonoff log ("rc -2") betekent "MQTT_CONNECT_FAILED - the network connection failed". Dus de Sonoff kan geen initiele netwerkverbinding maken met Homey.

    Heb je zelf al eens geprobeerd om met een MQTT client te verbinden met de broker op Homey?

    Oh en nog een dingetje: ik gebruik zelf de beta versie (v0.1.9) van de MQTT broker app. Zo te zien gebruik jij de stable.
  • Hoi Robert,

    Een paar antwoorden en bevindingen:

    De MQTT client geïnstalleerd, geen meldingen, maar ik weet ook niet wat daar verder mee te doen.
    Als ik in "instellingen" links op Sonoff klik, daar verschijnt er alleen maar een wit scherm met een draaiend wieltje. 
    Maar dat zal waarschijnlijk komen doordat er geen (sonoff) apparaten zijn te vinden.
    Ondertussen de Beta geïnstalleerd, echter hetzelfde resultaat.

    Ik ga een beetje twijfelen aan de kwaliteit van mijn Homey, daar ik ook geen Osram Smart Plug kan installeren.
  • Dat het instellingenscherm leeg is, komt door een bug in m'n app  :/

    Maar het probleem blijft dat de Sonoff app geen netwerkverbinding kan maken met Homey. Ik zou bijna gaan denken dat er ergens in je netwerk een firewall in de weg zit.
  • Windows Firewall uit/aan/uit/aan - geen verandering

    Nu probeer ik een volledige schone installatie van de Homey uit.
    Inclusief factory reset.
  • OK, opnieuw begonnen met een schone lei.
    Oude installatie netjes opgeruimd met Revo
    Computer opnieuw gestart (Win10)

    Factory reset
    Nieuwe installatie
    Sonoff geïnstalleerd
    MQTT Broker geïnstalleerd

    Gegevens ingevuld
    Broker gestart
    IP's dubbel gecontroleerd

    Wel een melding in mijn account: Retreiving broker data failed.........
    Zie bijgaande afb.
  • robertkleprobertklep Member
    edited April 5
    Die melding gebeurt bij wel meer apps, volgens mij niet problematisch.

    EDIT: ff gecheckt, en die melding krijg je altijd na een verse installatie van die app. Dus geen probleem.
  • OK, goed om te weten.

    Ondertussen heb ik nog steeds niet de Sonoff weten te benaderen via Homey.
    Wel via HTTP
  • Ik ga maar eens contact opnemen met Athom, alles in huis verbonden, gaat weer eens niet op. (Osram-smartplug)
    Misschien dat er iemand van Athom mee leest, @Stefan of @Bram, en bereid is om te interveniëren om met elkaar een oplossing te creëren.

    Robert ontzettend veel dank voor jouw hulp en heldere aanwijzingen (kudo's)
     :'(  :#
  • arthurarthur Member
    @Undutchable62 Heb je al eens geprobeerd om vanaf een andere machine is hetzelfde netwerk een tcp verbinding op te zetten naar je homey met mqtt broker enabled? Het command "telnet <HomeyIP> 1883" zou in ieder geval een connect moeten geven. Als dat niet werkt, dan is ligt het probleem waarschijnlijk aan de mqtt broker app. Als dat wel werkt moet je aan de kan van je SonOff zoeken (of het netwerk daartussen).  Hoe heb je de Sonoff geconfigureerd? Middels DHCP of met static IP settings? 
  • Undutchable62Undutchable62 Member
    edited April 6
    Hoi @arthur
    Dank voor jouw aanwijzingen.

    Ik heb een client gebruikt, Telnet Client. (TCP/IP) deze geeft direct aan dat er connectie is.
    Krijgt een vervolg.
  • Ondertussen de Sonoff in de router op Static gezet.
    Maar nog steeds wordt er niet gevonden. Jammer.
  • GOED NIEUWS:

    met de Beta 4.0.2 welke @robertklep zojuist heeft geplaatst is het eindelijk gelukt.
    geen van de instellingen zijn door mij veranderd.
      :)
  • Oh uh beetje onverwacht, maar graag gedaan  :D
  • Onverwacht?
    In 4.0.1 kon ik niet de "basic" selecteren in 4.0.2 wel, BINGO
  • Ja okee, dát werkt nu wel, maar de verbindingsproblemen die je had en die nu kennelijk zijn opgelost kan ik niet verklaren, want daar heeft 4.0.2 niks aan veranderd  :)
  • Het gejuich wordt verstomd want een tweede Sonoff basic wordt niet gezien.
    Gelukkig twijfel ik niet aan mijzelf, maar helaas wel aan de kwaliteit en stabiliteit van mijn Homey.
  • arthurarthur Member
    Het pairen van een nieuwe sonoff/tasmota werkt bij mij het beste door gedurende het zoek proces van de app de sonoff te (soft) rebooten. Daarna wordt ie meteen herkend. Misschien helpt dat? Ik je screenshot zie ik ook dat ver versie 5.10 van tasmota gebruikt. Ik gebruik 5.12, mogelijk maakt dat ook een verschil?
  • Hoi @arthur

    Dank voor jouw aanwijzingen,deze heb ik nauwlettend gevolgd en nu zijn ze wel gevonden.   :)
  • robertkleprobertklep Member
    edited April 7
    Bij het pairen krijg je ook een melding te zien dat als het te lang duurt, je het apparaat uit en weer aan moet schakelen, maar misschien is dat een beetje onduidelijk geformuleerd? (overigens klopt die melding eigenlijk niet, want je móet het apparaat uit en weer aanzetten voordat ie gevonden kan worden)
  • Hoi @Robert
    Dat klopt wel, maar ik denk dat vooral Tasmota 5.12 het grote verschil maakte samen met aanwijzing soft-reboot.

    Soft-reboot is iets anders dan uit en aanschakelen.
    Soft-Reboot is imo "Herstart" en dat is toch iets anders uit en aanschakelen (Toggle).
    Dus wellicht een idee om de aanwijzing/melding te wijzigen in "Herstart".

    Dank allen!! :)
  • Bij deze aangepast, verandering gaat mee met het toevoegen van de 4CH devices (hopelijk morgen klaar).
  • DrDoomDrDoom Member
    Heren,

    Het lukt mij nog niet te pairen. Flashen met Tasmota (5.12) van de Sonoff Basic lijkt gelukt. MQTT Broker (0.1.2) op de Homey geinstalleerd. Krijg bij de 'Get Logs' functie keurig netjes te zien dat er contact gemaakt wordt. Ook als ik met een terminal programma de Sonoff uitlees tijdens het soft booten zie ik geen problemen voor bij komen. Zie onder:

    00:00:00 Project module01 Sonoff (Topic Topic_Module01, Fallback ClientModule01, GroupTopic sonoffs) Version 5.12.0
    00:00:00 WIF: Connecting to AP1 XXXXXX in mode 11N as Module01...
    00:00:06 WIF: Connected
    00:00:06 DNS: Initialized
    00:00:06 HTP: Web server active on Module01.local with IP address 192.168.100.52
    16:16:30 MQT: Attempting connection...
    16:16:30 MQT: Connected
    16:16:30 MQT: FullTopicModule01/LWT = Online (retained)
    16:16:30 MQT: FullTopicModule01/cmnd/POWER = 
    16:16:30 MQT: FullTopicModule01/INFO1 = {"Module":"Sonoff Basic","Version":"5.12.0","FallbackTopic":"ClientModule01","GroupTopic":"sonoffs"}
    16:16:30 MQT: FullTopicModule01/INFO2 = {"WebServerMode":"Admin","Hostname":"Module01","IPAddress":"192.168.100.52"}
    16:16:30 MQT: FullTopicModule01/INFO3 = {"RestartReason":"Software/System restart"}
    16:16:30 MQT: homeassistant/switch/Topic_Module01/config =  (retained)
    16:16:31 MQT: FullTopicModule01/RESULT = {"POWER":"OFF"}
    16:16:31 MQT: FullTopicModule01/POWER = OFF
    16:16:38 MQT: FullTopicModule01/STATE = {"Time":"2018-04-28T16:16:38","Uptime":"0T00:00:16","Vcc":3.212,"POWER":"OFF","Wifi":{"AP":1,"SSId":"XXXXXX","RSSI":98,"APMac":"2C:30:33:64:B2:E4"}}

    Maar bij toevoegen blijft het 'wieltje' draaien...

    Voor mijn info: Bij het starten van het pairen wordt er optioneel om een MQTT broker username en password gevraagd. Ik zie dat @Undutchable62 daar het MQTT account van de Sonoff die hij wil pairen opgeeft. Maar moet dat niet het account van je eventuele extenre MQTT broker zijn als je niet de Homey gebruikt?
    Ik krijg in beide gevallen overigens dezelfde fout.

    Zijn er nog andere plekken waar ik kan troubleshooten?
  • 2mv2mv Member
    Dokter Doom, tijdens het pairen het sonoff apparaat de spanning eraf halen. En weer in het stopcontact stoppen. Dan lukt het pairen. Succes.
Sign In or Register to comment.