This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.


Hello out there.
I have 20 of ZHC5010 in my new house. But i cant not conncet them with Homey.
I have tried push the left upper button 3 time. I have tried to push the middle button 3 times. But nothing work.
I have also triede another
ZHC5010 an tried to cut the power on and off.

First i was in the old firmware for homey and the
ZHC5010. But now i have the newest firmware for the both.

Can somebody help me?


  • cbhcbh Member
    Have you tried the steps on page 4 in the installation notes? (
    Try both the "remove device" method and if that doesn't help, factory reset by pressing the "hidden" button.
  • Yes i have tried the factory reset also. But i will try again.
    Maybe i have to update the firmware in the ZHC5010?
  • cbhcbh Member
    You wrote you're on the newest fw on both?
    Have you updated fw on zhc yourself? Which version?
  • Sorry i didnt now the firmware in til zhc - I have not update this.
    But i have the newest homey software (1.5.7) and the newest zhc app software (2.0.0)

    I altso tried to connect them with she old app and homey software

  • cbhcbh Member
    How close is Homey to the switches?
    Is there some connection or nothing at all?
    Do you get any error messages?
    If you can describe what happens (including all the basics, like "clicked on this one, message in app was this and on) it would be a big help.
  • cbhcbh Member
    edited March 2018
    What happens when you remove a device?
    ("Settings” -> "Z‐Wave” -> “Remove a 
    device”) - does it say "Device successfully removed"? Or is there no response at all?

    To be sure: Devices are connected and power turned on? No battery inside ;-)
  • I have tried with the homey only 1 meter from the zhc - There have never been a connection. I push the "+" and take the ZHC5010 - RELAY - after that i push the left uper butom 3 times (I also tried the hiden midle butom 3 times). After nearly 1 minute, the homey say "No Z-wave device has been found"

    And yes, there is power on :) When i press the left upper butom i can hear the relay clicking. I have also too zhc with LED light, and when i press the butom, the LED light is on.

    I have only problems with the zhc - alle the other device is working fine.

    But do you have to get the zhc very nearly the homey, when you make the connecting?

  • cbhcbh Member
    Try moving Homey closer - it may help - you never know.

    Have you removed the device? (settings - z-wave - remove device)
    No matter the device seems not to be connected to Homey - or any other controller - you should definitely do this - each time you re-attempt pairing a device, this is the first step.

    Be aware that the triple-click has to be rather fast - it fooled me in the beginning...
    Actually, if you hear the relay click when you triple-click, this may be the problem - that you're not tripling fast enough...

    Try opening and enable logging and watch the lines to see what's going on - there ought to be some kind of communication going on...
  • Tanks i will try.

  • cbhcbh Member
    How did it go? Any progress?
  • Yes now it work. The problem was "to slow 3 push" and to long distance between homey and zhc5010

    Tanks :)
  • cbhcbh Member
Sign In or Register to comment.