Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.
Ask your Homey-related questions in this category. You can also go to athom.com/support to get support from Athom.

Partial problem with Somfy RTS rolluik

Just_A_UserJust_A_User Member
edited December 5 in Questions & Help
So, I have installed a rolluik (don't know the english word for it...blinds?) which has a Somfy RTS motor in it. It came with a remote that is not actually a remote shape, but it is a 'remote' that you would normally install on your wall. It is battery powered, it's  square, and it kinda looks like a wall mounted light switch. 

Anyway, the thing works, it let's the rolluik go up and down, so everything is working. Then, I paired it with Homey. That also worked fine, and for the first 3 days, opening it worked great. I made a flow that told Homey to open the rolluik in the morning when the sun comes up, and close the rolluik when the sun goes down.

Here's the problem: 

Homey closes the rolluik in the evening without a problem. It sends me a message on my phone, and all is good. The problem is in the morning. I want Homey to open the rolluik in the morning when the sun is up. Homey sends me the notification that it opened the rolluik, but in reality, the rolluik is still closed. 

If I then go in the (mobile) app of Homey and open the rolluik via the app, it works fine. Then I thought; ok, I'll check over the weekend, but when I came down, the rolluik was open? Both days. 

So, to summarize; closing the rolluik is no issue. Opening the rolluik in the morning IS a problem, except for the weekends apparently, then it works. 

What could be going on here? 

Note: I already set Homey to send the longest possible signal. 

Comments

  • Could you post a screenshot of your flows. I have a feeling that the 'morning workday flow' has an issue.
  • JPeJPe Member
    the longest possible signal isn't always the best, for some devices the shortest signal works best because, for these devices, the long signal is seen as a start+stop signal, so start opening and stop opening the "rolluik"
    http://www.interglot.com/dictionary/nl/en/translate/rolluik
  • Eternity said:
    Could you post a screenshot of your flows. I have a feeling that the 'morning workday flow' has an issue.
    I see how you made you think this....there is no 'weekday' and 'weekendday' flow. There is 1 flow for shutters down, and 1 flow for shutters up: 


    That's it. It DID work the first 3 days, now it does'nt work anymore, except when it is weekend, then it works apparently. Keep in mind that even though the shutter does not go up, I still get the message, so apparently it does execute the flow. 
  • Oh, I see. Yes, I misunderstood your issue.

    Very odd..... but as you write, the flows *does* work... so it must be a communication issue between Homey and the Somfy receiver. I don't own Somfy, so unfortunately can't help you any further....


  • Eternity said:
    Oh, I see. Yes, I misunderstood your issue.

    Very odd..... but as you write, the flows *does* work... so it must be a communication issue between Homey and the Somfy receiver. I don't own Somfy, so unfortunately can't help you any further....


    Yes, it almost has to be a miscommunication, but since the Homey does not move from it's location (which is close to the shutter), AND it works in the evening without any issues AND it also works in the morning during the weekend, where does this go wrong? 

    Because this morning, I was waiting for the message on my phone, which I got, but the shutter stayed closed. I immediately opened the homey app on my phone, and 'manually' set the 'open' command for the shutter device, and the shutter opened right away. 

    It's weird. 
  • JPeJPe Member
    edited December 5
    @Just_A_User
    In my flow, I have 2x the open command, 1 time directly and the second one 1 minute later, the RF signals can always be interrupted by other signals because they can be sent by many devices at any time so you get collisions, I have a weather station that sents every minute his measurements.( so maybe, I better set my delay to 1:30 :) )
  • do you know that you can change the length of each signal thats is send to your somfy blinds?
    maybe change that one and try it again
  • I edited the flow and added 2 delayed 'open' commands. This morning it worked. Weird though that this problem isnt there in the evening. 
Sign In or Register to comment.