Welcome to the Athom Community Forum! This forum centers around the product Homey. Homey is built by Athom and has a mission to connect everything at home. Read more about the product on the official Homey website.

This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.
Ask your Homey-related questions in this category. You can also go to athom.com/support to get support from Athom.

Removal of dead device

cbhcbh Member
edited February 13 in Questions & Help
The question has been up before, but I can't find a solution although searching through the forum :-(

Have a (battery) device, initially added as generic device, and unfortunately not removed properly.
Now it is simply impossible to remove it.
Have tried removing it by clicking the X at the device itself, using the "Remove a device" in settings, including it again (which results in a new unit with a new node-ID) and removing that device.

Get the following message when trying:

The unit has been "dead" for some week and I was hoping it disappeared by itself - but it's still there.
Looking at the graphic representation of the mesh ("157. unknown Z-Wave device"), it has 12 (twelve) connections - and I think it might be causing some delay in the transmissions...


Any suggestions?

Comments

  • When in Settings->Z-Wave->Remove Device, do you perform the action specific to the device? e.g. single button click, triple button click, etc.
    The message you’ve mentioned, do you also get it when try removing from Settings or only when clicking on X? And what is that device actually?

    I had the same problem with a couple of devices but when firmware 1.3.2. 
    One of them eventually removed after few attempts under Settings, Remove Device, the other was a stubborn Fibaro Double Relay 2. I had to reset this by holding the button while power on.
  • casedacaseda Moderator
    An unknown device is a "failed to include completely" device and is not active in anyway once it is reset, that there are connections just means the device is known to the other devices it was nearby on inclusion and is in their neighbouring table, which in turn hasn't been updated yet in those working devices, that that device is not there anymore.

    It will not cause any slower connection(s), as there will be no data to and from the unknown device
  • Fire69Fire69 Backer - Geek Edition
    When you remove it by clicking the X on the device and the device doesn't respond, it will be removed automatically after a timeout period. (if everything goes as it should at least)
  • The device is a blind from https://www.byartandersencph.com/en/ (unfortunately they haven't made an app yet).

    @danone: Yes, tried all possible combinations of what they write in the manual...
    @caseda: Will the other devices not still try to use the routes they "know" according to the z-wave protocol and not until they've failed to get an aknowledgement a certain number of times over a given period stop trying?
    @Fire69: It says so, yes, but it's still there - no matter the number of times I've tried to remove it, using the X or the option under settings :-(

    Anyway, if it doesn't influence speed as @caseda says, it is more some kind of cosmetic problem - and maybe it disappears some day :-)
  • casedacaseda Moderator
    edited November 2017
    Battery devices can't route anyway :wink:
    but even if it is a powered node, if a signal fails for 3 times to get an acknowledge back, it will timeout (and thus not use) for some time on that device route.
  • hi, I have a few devices that is broken and no longer exist , how do I remove them ? 
  • casedacaseda Moderator
    edited January 8
    press the nice red X of the device, and let it timeout (just like it was tolled 3 messages up, by @Fire69).
  • EternityEternity Member
    edited January 8
    Unfortunately, that does not always work, @caseda

    github.com/athombv/homey/issues/1975
  • casedacaseda Moderator
    edited January 8
    @Eternity
    i know that better then anyone i guess :tongue: but for a lot of people it will work
  • EternityEternity Member
    edited January 9
    I know you know. And now we know :-)
    Looking forward to a solution. Somehow I have a feeling these doggy nodes screw up my z-wave performance.
  • I also have two unidentified Z wave devices and am having quite a problem with delay in the z wave networks. I suppose they are the result of incomplete pairing  (or rather unpairing) process. Since I have no nodes with those id:s. As a result of this I can't remove them from the device page since they dont exist there, I cant remove them from the settings => Z wave settings page since there are no device buttons to triple click. The only way to see them is in the Z wave network graph. Is there a way to remove these devices?

    The lag extremely annoying since I use a motion detector to turn the lights on in some rooms but now usually I enter the room, have to turn the light on manually, turn off the light manually and leave the room. Then maybe 30 sec afterwards the light is turned on by the flow :/ .

    I am not sure these nodes are the cause but I see no other reason for the lag..

    For the future an option to remove devices (at least unknown ones) from the network graph would be nice
  • Perhaps this issue should not be flagged as  'solved'... 

    I have updated to the latest experimental f/w and was suggested to try  the new heal button. Still no luck and stuck with a dozen alien nodes. 
  • Eternity said:
    Perhaps this issue should not be flagged as  'solved'... 

    I have updated to the latest experimental f/w and was suggested to try  the new heal button. Still no luck and stuck with a dozen alien nodes. 
    Heal only works with powered devices, those devices will take a look wich devices are near. Battery devices can't be used with the heal function
  • YvesGeffensYvesGeffens Backer - Homey
    I think we need to be able to delete a device with a simple click of a button.
    Apart from the heal function that is.

    When I try to delete a device, it see a message that the device will automatically be deleted when it can't be found, that that doesn't do the trick.

    After 15 seconds or so, I get a message: "vdevice.drivers.zwavebasic.pair.Connection timed out" - click close, and the device is still there.

    When I look at the graph with the interconnections between the z-waves device, it's still there.

    So +1 for removing the "solved" label.
  • TowandaTowanda Member
    edited February 11
    I managed to remove the unidentified devices (I had forgotten about some devices and removed them the standard way). Now I have no unknown devices, only a terrible lag :'( so I guess I can confirm that unkown devices doesn't cause the lag.

    Still think a way do remove devices from the Z-wave network graph would be a useful tool.
  • EternityEternity Member
    edited February 13
    Agree @Towanda

    With Domoticz this was 'easy' ;-)




    - Stop Domoticz (sudo service domoticz.sh stop)
    - Modify zwcfg_xxxx.xml (sudo nano /home/pi/domoticz/Config/zwcfg_xxxx.xml)
    - Find the ghost device-node (<Ctrl> W, id="nn" where nn is the node-number)
    - Remove the sub-node with COMMAND_CLASS_WAKE_UP (Remove from <CommandClass... to - and including - ...</CommandClass>, including the two sub-nodes <Instance> and <Value>. Total 4 lines.)
    - Save zwcfg_xxxx.xml (<Ctrl> S) and stop nano (<Ctrl> X)
    - Restart Domoticz (sudo service domoticz.sh start)
    - In the OZW console select the (now dead) Node and choose option Controller --> Remove failed Node --> GO (wait a few minutes)
    - Restart Domoticz again. The Node will be there with status "Probe (Awake)". After a few minutes, the Node-state should be... DEAD.
    - Stop Domoticz and power down the Raspberry Pi.
    - After restart the Node should be gone.



    Source: www.domoticz.com/forum/viewtopic.php?t=17497
  • Fire69Fire69 Backer - Geek Edition
    edited February 13
    I discovered I have two unknown devices also.  I have no clue what devices this could be.
    They are unknown, the device table in Developer tools show they have no neighbors, but the graph does show neighbors  :/



    Can I discover what devices these are?
    And if they are leftovers, how can I get rid of them?

  • Sorry, this subject has been solved and closed ;-)

    Just kiddin'

    I made a github issue in november. It must be on the to-do list of the Athom team. A was also in e-mail contact with @Emile but  I gues the latest f/w release took over the agenda.

    In November I was advised to be patient.
    So, I am patient :-)
  • Eternity said:

    So, I am patient :-)
    But still!
  • EternityEternity Member
    edited February 14
    Patient, not still...

    It just doesn't feel right to see this subject flagged as closed 'solved'  as it obviously isn't. 

    As it is logged via Github, it will get addressed. So, my patience is with the Athom team. 
  • "solved" tag is removed. It wasn't closed because u could have never response when closed.
  • EternityEternity Member
    edited February 13
    Hm, my wrong!

    Thanks for removing the flag 'solved'.


  • TowandaTowanda Member
    edited February 14
    I need to take back my confirmation that lag has nothing to do with unknown devices :/ . I don't have any in my network graph anymore but according to the developer tool I still have three unknown nodes which I can't figure out what they are, node 3, 27. I am pretty sure there was only one last night






    Another question, how does Homey handle polling time? Does it change automatically or do i need to change it for every device?
  • you need to change polling on every device  i belive 
  • casedacaseda Moderator
    Zwave does in general no polling at all.
    Polling is not needed 99% of the time with powered devices, as a state change is announced by the device itself.
    If in case it is a battery device it can get the state when it wakes up, though that is not done for all capabilities as that creates too much traffic.
    If it has polling (like greenwave devices) then it always is specified in the device's settings
Sign In or Register to comment.