This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to https://community.athom.com.

This forum is now read-only for archive purposes.
Closed Official Zigbee SDK2

[App] Xiaomi-mi ZigBee - Main discussion topic (v0.4.1)

11516171820

Comments

  • gijsjegijsje Member
    I have about 10-15 xiaomi zigbeer sensors and want to make a mesh network to make it more stable.
    What is the best way to make a zigbee mesh network.
    Can it be with the ikea even if i only have xiaomi products?
    The only power device i have is the hub from xiaomi but that is not part of the zigbee network
  • Oy1974Oy1974 Member
    gijsje said:
    I have about 10-15 xiaomi zigbeer sensors and want to make a mesh network to make it more stable.
    What is the best way to make a zigbee mesh network.
    Can it be with the ikea even if i only have xiaomi products?
    The only power device i have is the hub from xiaomi but that is not part of the zigbee network
    The answer you could find yourself, there are multiple topics and answers about it.

    But in short(and long ) only powerd devices making mesh network.
  • gijsjegijsje Member
    Yes i do now this but will the ikea stuff work with the xiaomi stuff to make a mesh?
  • gijsje said:
    Yes i do now this but will the ikea stuff work with the xiaomi stuff to make a mesh?
    Yes they will!
  • EternityEternity Member
    edited July 2018
    I bought 3 powered devices to create a more reliable zigbee mesh, but all zigbee devices (12 in total) are still communicating directly to Homey.
  • gijsjegijsje Member
    gijsje said:
    Yes i do now this but will the ikea stuff work with the xiaomi stuff to make a mesh?
    Yes they will!
    Thanks i will give it a try
  • Eternity said:
    I bought 3 powered devices to create a more reliable zigbee mesh, but all zigbee devices (12 in total) are still communicating directly to Homey.
    Same here, i have many Xiaomi-Aqara devices and only 3 communicate via an Osram plug to Homey.
    The rest communicate directly to Homey while i have 4 Osram plugs and an Innr plug as powered devices.
    Strange...
  • jaykay said:
    Just spotted a new sensor from Aqara on AliExpress, a stock/vibration sensor. 
    http://s.aliexpress.com/jUnUveMZ
    will it be possible to add support for it in your app, @TedTolboom?
    If it is possible, I can’t confirm yet... but mine is on order and I’m awaiting delivery.
    Hi Ted,
    I have an Aqara Wall Switch Single (L, without neutral).
    After pairing, that goes ok, the switch works fine with Homey and some flows.
    But after a few hours the connection with Homey seems to be lost and the switch doesn't respond anymore.
    Removing it from Homey and pairing again (after reboot or PTP of homey) all is well again, but the same happens, connection gets lost.
    All my other zigbee devices (Aqara, Osram, Hue and Innr) keep working fine all the time.
    The Aqara Wall switch is only 2 meter away from Homey.
    What could be wrong?
    @Martin_vd_Aart I'm not sure why this happens... you didn't press and hold one of the buttons of the L-switch?
    Can you check based on what steps the issue becomes reproduceable?
    So I can try to reproduce it here at home and what the Zigbee network traffic via my Zigbee sniffer...
    PetervdK said:
    Will dive into this this weekend, thanks!
    @PetervdK great! Much appreciated.
    HI Ted,
    After the pairing of the switch (single button L, without neutral) , that goes ok, i don't do any other steps.
    I also don't hold the button to long, (i know that might cause it to go into pairing mode again) but just a quick push and it works ok like it should.
    But after a few times switching on/of with a flow triggered by an Aqara doorsensor or with Homeykit it suddenly loses connection.
    It mostly happens within 2 hours after after the pairing, but one day it worked for almost 12 hours and then lost connection again.
    If i test the flow, the red triangle comes with the message "AF data request fails, status code 205, No network route. Please confirm that the device has (re)joined the network".
    All other zigbee devices keep working ok.


    @Martin_vd_Aart thanks for the feedback...
    I’ll have to look into this issue further and see if I can reproduce to get the Zigbee communication data through my sniffer...

    Do you mind creating an GitHub issue (at the apps repository, see link in App Store), for better tracking and consolidating more users experiencing this issue?

    Please accept a delayed response due to the holiday season...😎
  • Is there any way to force a route with my sensors? 
    Per issue above I re-synced a module in my bedroom and it worked for a bit but now once again has dropped. There is a powered device very close by that it seems to ignore the route for and just tries to connect straight to Homey, whcih clearly isn't strong enough for it. Sometimes it even tries to route to a device FURTHER away than homey (a bulb), but it wont use the device that is closest... other devices are using the router closest, but seems to chop and change constantly
  • Same issue here. I intentionally bought routers, but the battery powered window sensor in the attic remains unreachable. 
  • SiaOLiaOSiaOLiaO Unconfirmed, Member
    edited August 2018
    Hi, I bought a pair of Aqara Wireless Double Wall Switch LN and tried to pair them to Homey.
    Everything is fine but problem is that I cannot use voice commands to get Homey to switch of the second switch, i.e. switch on the right.  Same issue with Homekit app in Homey, Homekit only shows 1 switch instead of two.
    Any ideas how to resolve this? 
  • SiaOLiaOSiaOLiaO Unconfirmed, Member

  • SiaOLiaO said:
    Hi, I bought a pair of Aqara Wireless Double Wall Switch LN and tried to pair them to Homey.
    Everything is fine but problem is that I cannot use voice commands to get Homey to switch of the second switch, i.e. switch on the right.  Same issue with Homekit app in Homey, Homekit only shows 1 switch instead of two.
    Any ideas how to resolve this? 
    @SiaOLiaO that is a limitation of the current Zigbee implementation; it does not support multichannel nodes..

    To work around this is I had to make a custom second switch on the same device, which is not recognized by voice and HomeKit..

    it will only be resolved with the Zigbee rewrite...
  • You can create a flow with a virtual device using better logic - name this device the second switch and run a flow to flip it

    I use Alexa and this works for me
  • SiaOLiaOSiaOLiaO Unconfirmed, Member
    SiaOLiaO said:
    Hi, I bought a pair of Aqara Wireless Double Wall Switch LN and tried to pair them to Homey.
    Everything is fine but problem is that I cannot use voice commands to get Homey to switch of the second switch, i.e. switch on the right.  Same issue with Homekit app in Homey, Homekit only shows 1 switch instead of two.
    Any ideas how to resolve this? 
    @SiaOLiaO that is a limitation of the current Zigbee implementation; it does not support multichannel nodes..

    To work around this is I had to make a custom second switch on the same device, which is not recognized by voice and HomeKit..

    it will only be resolved with the Zigbee rewrite...
    Thanks a lot for the advice. Seems like I will have to use this workaround.
  • SiaOLiaOSiaOLiaO Unconfirmed, Member
    vaderag said:
    You can create a flow with a virtual device using better logic - name this device the second switch and run a flow to flip it

    I use Alexa and this works for me
    Hi does this include having to code anything? I am clueless in coding but could start learning to find a workaround. Appreciate if you can point me in the right direction. Thanks in advance.
  • SiaOLiaO said:
    vaderag said:
    You can create a flow with a virtual device using better logic - name this device the second switch and run a flow to flip it

    I use Alexa and this works for me
    Hi does this include having to code anything? I am clueless in coding but could start learning to find a workaround. Appreciate if you can point me in the right direction. Thanks in advance.
    No.
    Better Logic App -> Create variable in settings > create device in devices > create flow in flows
  • I know the xiaomi devices can be connected directly to the homey but why is the xiaomi gateway not use as a "gateway".
    If you look at domoticz there you only need to connect the devices directly to the mi home app and gateway and you can use them.
    I think it would be much better if the gateway is also used as a gateway and not as a separate devices where most function are not even supported.
    If it was used as a gateway you would also be able to use the mi home app to switch some things

  • gijsje said:
    I know the xiaomi devices can be connected directly to the homey but why is the xiaomi gateway not use as a "gateway".
    If you look at domoticz there you only need to connect the devices directly to the mi home app and gateway and you can use them.
    I think it would be much better if the gateway is also used as a gateway and not as a separate devices where most function are not even supported.
    If it was used as a gateway you would also be able to use the mi home app to switch some things

    Hi @gijsje,
    I’m familiar with the way how Domoticz is adding the Xiaomi hub...

    Downside of it is that it will create a seperate Zigbee mesh network, with unique code and network channel. In addition, the automation rules between the domoticz controller and the Mi Home app are not synchronized; which could mean that they are counteracting one another.

    Imagine that you would do this for all different brands; add a Xiaomi hub, add a IKEA Tradfri hub, add a Philips Hue hub... you would end up with 3 different mesh networks (not helping each other) and 4 different apps to control the devices... 🤔

    The whole concept about Homey’s Zigbee network is that all devices can be added individually, creating one big mesh (a IKEA Tradfri bulb will become the router for a Xiaomi door sensor) and being controlled by one set of automation rules and one app...

    That’s IMHO the most intuitive and robust approach.

    That said, Homey’s Zigbee implementation is not there yet; some sections are missing (Zigbee Light Link and IAS cluster) and stability can be improved... which is on the roadmap of Athom to further complement.

    But this app will remain focusing on adding Xiaomi Zigbee devices directly to Homey.... not through a Xiaomi hub...
  • Oscar23Oscar23 Unconfirmed, Member
    Hello! I have a problem. Any xiaomi zigbee device (I'm using a plugin) that I add to Homey appears as "unknown ZigBee", it's very bad ... Help me!
  • Oscar23 said:
    Hello! I have a problem. Any xiaomi zigbee device (I'm using a plugin) that I add to Homey appears as "unknown ZigBee", it's very bad ... Help me!
    Did you install the Xiaomi Zigbee app?
  • Oscar23Oscar23 Unconfirmed, Member
    Oscar23 said:
    Hello! I have a problem. Any xiaomi zigbee device (I'm using a plugin) that I add to Homey appears as "unknown ZigBee", it's very bad ... Help me!
    Did you install the Xiaomi Zigbee app?
    Yes, of course
  • Oscar23Oscar23 Unconfirmed, Member
    Xiaomi device, wifi router and Homey, near. Half meters.... 
  • Oscar23 said:
    Oscar23 said:
    Hello! I have a problem. Any xiaomi zigbee device (I'm using a plugin) that I add to Homey appears as "unknown ZigBee", it's very bad ... Help me!
    Did you install the Xiaomi Zigbee app?
    Yes, of course
    Which version?
    and which devices did you try to install? Are they listed as supported?
  • Oscar23Oscar23 Unconfirmed, Member
    Oscar23 said:
    Oscar23 said:
    Hello! I have a problem. Any xiaomi zigbee device (I'm using a plugin) that I add to Homey appears as "unknown ZigBee", it's very bad ... Help me!
    Did you install the Xiaomi Zigbee app?
    Yes, of course
    Which version?
    and which devices did you try to install? Are they listed as supported?
     v0.4.1 - 18.07.18
    test on
    Aqara Wireless Remote Switch Double
    Wireless switch
    This device unknown Zigbee.

    Normal connect only "Occupancy sensor". 
  • Oscar23 said:
    Oscar23 said:
    Oscar23 said:
    Hello! I have a problem. Any xiaomi zigbee device (I'm using a plugin) that I add to Homey appears as "unknown ZigBee", it's very bad ... Help me!
    Did you install the Xiaomi Zigbee app?
    Yes, of course
    Which version?
    and which devices did you try to install? Are they listed as supported?
     v0.4.1 - 18.07.18
    test on
    Aqara Wireless Remote Switch Double
    Wireless switch
    This device unknown Zigbee.

    Normal connect only "Occupancy sensor". 
    What ID’s does it show under devices > device information?
  • Oscar23Oscar23 Unconfirmed, Member
    Oscar23 said:
    Oscar23 said:
    Oscar23 said:
    Hello! I have a problem. Any xiaomi zigbee device (I'm using a plugin) that I add to Homey appears as "unknown ZigBee", it's very bad ... Help me!
    Did you install the Xiaomi Zigbee app?
    Yes, of course
    Which version?
    and which devices did you try to install? Are they listed as supported?
     v0.4.1 - 18.07.18
    test on
    Aqara Wireless Remote Switch Double
    Wireless switch
    This device unknown Zigbee.

    Normal connect only "Occupancy sensor". 
    What ID’s does it show under devices > device information?

    Aqara Wireless Remote Switch Double

    Wireless switch

  • Seems similar to my problem. Does the product id show on the developers page and/or after a reboot of the Homey?
  • zilla_1982zilla_1982 Member
    edited August 2018
    Is there anyway to make a flowcard, that when the sensor detects for ex. 60% humidity,
    that only then you can trigger an alarm?

    so far i can see is that there is only a card for "when humidity changes ( or temperature)
    but not to set a specific value

    type is : --> Aqara Temperature and Humidity Sensor (WSDCGQ11LM)

    should this do the trick?


  • Is there anyway to make a flowcard, that when the sensor detects for ex. 60% humidity,
    that only then you can trigger an alarm?

    so far i can see is that there is only a card for "when humidity changes ( or temperature)
    but not to set a specific value

    type is : --> Aqara Temperature and Humidity Sensor (WSDCGQ11LM)

    should this do the trick?


    You should use  this card "Greater then" otherwise when the Humidity is 61 its not sending the push becauese its not exactly 60


This discussion has been closed.