Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.

Aeotec Garage Door Controller Gen5 - Shows up as a Door lock.

As posted on the Homey appstore - Aeotec app comments
 
I paired the Aeotec Garage Door Controller Gen5. The device works alright. Although it does not respond 10-20% of all commands sent.

It also shows on Homey as "lock" and "unlock" for a garage door. Could that be changed to Open/Close?

Can we also have Garage Door state, if it is open or closed since it has a tilt sensor for that? My flows do not work correctly because I have to insert "If 'said device' lock OR unlock, turn on the garage lights." Since the tilt sensor shows the incorrect information, and that combined with 10-20% of commands missed, the flow will not work accurately.

Comments

  • Also have issues with the garage door controller. Homey can't seem to understand if my door is closed or open? Or it seems it gets it the wrong way around? It shows up in Apple home app as locked when open and opposite. 

    Have tried calibration steps many times. The tilt sensor is paired. I might be doing something wrong but can't figure out what. 

    Tilt sensor is registered, cause my flow run most of the times it opens/closes. Just at the wrong time.
  • @yhaugom ;Did you happen to figure out how to fix the open/close sensor?
  • I too have had som strange behavior with the garage door controller.

    For one, i think the implementation in homey is a bit strange. There should be one command to toggle the door trigger, and one state to tell if it indeed is opened or closed.

    right now, they are implemented in the same function
    Now, if i open my garage door with my normal remote control, the homey device change state from "left" to "right" (should be opened or closed as mentioned above).
    and if i change the state of the device in homey. It starts to open the garagedoor, and the state is changed, even though the door might not be opened yet.


    @mehakb and @yhaugom, have you been able to change the settings for the sounds?
    for me, even with these settings in homey

    it generates a sound before opening the door. Have also tried to change to other sounds I've uploaded my self, but did not work either.

    Last but not least, when I installed it the other day, I succsessfully opened the garage door via homey, but it did not close the door. Did not have much time to test it though, so maybe it just missed the command as you mentioned @mehakb.

    I think this is quite important to address, not only to be able to use it in flows. But more importantly if you use it to open or close the door remotely, it's quite important to know that you can trust whether it's opened or closed.
  • Just as a quick update, opening and closing seems to work fine for me.
    But not in quick successions, don't know if it's the motor, the garage door controller or homey that dont accept/send the command if I for exampel open the door, then want to stop the opening halfway up, and the close it again. This works fine with the standard IR-remote for the door.

    If i open the door, i have to wait a good 5 seconds or so before being able to close it again with homey. This might just be a problem when testing this out, and not in real life, but still true.

    But either way, it would be much more convenient and usable if the door in homey had one indicator for if the door is opened or closed (tilt sensor) , and one trigger to open/close the door.
  • yhaugomyhaugom Member
    edited February 17
    mehakb said:
    @yhaugom ;Did you happen to figure out how to fix the open/close sensor?
    Sorry, didn't see this until now.I changed the logic in the app myself, and submitted a pull request on Github: https://github.com/athombv/com.aeotec/pull/86
    As you can see they asked me to contribute, but I haven't had the time yet. I am busy on other projects at the moment. 

    @Baron I agree with the other comments about toggle and showing current state is a bit strange.
    Did try to change sound, but not upload my own. Changing sound worked I think, if I didn't do it manually on the garage door controller? Don't remember.

    If I can find the time I will have a look.
  • I would say that the Aeotec garagedoor controller is not compatible with Homey witout this function implemented. I had to revert to adding it back to the Vera for the time being and running dual controllers. The Vera creates 2 devices (1, Sensor value for Open/Close) (2, For the opening and closing function) Remove it or fix it! 
  • BaronBaron Member
    edited April 15
    yhaugom said:
    mehakb said:
    @yhaugom ;Did you happen to figure out how to fix the open/close sensor?
    Sorry, didn't see this until now.I changed the logic in the app myself, and submitted a pull request on Github: https://github.com/athombv/com.aeotec/pull/86
    As you can see they asked me to contribute, but I haven't had the time yet. I am busy on other projects at the moment. 

    @Baron I agree with the other comments about toggle and showing current state is a bit strange.
    Did try to change sound, but not upload my own. Changing sound worked I think, if I didn't do it manually on the garage door controller? Don't remember.

    If I can find the time I will have a look.
    I have the will to fix this, but not the coding knowledge. Can i buy you a beer or two too motivate you to find some time to implement the improvements needed?
    For the moment I get irritated when ever I use the garage controller. So might be motivated to buy you a few beers ;)
  • Does the garage controller have to be in direct range of the homey itself? Mine pairs and responds fine when connected in the living room, but not responsive when installed in the garage. I have wall plugs in the garage also that works fine, so the mesh works fine.
  • BaronBaron Member
    Don't think so. But mine was acting very weird before I got it going to. Worked I. The living room (next to homey). But not in garage. My guess is that the route in the mesh not updated when I moved it.

    Try the tools on you homey settings to fix your mesh to see if it helps
  • BaronBaron Member
    And by the way. I've been following the git. And it seems like the fix @yhaugom made now have been accepted. So hopefully in the next update the inverse problems might be fixed.
Sign In or Register to comment.