This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to https://community.athom.com.

This forum is now read-only for archive purposes.

Zigbee devices go offline

LurendrejerLurendrejer Member
edited August 2017 in Questions & Help
Hi.
What does "Offline" mean when we are talking about zigbee? (Ikea Trådfri).
I have two bulbs, sitting two meters apart, hanging in the air - and one can be offline while the other is online.

The bulbs are powered all the time and i can turn on the bulb through homey if i try a few times - why does this happen?


«1

Comments

  • I have the same problem, after rebooting the Homey (not sure if this caused it or not) I notice almost all my nodes (also Tradfri) are offline. Switching works but not reliably. What gives? 
  • No-one has any ideas? Tradfri does not work reliably at all and I would hope someone from Athom would care about that...
  • email support,  i use 5 ikea lights and all good 
  • TonD83 said:
    No-one has any ideas? Tradfri does not work reliably at all and I would hope someone from Athom would care about that...
    Works fine for me. I have 4 Tradfri bulbs. Distance between Homey and all bulbs max 5 meters. Does the reliability improve when you bring one or more bulbs close to homey?
  • TonD83TonD83 Member
    edited September 2017
    Problem is it worked perfectly for a couple of days until I rebooted Homey. Now it's flakey and unreliable, bulbs are showing as offline. With the Zigbee mesh network there is no reason for bulbs to be unreachable as 4 bulb are sitting right next to each other. Will try to contact support directly.

    @Lurendrejer
    Have you found any solution for this problem yet?

    Update: after updating to 1.5.3 most devices came back online, only the lamp in the attic is still offline and now not even connected in the graph anymore. Strange, but I did move the Homey slightly since installing so this could be a range problem. 
  • @TonD83 I gave up.
    My trådfri devices turn off via a relay, and i use the Ikea rotating dimmer directly associated to them.

    I had both hue and trådfri connected via zigbee, so I thought that was the reason. If you only have Ikea devices, I guess that isn't the case :(
  • TonD83TonD83 Member
    edited September 2017
    @Lurendrejer
    I have an extensive Hue network, too. I use them through the Philips bridge though. Did you connect them directly to Homey?

    Edit: Thanks for the hint.. I just checked and Hue and Tradfri were both on channel 11. I changed Hue to channel 25. Let's see if this improves the situation. See: https://support.metageek.com/hc/en-us/article_attachments/115017048148/ZigBee_Channels.pdf
  • I did use zigbee through homey, no bridge.
  • Didn't even know this was possible. But not a success story anyway, it seems :) 
  • bvdbosbvdbos Member
    edited September 2017
    No problem for me... Tradfi works reliably for me...
    Seeing you both have similar issues and the network-controller of @TonD83 is made by Philips while the controller of @Lurendrejer is made by Athom I think this might be inherent to Zigbee?

    Did any of you file an issue on Github? Athom will probably not react here...
  • Hmmm that's not entirely correct, I use Tradfri through Homey directly as well. I was just saying I use Hue bulbs through the Hue hub.
  • Just tried putting my bulbs always online (by disabling the relays).

    I had hopes of 1.5.5 solving the problem, but zigbee devices still go "offline". They don't work in flows, but turning them on/off via 'devices' seems to be pretty reliable.

    I've doublechecked my wireless AP's - that they don't use the same channel as Homey-zigbee.
    I've readded bulbs.
    I've added extra bulbs, to strengthen the network.
    I've had my Homey turned off for 30 minutes, to force the devices into creating new routes.

    still - two bulbs, in the same room (even in the same lampshade) doesn't always have the same status. One is offline, the other is online.
  • If it works through devices then you'll probably need to increase the time between switching the bulbs.
  • Not sure if it's related, but I have some problems with the Zigbee Ikea ligths too. In the Zigbee Graph the lights are online, but switching them via Homey doesn't work. The stay on.. Last week I had the same problem and even tried to remove and readd one of the bulbs. Strangely that worked withoud a problem, but after adding, I still couldn't controll it via Homey. After a couple of reboots, everything started working again..

    For now, I'm going t o reboot again a couple of times...
  • kastelemankasteleman Member
    edited November 2017
    @keverjeroen ; what firmware are you running?
  • Running on 1.5.4. I just (soft) rebooted Homey, and the lights are working again.
  • Same issue here. With 1 Tradfri bulb it worked almost fine, but now I have 3 bulbs it doesn't work anymore. After a reboot or PTP it is working for several hours, after that, the bulb status won't refresh en don't go on or of anymore. FW 1.5.8
    Removing all the bulbs and a reset then and added them again didn't help.
  • ArjenArjen Member
    Hi, how do you change the Zigbee channel in Homey?
    Mine is reporting channel 11, without any sign of how to change that...
    Since my wifi is 'stuck' on channel 1 (heavily interfering with zigbee 11), I'd like to have a go at channel 18...
  • You can’t! Not implemented (yet) by athom
  • ArjenArjen Member
    You can’t! Not implemented (yet) by athom
    Thanks! Well, anyone interested in a Portal Router? <span>:wink:</span>

  • Arjen said:
    You can’t! Not implemented (yet) by athom
    Thanks! Well, anyone interested in a Portal Router? <span>:wink:</span>

    Just sold mine and replaced them with ubi AC-Pro haha :P 
  • B3rtB3rt Member
    here same problem..

    I have about 12 ikea bulbs and randomly bulbs do not respond on flows.
    When i run the flow manually i get a red triangle with ikea several ikea bulbs and on hover over it reports rpc 17 error.

    I rebooted homey but this does not always solves the problem, sometimes i reboot the bulb (power on/off of bulb) and this helps.

    I do not have this kind of problems with z-wave devices but only with the ikea bulbs, this way flows are not very reliable.

    Are there some tricks to get the zigbee network much more stable/reliable?
    (i am running Homey firmware 1.5.3)
  • zigbee should be more stable in the upcoming 1.5.6-rc10 release. so hopefully with the stable 1.5.6 the zigbee probs will disapear ;-)
  • phil_s said:
    zigbee should be more stable in the upcoming 1.5.6-rc10 release. so hopefully with the stable 1.5.6 the zigbee probs will disapear ;-)
    RC10 wil not come to experimental, RC11 at this moment in DP :)
  • SlofwareSlofware Member

    What is the recommended amount of zigbee devices in a device group, now using 4 and 6 ikea lamps and sometimes 1 is not responding on the group.
    Also 1 single lamps is not responding on a flow, is that still a bug in zigbee?

    Hopefully it all will be solved in Homey 2.0? 

  • lubbertkramerlubbertkramer Member
    edited July 6
    Slofware said:

    What is the recommended amount of zigbee devices in a device group, now using 4 and 6 ikea lamps and sometimes 1 is not responding on the group.
    Also 1 single lamps is not responding on a flow, is that still a bug in zigbee?

    Hopefully it all will be solved in Homey 2.0? 

    groups is not yet fully implemented in the current zigbee implementation of Athom
  • SlofwareSlofware Member
    Oké so for now it's better to switch them one by one.
    Can do that without delay if I switch 6 lamps?
  • cautjecautje Member
    @Slofware nope, i have tried it all with ikea 6 gu10 lamps. Swiching one by one with an delay of 1 sec. All at once and repear 3 times with an delay of 1 sec. Always one or two dont switch... i gave up tring for almost a year. Now waiting on the zibee stack rewrite in V2.0
  • cautje said:
    @Slofware nope, i have tried it all with ikea 6 gu10 lamps. FSwiching one by one with an delay of 1 sec. All at once and repear 3 times with an delay of 1 sec. Always one or two dont switch... i gave up tring for almost a year. Now waiting on the zibee stack rewrite in V2.0
    Will not be in 2.0 but after 2.0 so some more patience is needed
  • cautjecautje Member
    @lubbertkramer
    Ok, thx. Then it was wischfull thinking... It would be great this is solved. This is my main issue, the rest is working fine. 
Sign In or Register to comment.