Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.
Official

[Published] Ziggo Horizon app

jordenjorden Member
edited July 19 in Apps
As of today, there is now an app to control Ziggo Horizon available in the appstore: https://apps.athom.com/app/tv.horizon.ziggo

Enables the following actions to use in your flows:

  • Toggle power
  • Send key

Changelog

Version 0.1.2:

  • Fixed Power toggle action card

Version 0.1.1:

  • Fixed: Now correctly closes connection

Version 0.1.0:

  • First release
Tagged:
«1

Comments

  • jordenjorden Member
    I hope we can soon discover how to detect if it's on or off; that will enable more cool possibilities.
  • icekingiceking Member
    So I added the IP address of my horizon in Homey (I tested the IP in my browser to make sure the login page of the Horizon is opened)...Created a simple flow and used the test button, but nothing happens. It does show a green check icon, but my Horizon isn't responding to the command. So my Homey is (ofcourse) connected through Wifi to my router and my Horizon is connected with an ethernet cable to my router, this should not be any problem right? the remote in the official Ziggo app is working so there should be an open internet connection between the router and the Horizon.  So what am I doing wrong here... ? 
  • jordenjorden Member
    That's really hard to tell. Currently the "Send key" card should work and it should show the green mark only if the command was correct,  but I'm not completely sure if that works the way I intended it :) This first version is more of a "wow this seems to work well"-version, I am going to put some more time into it soon.

    Some things you could check:
    1- If you are logged into the same Wifi network, can you ping both Homey and the Horizon box?
    2- If you install the Horizon app via the developer tools, can you show me the logs of when you execute the test flow? There are no "secret" settings in this app that you should mask in the logs, but ofcourse you can also send the logs in a private message.

    Part 2 is a bit hard if this is your first time running an app via the developer tools. Some more is explained via https://developers.athom.com/ - it requires you to install Node and NPM, then install the athom-cli tools via commandline and then you can download the app from https://github.com/jordenc/tv.horizon.ziggo and run it.
  • icekingiceking Member
    Hm thanks, I will try to run de dev tools and see what logs I get. It is my first time running the dev tools, but that shouldn't be a problem... It was your first time once to ;-p I will try to get it al working and post the logs.
  • Pietje5Pietje5 Member
    Work really fine overhere. Installed via developer tools
  • Pietje5Pietje5 Member
    iceking said:
    So I added the IP address of my horizon in Homey (I tested the IP in my browser to make sure the login page of the Horizon is opened)...Created a simple flow and used the test button, but nothing happens. It does show a green check icon, but my Horizon isn't responding to the command. So my Homey is (ofcourse) connected through Wifi to my router and my Horizon is connected with an ethernet cable to my router, this should not be any problem right? the remote in the official Ziggo app is working so there should be an open internet connection between the router and the Horizon.  So what am I doing wrong here... ? 
    Had the same here first to. Green check but the wrong IP. First filled in 192.168.192.1 but that was the router. Then tried 192.168.192.2 and bingo!
  • jordenjorden Member
    edited July 21
    The IP can be a bit hard to find, because it depends on how you set up your network. If Horizon is also your router, it is probably the router IP +1, if not it can be anything. You can see it in the Horizon menu I think (didn't check)
  • Pietje5Pietje5 Member
    Jorden said: If Horizon is also your router, it is probably the router IP +1

    Correct!
  • icekingiceking Member
    So I have the Logs :-) But it looks like the IP is incorrect or the IP can't be accessed which was kinda obvious... But I don't understand why it's not working. 

    To make sure I used the correct IP address I checked the IP in the browser and in my Horizon management. As I mentioned in my first post, I do NOT use my Horizon as router, I have my own router which is connected to both the horizon and my Homey. I have added an screenshot of my Horizon management screen. Hopefully someone has the solution to this strange puzzle :p 

    ==================================================================
    Horizon app - init done
    Horizon app - got get_devices from front-end, tempIP =192.168.1.107
    Horizon app - list_devices tempIP is 192.168.1.107
    Horizon app - User aborted pairing, or pairing is finished
    TypeError: Cannot read property 'settings' of undefined
        at Object.<anonymous> (/drivers/settopbox/driver.js:210:46)
        at emitThree (events.js:97:13)
        at Object.emit (events.js:175:7)
        at /homey-app/manager/flow.js:12:37
        at /homey-app/helpers/client.js:1:1035
        at Array.forEach (native)
        at process.<anonymous> (/homey-app/helpers/client.js:1:1004)
        at emitTwo (events.js:87:13)
        at process.emit (events.js:172:7)
        at internal/child_process.js:729:12

    --- INFO: tv.horizon.ziggo has been killed ---
    ================================================================

  • Pietje5Pietje5 Member
    made a flow for example to set channel 204. That does not work properly every time. Would be great if there was a code for each channel wich can used in one card
  • jordenjorden Member
    @iceking if you restart the app after it crashed, does it work? I am doing something wrong with the initial "setup" of the device which I need to fix soon.
  • Does it work with the other ziggo mediabox too? Installed the app and it is not working. 
  • jordenjorden Member
    For as far as I know, only with the Horizon mediabox.
  • icekingiceking Member
    @jorden Hm interesting, I will try and let you know.
  • jordenjorden Member
    0.1.3 is pushed to the appstore for approval. It fixes the crash on the first "command" you execute after pairing.

    Also has a "Set channel" card now, which makes it easier to set a channel number above 9. This will work better for you @Pietje5

    I will update the first post as soon as the new update gets published.
  • Pietje5Pietje5 Member
    @jorden : Thumbs up!!! Great Job so far!
  • jordenjorden Member
    New version published to the app store!
  • icekingiceking Member
    So I was testing your idea, and with some success. After restarting the app, it showed a green check and the logs says it succesfully added the IP address .... but unfortunately when triggering a flow the connection was refused ... I think the port 5900 is not opened by the Horizon or something.
    My log:
    ====================Athom LOG==================================
    TypeError: Cannot read property 'settings' of undefined
        at Object.<anonymous> (/drivers/settopbox/driver.js:218:60)
        at emitThree (events.js:97:13)
        at Object.emit (events.js:175:7)
        at /homey-app/manager/flow.js:12:37
        at /homey-app/helpers/client.js:1:1035
        at Array.forEach (native)
        at process.<anonymous> (/homey-app/helpers/client.js:1:1004)
        at emitTwo (events.js:87:13)
        at process.emit (events.js:172:7)
        at internal/child_process.js:729:12

    --- INFO: tv.horizon.ziggo has been killed --- 
    add device: {"id":"192.168.1.107"}    // This is the restart :-D
    Horizon app - init done
    ======================================================
    Horizon app - sending E301 to 192.168.1.107
    Error: connect ECONNREFUSED 192.168.1.107:5900
    Connection closed
    ======================END Athom log============================
     
    So after some research I found this article from Tweakers where they have some more port numbers which could be open: https://gathering.tweakers.net/forum/list_messages/1517323/35
    So what I did next was opened my terminal and ran 'nmap 192.168.1.107' and with this result:

    ============ NMAP Scan Result =============
    Starting Nmap 7.12 ( https://nmap.org ) at 2017-08-01 23:39 CEST
    Nmap scan report for 192.168.1.107
    Host is up (0.0089s latency).
    Not shown: 997 closed ports
    PORT    STATE    SERVICE
    23/tcp  filtered telnet
    80/tcp  open     http
    443/tcp open     https

    Nmap done: 1 IP address (1 host up) scanned in 7.96 seconds
    ================ END Nmap scan =====================

    So I think that only port 23 (SSH), 80 (HTTP) and 443 (HTTPS) are open and not 5900 which is used in the Horizon app. Maybe my Horizon is to new and that they fixed the open ports or something ? I'm curious if other people get a different result when they scan (nmap) there Horizon IP.... 
  • jordenjorden Member
    @iceking can you try to use 192.168.1.108 instead? Let's see if that works, I've seen it before :)
  • Hi! A bit off topic.. My Horizon is in a complete other network then my home network (via the Ziggo modem). I guess this are some default settings from the Horizon box. Any tips on how I get my Horizon in the same network? <span>:open_mouth:</span>
  • icekingiceking Member
    @jorden
    Thx, the IP 192.168.1.108 works !!! <span>:smiley:</span>
    So the app works now :-) Thx for the support. I still have to restart the app after installing before it works, but if you know that and you have the correct IP address there is no problem  
  • jordenjorden Member
    @keverjeroen That completely depends on your network setup. I use a separate router, Horizon does not do routing for me but is just a client in the network. You can do that in the settings but ofcourse you'll need another device that will do routing.
  • @jorden , just wondering, I'm in the old Ziggo area and can't use the Horizon as a modem in the network. I understand you've got the same and set-up the unit as a client. Does ondemand still work? And the Netflix app?  
  • OskarOskar Backer - Homey
    Jordan, I like this app, as it particularly helps to overcome my link with Harmony that only issues IR commands, Should I get this working as planne, I can now use the "Guide" button on Harmony, via Homey, to send the WIFI commands "guide" (now done via a series of button presses via the harmony app).

    However, not there yet. My Horizon box does not react to any command so far. I have a separate modem/router, so I changed the Horizon IP address to my local network. This works as I can now login to Horizon directly  from my network. But via the Homey app I get no reaction. I thought possibly setting changes on the separate WIFI capability of the Horizon box could be related but this also did not make a difference.
    Somehow a connection seems to be linked in a different way, however I am not clear on how to go further in tracing or testing where the link is broken

    Any ideas?
  • bvdbosbvdbos Moderator, Backer - Geek Edition
    Horizon has a separate app: https://apps.athom.com/app/tv.horizon.ziggo
  • OskarOskar Backer - Homey
    edited August 13
    That's the one I am refering to.
    I see there are 2: one for IR commands and one by Jordan with WIFI commands.
    I thought this was the topic for WIFI, although great if it will all be integrated into one app


  • bvdbosbvdbos Moderator, Backer - Geek Edition
    Ah, meant to point to the IR-oen :)
    https://apps.athom.com/app/nl.ziggo.horizon.ir
  • jordenjorden Member
    Steefph said:
    @jorden , just wondering, I'm in the old Ziggo area and can't use the Horizon as a modem in the network. I understand you've got the same and set-up the unit as a client. Does ondemand still work? And the Netflix app?  
    I don't use the Netflix app, but it works. Ondemand I do use and works as well. The only thing that changes is that it doesn't act as a bridge in your network, although it does for your "extra" Horizon mediaboxes (I have one extra in the bedroom).
  • jordenjorden Member
    edited August 13
    Oskar said:
    Jordan, I like this app, as it particularly helps to overcome my link with Harmony that only issues IR commands, Should I get this working as planne, I can now use the "Guide" button on Harmony, via Homey, to send the WIFI commands "guide" (now done via a series of button presses via the harmony app).

    However, not there yet. My Horizon box does not react to any command so far. I have a separate modem/router, so I changed the Horizon IP address to my local network. This works as I can now login to Horizon directly  from my network. But via the Homey app I get no reaction. I thought possibly setting changes on the separate WIFI capability of the Horizon box could be related but this also did not make a difference.
    Somehow a connection seems to be linked in a different way, however I am not clear on how to go further in tracing or testing where the link is broken

    Any ideas?
    Can you ping both Homey and the Horizon box with your laptop if you are in the same network? You might also want to try to set the IP in the Homey-Horizon-app to one higher (+1) than the one you think it is... that has worked for some people.
    So if your Horizon is at 192.168.1.7, try 192.168.1.8 as the IP in Homey and try if that works.
  • OskarOskar Backer - Homey
    jorden said:
    Oskar said:
    Jordan, I like this app, as it particularly helps to overcome my link with Harmony that only issues IR commands, Should I get this working as planne, I can now use the "Guide" button on Harmony, via Homey, to send the WIFI commands "guide" (now done via a series of button presses via the harmony app).

    However, not there yet. My Horizon box does not react to any command so far. I have a separate modem/router, so I changed the Horizon IP address to my local network. This works as I can now login to Horizon directly  from my network. But via the Homey app I get no reaction. I thought possibly setting changes on the separate WIFI capability of the Horizon box could be related but this also did not make a difference.
    Somehow a connection seems to be linked in a different way, however I am not clear on how to go further in tracing or testing where the link is broken

    Any ideas?
    Can you ping both Homey and the Horizon box with your laptop if you are in the same network? You might also want to try to set the IP in the Homey-Horizon-app to one higher (+1) than the one you think it is... that has worked for some people.
    So if your Horizon is at 192.168.1.7, try 192.168.1.8 as the IP in Homey and try if that works.
    I can ping all of indeed both (192.168.1.24 is Homey and **.27 is Horizon). Interestingly the Horizon box created a lot of entries in my DHCP table. UPCGW-7822 is the one on **.27 and is online. Then there are 15 other hostnames: UPCGW-2200, UPCGW-2201 up to UPCGW-220E (I expected a UPCGW-220F, but is not there) and then a UPCGW-2242. The associated IP addresses are not in same order as other client have some of those addresses in use. I am not sure which one is most logical to pick.
    The Horizon box is off now and, with exception of the host UPCGW-7822 on IP **.27, all other associated hosts are offline as well. So it would not make sense if I test **.28 now knowing it is offline.

    I will see what happens if I test a power-toggle and some other buttons on alternative IPs, and will share my findings.
Sign In or Register to comment.