This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Light doesn't stay on when movement is detected

tomdevissertomdevisser Member
edited June 2017 in Questions & Help
Hi guys,

I'm trying to automated the light in the bathroom with:
- Aeotec Multisensor 6, USB powered;
- Fibaro Dimmer 2;
- Countdown

Unfortunately the light goes on with a relay of around 3/4 seconds. But most importantly, the light does not stay on when motion is detected before the countdown has ended. The light goes of and it will take between 5 to 30 seconds (random) before it will switch on. Below you find my setup (sorry, in Dutch).

Hope you can help me with my setup.
I'm stuck.


  • glijieglijie Member
    edited June 2017
    WHEN movement AND timer is off THEN turn on the light ELSE stop timer
    WHEN no movement THEN start timer
    WHEN timer is empty THEN turn off the lights
  • Hero....
    Works like a charm.

    Problem solved.
  • glijieglijie Member
    Just changed a little the flow
  • glijieglijie Member
    Maybe better to use this:

    WHEN movement AND light is off THEN turn on light ELSE stop timer
    WHEN no movement THEN start timer
    WHEN timer is empty THEN turn off light
  • swtttswttt Member
    Why not just

    IF movement THEN zandloper omdraaien and lights on
    IF zandloper empty THEN turn lights off

    This way if you keep moving the zandloper wil be resetted to the max time again. And only turns off when there hasn't been movement for the time the zandloper was running.
  • glijieglijie Member
    because if movement doesn't stop the light wil go off.
    And why turn on the light when it is on?
  • swtttswttt Member
    If the zandloper never gets to 0 it wouldn't turn off.

    So if you keep moving within the area and you have a flow like IF movement THEN timer 60 seconds and light on it never turns off.

    Then if the zandloper hits 0 turn the lights off == no movement for 60 seconds

    Turning the lights on on every movement is not something you will notice at all.

    You even could do the first flow something like:
    IF movement AND light is on THEN timer on 60 seconds ELSE light on and timer 60 seconds
  • swtttswttt Member
    You might need to edit the sensor blind time settings etc. So it can detect multiple movements within the 60 seconds. (had to with my fibaro as well)
  • glijieglijie Member
    swttt said:
    If the zandloper never gets to 0 it wouldn't turn off.
    That's why I use IF Motion stops THEN start the timer

    It is all about triggering. With the standard settings of most motion sensors you have to change indeed the blind time.
    otherwise if movement doesn't stop there will be no trigger to reset the timer again and lights go off.

    In a toilet it maybe would not be such a big issue, but if you use it in a crowded livingroom i'm sure the lights go off and won't go on until the sensor stops seeing movement.
  • swtttswttt Member
    edited June 2017
    Why would you want to start the timer if the motion stops? The timer should be running and resetting to 60 seconds IF there is motion. I use it like this in 3 places in the house, works like a charm and saves even a flow.

    So for me Timer Running == There is motion.
    As long as the timer doesn't hit 0 the lights stay on.
    Motion CAN be triggered again within the timer running (60 seconds), you might need to edit the device settings for it.
    When the Motion is triggered again, the timer is set to 60 seconds again.

    How would it be possible to have the lights go off if there is motion in this example? :/

    Just noticed our flows might be different because of different devices. With my fibaro i was able to set it up that even if it keeps seeing movement it does stop the movement alarm and triggers again within the 60 seconds. Not sure if this is possible with the aeotec, but my feeling says it should be :/
  • glijieglijie Member
    because you did change the settings (blind time) Why do you think that the light did go off from the one who started this post?
    The 2e flow he made is not wrong for restarting the timer? isn't it?
  • swtttswttt Member
    No its not wrong but not needed. 
    It's actually the same as mine if you remove the 2nd flow, and take away the AND column in the first one.
    Then he should make sure to edit the device settings so it is capable of noticing multiple triggers within 60 seconds.

    After that it should work as intended, and saves another flow.

  • glijieglijie Member
    yep change the settings is the way to do it also. I'm sure that changing the setting will give more questions in most cases tho.

    Now for me. Does this drain the battery more if the blind time is lowered?
  • swtttswttt Member
    Fibaro is running for 8 months now on the same battery. So not that i noticed...BUT mine is only switching when its dark outside.

    It's just that i want to minimize the amount of flows. Even ordered well in folders and sub-folders...i have allot. Every flow i can save is another one :)
  • glijieglijie Member
    Here also a lot of flows and well ordered...I think.

    Because I use the same Motion sensor for more flow triggers. I don't use the trigger WHEN timer stops, but i use 
    When the timer is at certain number.  This way I don't have to use multiply timers for one motion sensor.

    And that saves also a lot of flows for me.
Sign In or Register to comment.