This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Aeon Multisensor 6 - Wake-up Time

Hi there,

The wake up configuration of an Aeon Multisensor 6 is 4 bytes. In the config of the app I can set it to max 3600. Is there a reason for that, I'm I confused or is this a bug/feature request? I want to set it to a higher value to see how much this improves battery life as currently I have issues with 2 Multisensors both running new firmware and die in 3 days.


  • casedacaseda Member
    edited April 2017
    The values are gotten from the device itself on inclusion, if it can't go higher, then the module does not support higher.

    maybe that it has been changed in a firmware update of the sensor,
    but with the one 1 have the maximum is also really only 3600.

    the wakeup class value is 4 bytes, and that is defined by the z-wave alliance,
    its up to the manufacturer if they want to keep this full range of 0 - 4 228 250 625 seconds,
    or change the min, max and the size of steps
  • Hi there, the engineering spec also indicates it is using 4 bytes value. It seems that the maximum value is defined in the app or underlying system. I have contacted Aeotec and they confirmed that you can set higher values as wake up time.
    There are quite some use cases where a wake up time of every hour is not required.
  • casedacaseda Member
    edited April 2017
    Like I said, it is gotten from the sensor itself, no matter what the amount of bytes say.
    It's all what the manufacture puts into the maximum 4 byte size configuration.
    (after checking the documentation, it's not even 4 bytes for version 2, which is being used, but 3 bytes :wink: )
    aeotec uses a lot of parameters that are 4 bytes, but only 1 (even the half of that 1) is being used.

    just take a look at the parameters for what is being send to association groups (101, 102, 103)
    those are really good examples of that.

    The wake up time is limited in the gui,
    since all values that fall out of the range will deem "invalid"
    if the value is invalid, the standard wakeup time will be used (3600 seconds)

    these are the RAW values gotten from the device: (gotten them just a few seconds ago)
    { 'Minimum Wake Up Interval Seconds (Raw)': <Buffer 00 00 f0>,
      'Minimum Wake Up Interval Seconds': 240,
      'Maximum Wake Up Interval Seconds (Raw)': <Buffer 00 0e 10>,
      'Maximum Wake Up Interval Seconds': 3600,
      'Default Wake Up Interval Seconds (Raw)': <Buffer 00 0e 10>,
      'Default Wake Up Interval Seconds': 3600,
      'Wake Up Interval Step Seconds (Raw)': <Buffer 00 00 3c>,
      'Wake Up Interval Step Seconds': 60 }

    EDIT: and if you so desire here is the RAW data, that is in the z-wave log:
    Received application command for COMMAND_CLASS_WAKE_UP, data: 0x0a0000f0000e10000e1000003c

    It was even me who was asking for this limiting factor, since there are 2 big reasons.

    1. There are devices that have 0, and only support 0 (and yes i am talking about battery devices)
    but 99% of the battery devices that HAVE a wakeup time, don't support 0.
    0 = thus normally an Invalid value. (0 even disabled the settings button before this change, because the reason: why would you ever turn of wakeup)

    2. What i said before, if the value is invalid, especially with big steps,
    look at eurotronic elektronic thermostatics with a step of 300! seconds,
    and a default wakeup time of once a week,
    even though it only sets temperature when it wakes up...
    i wouldn't want my users to only be able to change the temperature once a week just because they use an invalid value.

  • Hi there, thanks for the extensive information. So basically device is reporting incorrect maximum wakeup seconds value as it can be configured above the value of 3600? It has been confirmed it can go above that  by Aeotec itself and I also tested it with another Z-wave controller (Homeseer) where I have a few of these sensors also attached to.
    I have many of these devices also with different firmware what command do you send to the device to report back the command_class_wake_up info so I can check it in logs?
  • TedTolboomTedTolboom Member
    edited April 2017
    @d_janssen you can check the feedback of the device yourself.
     * =========== GETTING WAKE UP INTERVAL (version 2) ===========
     * To get a certain device's wake up range we can use the
     * "Send raw data" in the z-wave settings.
     * NODE_ID = the node id you want the information from (Decimal or Hexadecimal)
     * The device does need to be awake just before sending this GET.
    Settings > Z-wave stuff for geeks
    'Send raw data': NODE_ID,0x84,0x09
    Wake-up the device and press send during the devices wakeup

    In the Z-wave log the feedback of this device will be shown:
     * Report back will be in Hexadecimal:
     * COMMAND_CLASS_WAKE_UP, data: 0x0a#1#2#3#4#5#6#7#8#9#A#B#C
     * 0a = WAKE_UP_IntervalCapabilitiesReport
     * #1 - #3 = Minimum Wake Up Interval Seconds
     * #4 - #6 = Maximum Wake Up Interval Seconds
     * #7 - #9 = Default Wake Up Interval Seconds
     * #A - #C = Wake Up Interval Step Seconds
    Example of a Neo PIR (in lack of a Multisensor 6 myself):
    [2017-04-26T21:32:04.969Z] Node[21]: Received application command for COMMAND_CLASS_WAKE_UP, data: 0x0a00012cfffff000a8c000003c
    0x0a = WAKE_UP_IntervalCapabilitiesReport
    00012c = 300 = Minimum Wake Up Interval Seconds
    fffff0 = 16777200 = Maximum Wake Up Interval Seconds
    00a8c0 = 43200 = Default Wake Up Interval Seconds
    00003c = 60 = Wake Up Interval Step Seconds
    Can you share your results?
Sign In or Register to comment.