Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.

Smart Presence; ERROR

obeliksobeliks Member
Since today, I receive the message "Cannot read property 'split' of undefined" in the log of Smart Presence... It doesn't see my presence anymore.  Removed the app and installed again, didn't work...
Somebody?


«1

Comments

  • bvdbosbvdbos Moderator, Backer - Geek Edition
    Could you save the settings, think that will probably work...
  • Could you save the settings, think that will probably work...
    Thanks, I had the same issue; now it works again.
  • obeliksobeliks Member
    edited January 10
    It was not Save Settings (@ Devices) but Save Changes (@ Settings). Now it works again!
    Tnx BasVanDenBosch
  • JonJon Backer - Super Early Bird
    I have installed the smart presence app and added my phone with what I with a 100% certainty know correct ip address, but somehow the app keeps displaying a 'disconnected' sign. 
    Anyone who know what might be the issue here? 

  • the disconnected sign means  that your not presence. so if you are at home check  if you are connected with the right wifi network..if so make sure that your phone has a fixed IP
  • JonJon Backer - Super Early Bird
    That's the thing @glijie I am at home AND connected to the same wifi as Homey. That's why I find it so strange!
  • bvdbosbvdbos Moderator, Backer - Geek Edition
    @Jon, you might want to try different portnumbers. Do you have a strict firewall on your router?
  • My router has a 5Ghz and 'normal'  wifi radio. Should all devices be on the same wifi radio? 
  • JonJon Backer - Super Early Bird
    @BasVanDenBosch AFAIK there's nothing unusual set in my router. 
    But I could try different port numbers, but what do you mean exactly by that? Didn't really get that. Should I allocate my phone to a different port number in my router setup page? 
  • Jon said:
    That's the thing @glijie I am at home AND connected to the same wifi as Homey. That's why I find it so strange!
    and has your phone a fixed IP?

  • Eternity said:
    My router has a 5Ghz and 'normal'  wifi radio. Should all devices be on the same wifi radio? 
    ik have the same and here it doesn't matter
  • JonJon Backer - Super Early Bird
    Yes I gave it a fixed ip. 
  • Fire69Fire69 Backer - Geek Edition
    Smart Presence works by detecting ports on your phone.
    Some phones don't work with the default port (Windows Phone for example), so try setting another port (default is 32000), it might work then.
  • JonJon Backer - Super Early Bird
    So how do I do this? I'm on a android phone (Sony xperia). Do I set this in my router? 
  • Fire69Fire69 Backer - Geek Edition
    No, in the settings of the Presence app.
  • JonJon Backer - Super Early Bird
    Okay @Fire69 but there's so many ports I could try. How do I find out which ports might work? 
  • JonJon Backer - Super Early Bird
    edited January 15
    By the way: my wife's iPhone seems to work flawlessly with smart presence. 
     
    As for my own phone: I just rechecked my phone's mac address in my router just to be sure I have the ip address correct. This was indeed the case. 
    Really strange! 

    EDIT: not so, cheering too early. Same issue with my wife's iPhone.
  • MennoMenno Member
    edited January 15
    Also had problems with eiphone model 5C (mg8x2dn/a) 
    Looked like when it was in locked mode / not used it was loosing it's connection

    <<<<edit>>>>

    And indeed windows phone was totally not working
  • @glijie
    Thanks you Sir
  • JulianJulian Backer - Homey
    edited January 15
    I had these issues also with my wife's (older) iPhone that it would lock up and thus would not work anymore.

    I changed some (standard?) settings and since then it works 100% (beside the one time I had to click on 'save settings' :wink: )

    These are 'my' settings:

    And for the user:

  • JonJon Backer - Super Early Bird
    Okay, @Julian, so when I change the host timeout to 2 seconds  (instead of the standard 3 seconds), my phone is displayed as 'present'. It seems to be fixed: hip hip hooray...!
    Until.... you switch off your phone's wifi or put it to airplane mode, and it will still display the phone as 'present'.  So apparently, it still does not work?!?
  • JonJon Backer - Super Early Bird
    By the way, here's a screenshot of what smart presence's log says:


  • JulianJulian Backer - Homey
    Did you also change the setting at the user (second screenshot)? That is the time it takes before it changes to away.
  • JonJon Backer - Super Early Bird
    edited January 16
    I left it to the (default) 900.
    I have now changed it to 60 and am testing it right now.
    Is this unit in seconds, milliseconds, or what else?
    EDIT: works perfect now. Saw that it's seconds, so after 1 minute it will display me as 'away'. ;) Thanks @Julian !!
  • JonJon Backer - Super Early Bird
    I still get a problem with my wife's iphone and smart presence. Because of the notorious wifi disconnection issue of iOS it will notify the iphone home/away every minute or so.
    Even though I have increased the 'absence delay' (afwezigheidsvertraging) to 900, the problem persists.
    Does anyone have the solution to this issue?
  • JulianJulian Backer - Homey
    As said I had the exact same issue (wife + old(er) iPhone) and for me it worked when I set the delay time to 600 seconds instead of 900. Did you already try to reboot Homey after changing the settings just to be sure? With a delay of 900 seconds the disconnect after one minute indicates that the previous setting of one minute is still active? 
  • JonJon Backer - Super Early Bird
    hi @Julian thanks. It seems that the changes only take place after a reboot (or after deleting a user in smart presence and re-adding afterwards). So it seems to work now.
    Another question: does the delay of 900 imply that Homey only knows that this phone is away after 900 seconds, so the accuracy is becoming much less when the delay is increased? Do you know about that?
  • JulianJulian Backer - Homey
    Yep, that is correct. You have to be away for that amount of seconds before it changes the state to away. 
  • JonJon Backer - Super Early Bird
    That's a bit of a bummer. Keeping track of all housemates with iOS devices is very inaccurate then :(
  • ThijsDeJongThijsDeJong Backer - Homey

    When you combine that with "tracker" and a Geo Fence, it (could be) quite accurate.


Sign In or Register to comment.