Welcome to the Athom Community Forum! This is a place to share ideas, ask for help and discuss about Homey in general.

Please read Welcome to the forum to get started.

Nodon Soft Remote not working anymore

Have had Soft Remote working perfectly for some time, but stopped working today (caused by version 1.0.3?). Exclusion/inclusion all works, device reacts on change LED behaviour via config in Homey, etc, but button presses do not lead to any reaction. Factory reset of remote, reboot Homey have no effect. Testing flows in Homey app function shows desired behaviour. It's really a problem for me, since in part light switching in my house relies on this powerfull device. 

Comments

  • Same problem, after the last update (1.07 i think) my octan remote doesn't work anymore.
  • dhanstede said:
    Same problem, after the last update (1.07 i think) my octan remote doesn't work anymore.

    sorry, last update is 1.03
  • casedacaseda Moderator
    Woops, that is my mistake, made a decision I did not think of properly what it would cause.
    fix is waiting for approval as we speak.
  • anneanne Member
    I ran into the same issue with a Nodon wall switch. I am glad to hear you have the fix ready to go, looking forward to it :-)
  • Same for my Nodon wall switch here...  :'(
  • casedacaseda Moderator
    Fix has been published to the app store and your devices should work again ones it is installed.
    You might need to reboot your homey once.

    If the reboot does not work, don't be shy to let me know and will look at it as soon as possible.

    Sorry for the inconvenience! 
  • caseda said:
    Woops, that is my mistake, made a decision I did not think of properly what it would cause.
    fix is waiting for approval as we speak.

    i have updated to 1.04 and reboot homey, but my octan remote doesn't work. Also i have repaired the octan remote, but it is not working.
  • casedacaseda Moderator
    yeahh... was hoping to do a quick fix without having to do a full debug, since i could only do that this evening... but the quick fix was not enough unfortunately. :s

    i did however fixed it now fully, no re-add is needed and should just work, without any reboot necessary.
    this fix also includes battery (level) flow triggers, you will have to re-pair it to get the flow trigger card.
    but it's not needed for the functionality otherwise
  • :) :) caseda said:
    yeahh... was hoping to do a quick fix without having to do a full debug, since i could only do that this evening... but the quick fix was not enough unfortunately. :s

    i did however fixed it now fully, no re-add is needed and should just work, without any reboot necessary.
    this fix also includes battery (level) flow triggers, you will have to re-pair it to get the flow trigger card.
    but it's not needed for the functionality otherwise
    Thanks for the quick response and action.  :)
  • Is there any stable version yet? I updated to 1.04 but my wall switch still doesn't work anymore.
  • casedacaseda Moderator
    @uniekwerk
    fix has been waiting approval now for almost a day now, so not up to me anymore unfortunately until it is accepted in the store
  • Thanks for the effort! Hope it'll be released soon!
  • @Annemarie please release this fix. We've got useless buttons now.

    And thanks @caseda
  • Thanks for the quick fix  @caseda

    @Annemarie ; approval proces takes to long. We have useless buttons for 2 days now.


  • casedacaseda Moderator
    For those who had not noticed yet, the update (1.0.5) has been accepted into the appstore this evening this wil fix any/all your issues.

    it will update automatically, but for those who have that unchecked, the update is here.!

    sorry for any inconvenience it caused.
  • @caseda, thanks. I added a fibaro door sensor to turn on the lights so I didn't need to shower in the dark.

    I notice that the door sensor immediately turns on the lights. Instead of what we already talked about on slack, the nodon has a delay or doesn't work at all.

    I also noticed the battery state was updated when I pushed the button. Maybe something's wrong there.
  • casedacaseda Moderator
    @NPeters the battery report is wanted behavior and is send to homey along side the button push and both do come in.

    The remote send power can be lower once the battery drains more and more, the battery level shown is not always representative to what the real level is, it starts from 100% when you re-pair it. Even if it is not 100%

    the delay is something I noticed as well but that is always been the case of the remotes and is not something I can change. 

    I'll see if I can speed it up a little with a change I had in mind, but don't expect too much more speed. 
  • @caseda thanks, but it's weird that a door sensor from fibaro always works immediately don't you think? Both are battery powered and in the same room...
  • casedacaseda Moderator
    edited January 15
    @NPeters
    it is the command class that the nodon remote uses, it is generally known that it is a slower kind of command, and also since it needs to wait if you pressed 1, 2 or 3 time, if this timeout (wait time) is reached it will only then send the signal.
    the door sensor does not have to wait for this timeout to be met before sending the command
  • Can anyone help me on (possibly) the same issue?

    My Soft Remote worked fine running firmware 1.1.1 - quick response and no complaints.
    After several firmware updates my Soft Remote only spuriously responds. Current version is 1.3.2
    I excluded the Soft Remote, but re-inclusion does not work any more. I simply get no response from HOMEY at all. Has anything changed? My Soft Remote hasn't as far as I know.
    Thanks.
  • bvdbosbvdbos Moderator, Backer - Geek Edition
    Did you try to reset the device?
    http://nodon.fr/support/NodOn_TheSoftRemote_ZWave_UserGuide_EN.pdf
    Otherwise could you file an issue at https://github.com/caseda/com.nodon ?


  • CyberSponkCyberSponk Member
    edited June 30
    Got 6 of NodOn SoftRemote > All working fine.
  • anneanne Member
    I had exactly the same or at least very similar issues with my NodOn wallswitch. It worked fine for months, then started to respond poorly (2.7 m from Homey, line of sight). After removing it, re-pairing didn't work, even centimeters from Homey there was no response. The reset procedure didn't work either, not once. Battery status was fine according to the device (green LED, so > 50%), and replacing the battery made no difference.

    I had it RMA'd, but initially the new devices wouldn't pair with Homey. After replacing the battery (measured at 2.96V, replaced for one that measured 3.08V) I was able to pair the remote with Homey (note that during this process I was able to do a factory reset on the switch exactly once). However, regardless of the distance from Homey it would not respond reliably, it needed a 'wake-up' push every time before responding. I ended up sending it back and replacing it with a Remotec remote which works flawlessly.

    In between I also paired 4 Neo Coolcam door sensors without any problems, and they operate without missing a beat from far greater distances, it seems something is definitely wrong with the NodOns. 
  • Quit often homeys reaction to my nod on soft remote is very slow.  I press one of the buttons to activate a flow to switch on a z-wave controlled light and the led on the nodon flashes blue. Then nothing happens. In some cases (maybe always, I can’t tell because often I choose to switch on the light using the button directly on the z-wave device) after several minutes the light switches on. 
  • casedacaseda Moderator
    edited October 11
    Soon(-ish) I will start on a rewrite to SDKv2 that might increase stability.
    The rest is not app related, so I can't change anything in that, and needs to be addressed by athom.

    It might be related to a bug that is going around at the moment with zwave, even though that let's a certain device (type) not respond at all for several minutes/hours (even days) which athom is actively trying to find.

    But it can also be outside interferences, like non zwave but working on the 868mhz band devices, or a wall that lowers the signal so that it needs to be routed several times, and a lot more that is the case.

    Please don't just say "it is slow" next time try giving a bit more info, like the situation, or at least the zwave log (settings - > zwave - > stuff for geeks)
    With real-life time stamps next to it.

    With no added information your just adding another nail to the pile
    Like going to the garage without your car and saying that the wipers don't work
Sign In or Register to comment.