This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Support Fakro ARF/ARP Z-Wave

Hi All,

I'm the developer of the Fakro App. I want to support the ARF/ARP  ZWave device (I don't own them) but I can't find the ZWAVE productId and the ProductTypeId. 

Can someone deliver me that information?

Thx in advance.



  • Anyone please ?
  • JonJon Member
    @kludon perhaps if you email Bram Koller from Fakro Nederland (bramk { AT }
    Otherwise you might try contacting them by phone to see who's a developer that might help you out?

    De Ren 34
    6562 JK Groesbeek
    T. 024 - 39 78 095

  • JonJon Member
    Otherwise; are the product(type)ids to be found on the physical products? The I could look it up for you, if you let me know where they are mentioned...
  • i found this on pepper1:

    Product Type ID:0x0003
    Product ID:0x0001

    Product Type ID:0x0016
    Product ID:0x0001
  • Thx Stomen, that Pepper is a great source for zwave device. But I can't find the zwave information for the fakro arf zwave or does they use the zwrs module?
  • i don't know. Sorry i thought everything of Fakro would be there. But it is not.
    I don't have a ARF/ARP with z-wave , so i can't help you with that. 

    I do have a ZWE230 with ZWS12, if you ever need someone to test that..
  • kludonkludon Member
    edited October 2016
    Hi @stimien I Have updated my fakro app to v 0.0.3. it now had zws 12 and zws230 support. Could you please test these for me because I don't own them. Thx in advance
  • Hi @kludon, I tried to pair with my sws230, but it didn't work. 
    I've got this message: manager.vdevice.drivers.zwavebasic.pair.invalid_capability.
    I'm on homey version 0.10.3
  • @stimien I think I have found the problem. I' ve uploaded V0.0.4 to the appstore. Hopefully it will be approved soon.
  • @kludon. i've got the same result with the v0.04 version.


    I am now on Homey version 0.10.7.
    After adding the device, it gives an error. But the device is connected to homey, i need to remove it from homey before i can try it again.

    Do you need more info or can I take a look somewhere to find out what is going wrong?

  • @kludon
    i've find the problem. It was with the capabilities and the class.
  • Hi @stimien, Thanks! I've replaced the files in my repository. V0.0.5 is now pending for approval by Athom. 

  • 0.0.5 has been approved!
This discussion has been closed.