This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Fibaro Smoke Sensor (V2)

ThorarinThorarin Member
edited May 2016 in Archive
Has anyone had any luck getting the Fibaro Smoke Sensor V2 (FIB_FGSD-002) to work with Homey?

Adding the device does not appear to work normally. Homey continues to show the progress animation for me. When I eventually close the window, a Z-Wave device has been added, but it appears as a wall socket symbol. Clicking the little sliders icon on the newly added device just gives me another eternal progress animation in a popup window.

I've tried with the latest stable Homey version (0.8.29 I believe) as well as 0.8.32, no luck with either.

The Chrome console log shows several errors:
  • WebSocket connection to 'ws://' failed: One or more reserved bits are on: reserved1 = 0, reserved2 = 1, reserved3 = 1

The error message leads me to believe that it is related to the device mistakenly being recognized as a wall socket thingy?

Now logged on GitHub (#588)


  • casedacaseda Member
    It becomes a "normal wall socket" or better called an "on or off" device, if something goes wrong during the interview of the device with homey.
    You could try again, after you delete from homey and reset the Smoke Sensor.
    Or wait until Z-Wave becomes more stable.

    I have a pair of Fibaro v2 Smoke Sensor's but have not tried to add them yet.
    Just using them as a normal smoke sensor at the moment until Z-Wave becomes more usable (for this kind of stuff)
  • ThorarinThorarin Member
    edited May 2016
    Definitely something seems to be going wrong with the interview. I've tried it several times now, always with the same result. Homey shows nothing but the Node ID and a checkbox that the device is working in secure mode.

    I'm pretty sure someone mentioned success with the Fibaro smoke sensor on this forum, but it was unclear whether that was V1 or V2. I think my firmware may be version 3.3 as well (the sticker on the box says V3/3 EU), so it may be similar to this issue if the firmwares are similar for multiple Fibaro products.
  • casedacaseda Member
    It is definitely a Z-Wave+ (plus) chip thing with homey that gives a lot of troubles.

    This includes the Fibaro Motion Sensor v3.2, but also the Aeotec 6 Multi Sensor, which are all commenly used Z-Wave+ devices
  • Had the V2 running. Included it next to Homey and pressed the button on the middel in order to make sure the sensor is online and not sleep-ins during the interval. Afterwards set a few parameter in order to report temperatur in desired interval.
  • gerbenzgerbenz Member
    I have fibaro smoke sensor v2
    and it is working on fw 0.8.32
  • mruitermruiter Member
    Had the v2 s running. have 5 of them, but as of firmware .32 they stopped wrking.
    Can add them without a problem, but they dont react to anything anymore.
    Have a nice smoke fire temp and temper alarm but they never get triggerd.

    Dont forget to fully reboot your homey before adding a device. It just how it works at the moment :)
  • Thanks for your suggestions regarding rebooting and such. Unfortunately it did not make any difference for me.
    I've created an issue on GitHub (#588) for completeness' sake.
  • Fire69Fire69 Member
    Received mine today.
    On adding it the first time, I got stuck on the interview.  I cancelled it and an unknown node was added.
    I removed it and tried adding it again, this time it worked ok and was detected as a sensor.
    But when I try to open the card, it stays blank.
    Chrome console shows me this error:

    In Insights I do get the temperature feedback.

This discussion has been closed.