This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

5th Generation Fibaro Multisensor (v3.2, Z-wave plus)

ZperXZperX Member
edited April 2016 in Devices
Hello guys,

The 0.8.30 firmware has fixed the pairing issue of the v3.2 Fibaro sensors . However not all of them can communicate with homey after pairing/reset/restart/data parameters/wake up. Some people has managed to make it work but others using the same settings can`t make it work. I have exchanged couple of emails with Stefan who confirmed that they know about the issue, the new chip uses secure communication. I thought it would be kind and helpful to share it:
I just got word from our Z-Wave engineer that this is a known problem on our side. To make the sensor work...
1) remove the sensor from Homey
2) wait until your firmware version is > .30 (we are releasing an update soon)
3) add the sensor to the network again
4) done - you don't have to set associations no more.
So don`t have to wait long for the official solution, but of course you can keep trying if you wish.


  • JanHJanH Member
    @ZperX "The truth is that none of those are from the latest generation...."
    As already mentioned in other corners of this Forum I could add the Fibaro Multi v3.2 with Homey 0.8.30.
    The diffferent sensors are working for me for about a week now.
    Being honest, there have been some complications, but trial and error with the data parameters and, more effective, with the wake up interval was quite effective.
    Maybe relevant, but I am not able to check that, is that I did NOT check the securebutton. It seems to be that unchecking after checking is not possible without a complete removal of the device.
  • ZperXZperX Member
    edited April 2016
    Just to clarify I have never checked the secure option. I was not given that choice. And yes I am quite familiar with the data parameter.
  • casedacaseda Member
    edited April 2016
    @ZperX ;
    It is not possible to add firmware v3.2 to an v2.5 - v2.8 sensor.
    v3.2 is Z-Wave plus only, which is a new (and thus completely different) chip inside the sensor.

    And i guess you are indeed familiar enough with the parameters,
    because you can active/deactivate the secure setting Only with the B-Button, and not parameters.
  • Thats actually a very good hint. I was looking though the manual and havent found anything how to deactivate the secure setting by pushing the B-Button. Could you please help? P.S. Yes... I am new to z-wave. :)
  • @Vagabond ;
    Hmm, i guess i misread it somewhere..
    As it seems you can not take off the secure tick with the B-Button..
    As in, you can not take off the secure completely.

    There is, however, a Parameter for them
    Parameter 18: Associations in Z-Wave network Security Mode
    0 - off
    1 - Group 2 Secure
    2 - Group 3 Secure
    4 - Group 4 Secure
    8 - Group 5 Secure

    Values not stated in the manual:
    3 - Group 2&3 Secure
    5 - Group 2&4 Secure
    6 - Group 3&4 Secure
    7 - Group 2&3&4 Secure
    9 - Group 2&5 Secure
    10 - Group 3&5 Secure
    11 - Group 4&5 Secure
    12 - Group 2&3&5 Secure
    13 - Group 2&4&5 Secure
    14 - Group 3&4&5 Secure
    15 - Group 2&3&4&5 Secure

    (13 and 14 could be switched)
  • JanHJanH Member
    edited April 2016
    @caseda Tnx for this annex to the manual! I like to add that in the manual at par. 18 is mentioned that those values only can be choosen when the overall secure state is checked as secure. So does that mean that Homeyans with the problem NOT to be able to uncheck "secure" (without complete reset of the device) they could go via par. 18 value 0?
  • @JanH ;
    Not necessarily, Group 1 will always be Secure in the Secured mode, even when parameter 18 = 0

    Sorry, i forgot to add that to the parameter 18 explanation.
  • JanHJanH Member
    @caseda, you're completely right, thus for the Homeyans with Z-wave output problems I think the advise should be: complete reset of the device, pairing at Homey again, and leave the secure button unchecked. Could you, as a far more experienced z-wave user, agree with that?
  • Lol, more experienced, i've only touched z-wave for the first time since last Tuesday (so almost a week now).
    Just a fast learner and i find it easy to put 1 and 1 together.
    But i do agree with you that until homey their Z-Wave firmware has been more matured.
    keep it as simpel as possible with Z-Wave.
  • It seems the problem is that it is (at least not for me)  not possible to check or unchecked the secure tick. Tried to switch to non secure mode by putting parameter 18 = 0. Generall it seems that additinal parameters are not communicated from Homey to the sensor and it seems the rote cause is the secure button.
  • casedacaseda Member
    edited April 2016
    @Vagabond ;;
    It should be possible when you are adding it as a device.

    (so you need to delete it first, reset the sensor and then while adding there should be an option.)

    You are not able to unchecked it afterwards.
    This is with every controller (for security reasons of course) 

    I am not fully sure though.. I have not seen the add pop-up for the 3.2 version
  • ZperXZperX Member
  • TedTolboomTedTolboom Member
    edited April 2016
    @ZperX thanks for the movie showing the inclusion of a v3.2 sensor... 
    Two observations: 
    - With the v3.2 sensor you do not get a dialog to add secure or non-secure (not able to change afterwards)
    - With the v3.2 sensor you also do not get a dialog to set the "report to association group" group number

    For the latter, this is the only way to make sure that the sensor reports are send to the right main controller.
    Adding it later on (via settings) is still buggy... this might explain the issues with the inclusion and data reporting of the v3.2 sensor 

    I would suggest to also add this to you Github issue #515
  • TacoTaco Member
    The secure checkbox is a read only setting. It shows you whether your device is included securely or not. You only get the question which association should be made for non Z-Wave Plus devices. For Z-Wave Plus devices always an lifeline association on group 1 is made.

    The notification command class is complete for the multisensor on version 0.8.31.
  • JanHJanH Member
    @Taco I hope I did understand you well? Because last week when Homey (0.8.30) arrived  I was able to pair a new Fibaro Z-wave Plus multisensor with v3.2  without checking the securebox. As you can see at the attachment it is still (only once!) possible to check it. Afterwards it cannot be unchecked. I am still wondering what the effect and differences in behaviour are with checked/unchecked. Do you know?
  • ZperXZperX Member
    - With the v3.2 sensor you do not get a dialog to add secure or non-secure (not able to change afterwards)

    Yes that was my point. Folks here were keep telling that don`t tick the secure option. This video is for them and for those who think they have accidentally selected that option.

    I had a second part of this video where I have showed that the settings are not sent to the sensor as there is no communication so does not matter what you set at #18 parameter (eventually I cut that out from the video because it was too long)

    @Taco Thank you so much for confirming this.
  • TacoTaco Member
    @JanH It is possible the sensor is added unsecure. This happens when something unexpected happens during the secure inclusion. When this happens you get a popup in the pairing wizard.
  • ZperXZperX Member
    Now I can be released from mental care... :smile: 
  • JanHJanH Member
    ZperX said:
    Now I can be released from mental care... :smile: 
    And I just made an appointment with my psych  :D
  • Taco said:

    The notification command class is complete for the multisensor on version 0.8.31.
    I think we have a winner, and the reason why all of our sensors are not sending their lux/temps and all other viable things we just want to know of our sensor, were send correctly to homey.

    It was not because of problems with the parameters not being send by/to homey, it is because all sensor's send their lux etc via notification protocol to homey, instead of the already implemented Binary.!?

    Could you confirm this @Taco ?
  • TacoTaco Member
    Only motion and tamper are send through the notification command class. Temperature and luminance use the multilevel sensor command class by default.
  • ZperXZperX Member
    The 0.8.32 firmware havent fixed this. Although the secure option is not forced any more there is still no communication either way.
  • How do you managed not to have the secure option? I tried to pair it several times, but always secure and not choice to untick it during pairing. Nevertheless it seems to work better. I see now tamper, motion, lux and temperature alarm immedietly. Tamper and motion works great. Still the same issue as you; parameters seems not to sent to the Sensor. Therefore Lux is only sent when changes appear (but that work fine) and for temperature I am trying to figure out when it is being sent....
  • ZperXZperX Member
    Definitely not working. The ambulance and the sedative is on its way they are taking me back to metal care.

    So first try: No security option but the issue was the same: Homey was not receiving values, sensor not receiving settings.

    2nd try: Security option selected by default (and beyond this point it was always selected a grayed out). However homey was receiving values. Alerts were cancelled in due time. Had some figures in the insight, though not everything. So I have restarted homey. After that no response.

    3rd, 4th, 5th, ......Nth try. Various issues every time:

    Homey has been been restarted after every un-pair, Z-wave network reset. Sensor was also reseted, battery removed. The distance between the Homey and sensor is still the same. And I have 3 sensors, so it is not a product fault.

    So what is it? Is it a conspiracy or a solar flare?

    The ambulance is here.
  • edited April 2016
    Here also an issue with adding Fibaro Motion Sensor. This is about adding / pairing the device. Send the log to Athom: Log ID 4BC401BF46. Hope this can help them solve these pairing issues.
  • Did someone manage to get the Fibaro multisensor with Z-Wave plus (=not the old Z-Wave non-plus version) working correctly with Homey?

    I'm asking because I want to buy one but only if Homey is developed so far it supports the Fibaro sensor..
  • markmgmarkmg Member
    thayoung1 said:
    Did someone manage to get the Fibaro multisensor with Z-Wave plus (=not the old Z-Wave non-plus version) working correctly with Homey?

    I'm asking because I want to buy one but only if Homey is developed so far it supports the Fibaro sensor..
    Yes the Fibaro multisensor Zwave plus, works over here. (unsecure)

  • ZperXZperX Member
    edited May 2016
    Yes I can also confirm that since 0.8.34 firmware the 5th generation sensor works. I have the 0.8.35 now and no issue apart of the terribly bad range. There is still some data loss but it is not that significant now. And if I change the motion sensor settings (particularly the cancellation time) than the motion alert is never cancelled. Also the night mode does not work for me. However I am not sure if this is a Homey or Fibaro issue.
    I hope the complete Z-wave rewrite will sort the range issue. 
  • Thanks for your confirmation @JanH and @ZperX.

    Yesterday I received my Fibaro sensor with Z-Wave+. It's working.

    Only difference is that I don't see the 'Generic Alarm' and 'Battery' options. Any idea why?

    My Z-wave configuration;

Sign In or Register to comment.