This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Fibaro RGBW - White channel

honeyhoney Member
edited September 2017 in Devices
Hi all,

Maybe I am missing an obvious thing but how can set the RGBW controller to provide power to the W channel only (in flow editor)? I have a RGBW tape and would like to use white channel only (when reading a book).


  • @honey flow card
  • Just add the RGBW to the then column and flip it until you can choose the individual colour.. 
  • No the colour card is not an option. For white it uses the 3 channels (Re, Green, Blue) instead of the White channel.
  • casedacaseda Member
    edited September 2017
    @honey there is a flow card to set individual outputs, including the white one

    You can also choose to set a color temperature, I created the driver so this is possible, even with rgb and rgbw strips connected
  • honey said:
    No the colour card is not an option. For white it uses the 3 channels (Re, Green, Blue) instead of the White channel.
    Check in the settings if you have selected the LED strip type as "Red, Green, Blue and White"
    Else, it will not show white channel in the flow editor.

  • I think what @honey wants is a "scene" but not directly possible in the Homey you need a Virtual Device (From the Virtual Devices App) then you create a flow that handles the "Scene" like you can see here..

  • Thank you for the effort in helping me. Still does not work.


    If I run this, I get no light at all:

    If I run this, the white card never get the green thick (is it a bug?), everything remains dark:

    Everything is wired correctly, with an old firmware (like a year ago) and phone app I could control the white separately but not anymore.
  • casedacaseda Member
    edited September 2017
    1. You don't have to turn it on before hand, that might even cause the weird behaviour you are having
    2. You first set the red channel to max(?) and after that the red again to probably off(?)
    i don't think that is going to work, i would change the first red channel to white channel
  • Initially I tried it without the turn on card. Same result.
    I have tested the channels individually. RGB works, white not.

    Yes the screenshot is `incorrect`. That is other weird bug I wanted to talk about.  After running the test Homey changes the colour of those channel cards. The last card was the white card. The original order was Red 0%, Green 0%, Blue 0%, White 100%. After running the test it has been shifted: Red, Red, Green, Blue.

    Does anyone have RGBW tape?
  • casedacaseda Member
    edited September 2017
    I use 2 rgbw strips myself without any issue, also 2 (1 version 2x) other versions where both of them use also the white channel (color temperature strips, and only white)

    Did you change any device settings perhaps? Try re-pairing it so it is fully stock again
  • I also have 2 RGBW - No issues at all - maybe its broke - like @caseda mention - try unpair / pair - or put a multimeter on from Ground to +12v and see of you notice a change

  • honeyhoney Member
    edited September 2017
    Thanks for your help. I have removed the device and re-added that sorted the misbehaviour.
Sign In or Register to comment.