This is the forum archive of Homey. For more information about Homey, visit the Official Homey website.

The Homey Community has been moved to

This forum is now read-only for archive purposes.

Poor range Somfy RTS



  • I'm sure they will find a solutions. Especially when they have found the issue.
    Great work @Reinier!
  • @d3rax dont worry too much, we already got the solution and are currently working on implementing it
  • Taco said:
    @JurgenVanDeRijke If you select it in the dropdown and press the Refresh Node button Homey will try to reach it. If it fails, the node will be placed in the so called failed node list. Then you can remove it by pressing the Remove Failed Node button.
    Taco, maybe you could show somehow which devices are in the failed list and which not. Show it in the drop-down somehow, and in the devices-section (or is already showing that there?).
  • Great suggestion!
  • honeyhoney Member
    edited February 2016
    you tune the frequency via the firmware? Will this change affect the range of the KAKU, etc devices or will you use two separate frequency? (433.92MHz and 433.42 MHz)
  • If that would work, it could also switch between frequencies (listen on 433.92 for .5 sec, switch to 433.42, back, forth etc etc)?
  • @honey ;
    After the problems we faced with the somfy devices we've decided to implement that. You can now define a base frequency for every  transmit protocol which will most likely solve the  somfy issue. Most of the devices we've implemented were aligned on the 433.92Mhz frequency so there was no need of shifting the base frequency. 

    @BasVanDenBosch ;
    In theory this should work. in practice this will result in unstable reception.

  • Reinier said:
    In theory this should work. in practice this will result in unstable reception.

    Somfy does not send signals (apart of the remote but that will be partly obsolete when the blind gets automated). So homey could be tuned to 433.92Mhz to make sure that it receives everything from door sensors, wall switch, DIY dry contact transmitters, etc and it would tune to 433.42MHz for example 10x500ms a day when it sends signals to the blinds. That would not really affect reliability of the reception. Would this be possible?
  • @honey ;
    that's exactly what we're doing right now ;) every app defines a protocol and a base frequency for that protocol. In the case of somfy the basefrequency will be 433.42Mhz.
  • After several tests we now can confirm that we've solved the range problems. The fix will probably be patched in 0.8.19.  
  • Awesome. That was something I was worried about, that this might be a hardware issue. So glad that you got it fixed!
  • really good news, keep up the good work.  :)
  • Is this issue sorted with the new 0.8.20 firmware?
  • edited February 2016
    Just installed 0.8.20 .. tested Somfy to get a paired RTS device.. switch RTS to pairing mode... not able to learn remote signals.. even the second option .(pops up if your RTS device does not respond to Homey during installation of device) .. doesn't give any solution. Unfortunately I am still stuck with 14 RTS devices unable to control with Homey :'( .

    Homey developers. (@Reinier)).: If I can help please just send me an pm. As already mentioned no issues with Somfy remotes and Homeward. As I have no ability to look at log files.. debugging is impossible.. 
  • ReinierReinier Member
    edited February 2016
    @JurgenVanDeRijke ;;
    I'm aware of a bug which causes communication issues with the mcu, the problem arises on some homeys. have you also tried to pair or control other remote switches/remotes? Have you already tried to turn it off or on again?
  • edited February 2016
    @Reinier ;;;
    Thanks for your swift reply. I have successfully connected KAKU, Elro, Z-wave devices. I also powercycled the device. All without a solution. Is there a way I can look at some debug info? 

    Update: (@Reinier ): After trying to pair a RTS screen KAKU devices aren't working anymore (need to check Elro). Power cycle the Homey revives the KAKU devices
  • @JurgenVanDeRijke ;
    Found the problem! The Somfy app has not been updated yet. I expect it will be updated today ;) 
  • ReinierReinier Member
    edited February 2016
    I've just want to let you guys know that the Somfy app has been updated. It should now be possible to communicate with somfy devices if you have version 0.8.20
  • But stil no memory stand. 
  • can others conferm that the distance problem has been solved? 
  • @Reinier:
    Great work. We moved a little further, but not there yet. 
    1) I am able to pair a RTS screen (excellent!)
    2) Control of the device is only possible after a powercycle ....needs work.. KAKU also stops working 
    3) After the powercycle I could move screen down.. stop ... and after that nothing.... KAKU also stopped working
    4) powercycle.. KAKU back.. Somfy works twice (could move down and up) .. and everything is blocked again (433 devices I mean)... so also KAKU blocked

    Hope this helps in moving forward. Almost there :)
  • @JurgenVanDeRijke ;
    Thanks for your feedback ;) I'm currently working on some stability issues. it looks like i've fixed the problem.
  • Reinier said:
    @JurgenVanDeRijke ;
    Thanks for your feedback ;) I'm currently working on some stability issues. it looks like i've fixed the problem.
    Just for the record, the specific Somfy issue or also the KAKU?
  • mruitermruiter Member
    edited February 2016

    Can confirm that my homey has good communication with the RTS (after a reboot offcourse), but KAKU dies and does not come back to life aka Walking Dead

    Have to reboot and then kaku works for some time but Always seems to day in hours a day. But when i use RTS i now for sure it will shoot dead the KAKU

    @JurgenVanDeRijke , i will try the update when i get home around 7pm and let you know, just put it online  :)

  • edited February 2016
    Reinier said:
    @JurgenVanDeRijke ;;
    Thanks for your feedback I'm currently working on some stability issues. it looks like i've fixed the problem.
    Reinier, looking forward to your solution. As mentioned before KAKU is influenced by Somfy app. As mruiter I also loose KAKU after some time... I removed the Somfy app hoping that would fix it, but unfortunately this wasn't/isn't the case.
    I also noticed that when I tried a voice command .. Homey doesn't respond .. and it also kills KAKU. Maybe it is more general 433 issue? 
    After you make the update available I will work out some test sequences to see if everything is working and keeps working (like KAKU which drops after some? time or when a certain action is performed). I noticed that a flow with a KAKU action is executed (without the actual KAKU action) so it doesn't kill that flow. 
    Maybe I need to add a new thread regarding 433 issues (like Somfy, KAKU).

    PS. I also noticed the KAKU is only working again when really powercycle the Homey (reset doesn't do the trick) 
  • JonJon Member
    @Reinier Are the range issues for Somfy RTS back? I am on 0.8.29 and latest version of Somfy app and there is just no way to pair the RTS motor with Homey. After pressing my Somfy Telis pair button (with a pencil point), nothing happens. Also when pressing 'Next' simultaneously with the pair button. It is, by the way, not clear if you should:
    - first press the pair button, then the Next button
    - press both buttons simultaneously.
    But as I said: none of the pairing attempts worked.
    Homey is, btw, about 6-7 meters away from the RTS motor.
  • JonJon Member
    @all and especially @Reinier. Turned out that a full reset of my Somfy RTS motor did the trick and after that Homey did a succesfull pair with the Telus 1 remote. To my nice surprise, I must say.
  • JaxcJaxc Member
    Somfy broken with 0.8.30 update??
Sign In or Register to comment.